Can't change ip address on Dynalink DL-WRX36

I am trying to set up my DL-WRX36 as a dumb AP, but it's failing at the first step--changing the static IP address on the lan interface. It wants to stay at 192.168.1.1 no matter what I do. I have tried changing it in Luci and also by editing /etc/config/network. It always fails and I have to use the Reset button to get back to something I can communicate with.
I am currently accessing the router by ethernet with the wifi turned off on the laptop; otherwise, of course, I would get my main router instead. Same thing would happen if I went ahead and replaced my old AP (192.168.1.2) with the DL-WRX36.
I have seen advice on clearing the browser cache...no luck. Same for using a different browser. I have upgraded the router to the recent stable release.
This has cost me a few hours, so I'd really appreciate finding a solution.

Can you show

ubus call system board

from your router?

If nothing else helps you can always edit /etc/config/network and replace 192.168.1.1 with anything of your liking and reboot router.

{
"kernel": "6.6.73",
"hostname": "OpenWrt",
"system": "ARMv8 Processor rev 4",
"model": "Dynalink DL-WRX36",
"board_name": "dynalink,dl-wrx36",
"rootfs_type": "squashfs",
"release": {
"distribution": "OpenWrt",
"version": "24.10.0",
"revision": "r28427-6df0e3d02a",
"target": "qualcommax/ipq807x",
"description": "OpenWrt 24.10.0 r28427-6df0e3d02a",
"builddate": "1738624177"
}
}

I have tried editing /etc/config/network, but it was the same result

Did you return client to dhcp after flashing openwrt?

Does this method work for you (CLI and LuCI methods are described)?

https://openwrt.org/faq/change_lan_ip

If not, please post your current /etc/config/network file.

No, those methods don't work. Here is the /etc/config/network after resetting the router.

[quote="MT-BEE, post:7, topic:227307, full:true"]
## This is what comes up after resetting.
Should I change that bit near the bottom?

## config interface 'wan'
option device 'wan'
option proto 'dhcp'

config interface 'loopback'
option device 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config globals 'globals'
option ula_prefix 'fd6d:d494:8376::/48'

config device
option name 'br-lan'
option type 'bridge'
list ports 'lan1'
list ports 'lan2'
list ports 'lan3'
list ports 'lan4'

config interface 'lan'
option device 'br-lan'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'
option ip6assign '60'

config interface 'wan'
option device 'wan'
option proto 'dhcp'

config interface 'wan6'
option device 'wan'
option proto 'dhcpv6'
[/quote]


```Sorry about the formatting. I'm flying blind here.

You can not have IP address inside dhcp pool, then dhcp server will not start
ie x.y.z.100-250 by default

Trying to understand (bear with me).
I am trying to change the IP address of a router connected directly to my laptop by ethernet. The laptop is not connected to my network (laptop's wifi is off). This seems like a "neutral" network environment, but I must be wrong about that.
Since my cable modem is 192.168.100.1 and I can connect to it just fine, I tried setting the router's IP to 192.168,100.2, which also failed. (It becomes unreachable until I reset it, at which point it reverts to 192.168.1.1.)
On Jeopardy!, this is referred to as a "triple stumper."

Are you changing the lan IP to the address above (192.168.100.2)? If so, that's not going to work properly anyway since the lan and wan subnets must be non-overlapping.

That said, in general when you change the IP address of your router to a different subnet, you need to make sure that you also do this on the computer that is being used to access the router. Most of the time, the computer is set to use DHCP -- if that's the case, you need to renew the DHCP lease at which point it will get an IP on the new subnet. This can be done a few different ways, depending on your computer's OS... but one simple way to handle it is simply to bounce the network connection (unplug/replug ethernet, or turn off/on wifi).

Thanks for the reply.
I was trying to change the lan ip address out of curiosity (or maybe desperation?).
The laptop has a static ethernet address and I need to turn off wifi to access the router (the one I am trying to change).
The DL-WRX36 used to be the main router for the house, so the 192.168.1.1 address worked fine. I got a new router for the house and am trying to use the old one as a dumb AC.

Since you're trying to use the device as a bridged AP, you probably want to start with it in the default state. Connect it to your computer and make sure there are no other connections on either device (turn off wifi on your computer)

Then, follow the bridged AP guide to prepare it for use as an AP.
https://openwrt.org/docs/guide-user/network/wifi/wifiextenders/bridgedap

If the subnet of your upstream router is not 192.168.1.0/24, change the IP address first, and make sure your computer is set to DHCP so that you can quickly get a new address on the new subnet. Then follow the rest of the directions.

Finally, connect the device (lan-lan) with your upstream router.

Just tried something else (also unsuccessfully).
I turned off the main router and the existing dumb AP, just on the off chance there was some kind of weird conflict with the existing network.
I do not understand why the DL-WRX36 refuses to change its IP address, but it just won't behave.

What is your main router's lan subnet?

I've got two of these running as APs, with static IPs set, they behave just fine.

Here are the stats from Luci

Protocol: Static address
Uptime: 0h 42m 25s
MAC: 94:83:C4:A8:C8:36
RX: 14.62 MB (54174 Pkts.)
TX: 50.37 MB (77357 Pkts.)
IPv4: 192.168.1.1/24
IPv6: 2603:6080:6100:725e::1/64
IPv6: fd9d:a2cb:c93f::1/60

Does that have the info you ask for?

And I'll bet their static IPs were very easy to change, too.
Mine is taking that whole "static" thing to absurd extremes.

Sure, I simply edited /etc/config/network :slight_smile:

I tried that 4-5 times. I tried Luci. I found some uci commands and tried those, too.
No luck with anything.
That router looks kind of like a football, and I'm getting ready to punt.

Connect only LAN cable to your router. Any of noted procedures do work absolutely. No telling what you are doing so different that you cannot make it right.