Can't boot combined-ext4 from flash drive

The issue that I am having is that any time I try to download the files from the openwrt website it is telling me that my files are corrupted and if i etch them onto a flashdrive it doesnt show up as a bootable drive on my PC. I have now tried every browser i can think of and multiple PC's to try and download these files and create a bootable usb stick but i just cant get it to work the sha256sum is always wrong no matter what I do. Any help would be appreciated thank you.

which file(s) are you trying to DL ? from where ?

and who's saying they're corrupt ?

The x86 64 version
Im downloading it from the openwrt website
My windows 10 pc says that it is corrputed and the sha256 isnt the same.

Works for me/Matches, the issue must be at your end.

[frollic@atlantis ~]$ wget
Length: 8172952 (7.8M) [application/octet-stream]
Saving to: ‘openwrt-19.07.7-x86-64-combined-ext4.img.gz’
openwrt-19.07.7-x86 100%[===================>]   7.79M  27.5MB/s    in 0.3s
2021-04-16 10:37:52 (27.5 MB/s) - ‘openwrt-19.07.7-x86-64-combined-ext4.img.gz’ saved [8172952/8172952]

[frollic@atlantis ~]$ sha256sum -b openwrt-19.07.7-x86-64-combined-ext4.img.gz
9a33ff3b9e8343a35db671af6a0309f9b8b619779ff6fab1f8ffda0c927b8d97 *openwrt-19.07.7-x86-64-combined-ext4.img.gz

Do you have any ideas as to how i could resolve this short of walking to my neighbors house to try and download it there. Ive tried 4 different pc's and its always wrong.

How are you verifying it ?

C:\Downloads>certUtil -hashfile openwrt-19.07.7-x86-64-combined-ext4.img.gz SHA256
SHA256 hash of openwrt-19.07.7-x86-64-combined-ext4.img.gz:
CertUtil: -hashfile command completed successfully.

So the compressed file has the right checksum but the uncompressed file is different so is there any reason that would not write as a bootable flashdrive?

the SHA is based on the file you DL, it got noting to do with the content.
I guess the issue wasn't the SHA after all ?

Depends on your computer, but I think most media will show up if you trigger the boot selection menu,
doesn't matter if it's bootable or not.

That would just be my issue then is that the drive isnt showing up at all.

tried another USB-port ?

ive been trying them all and still no luck maybe this is an ASRock board issue.

try flashing something else's that supposed to be bootable.
see if it works.

well i just got ubuntu to boot so thats not the issue.

Same flash drive used ?

I changed the topic of the thread.

Thats a more accurate description. I tried the same one and a different one and neither is showing up.

Windows doesn't support the ext4 file system, and it can only show the first partion of an USB flash drive. That's why you can't see the driver after flashing it, but the files are already there

1 Like

So I knew that was the reason that the drive would just disappear after etching it. But the issue is that I cant get it to show up on my other pc that has no OS currently. I've tried all the ports and 4 different flash drives. But I cant ever get it to show up as a boot option.

Sounds like your bios settings is in UEFI mode, change it to legacy if it still support it. many new motherboard only support uefi booting now, and those openwrt 19.07 images doesn’t support uefi, you have to add uefi patch and compile yourself

1 Like

Thank you for helping me through my lack of knowledge with this system. I finally did some digging and installed generic-ext4-combined-efi.img.gz and i was able to install it thank you again.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.