Can't access webUI i think i bricked my router (Urgent)

Hi everyone,

I think i bricked my router as i followed the instructions after releasing the reset button it rebooted and the power led started flickering faster and then it stopped and stayed on its been over a minute and when i try to access the webUI i cant access it. Should i try rebooting ?.
Only lan and power leds are on.
Router is TP-link archer c20 ac750.

I really need help its urgent.

Thank you

sounds like maybe you put it in safe mode, try connecting with ssh, or just reboot

Okay ill reboot i can't ssh into it cause i don't think i have ssh client installed in my live linux USB and do you think the firmware got flashed ?

Its still stuck i also tried without the lan cable and also plugged in my internet cable my internet led shows in green

Did you flash the stable release or a snapshot? Snapshot has no luci and requires you to ssh in to config.

I know no Linux Distro without a ssh client. Have you tried to open a terminal and then typed "ssh root@<IP.of.the.router> "

Stable here is the file name

Okay ill try

Is this command right ssh root@
If so it says no route to host

What is the ip of the pc? type in the terminal window

ip a
route -n

My static IP address of the pc is
When i run the second command it says route command not found

then try

ip route 

Here is the output

can you ping


have you tried to set the ip of the pc via dhcp?

dhclient enp2s0
1 Like

No luck when i ping it still shows same as above pic same ip too
Removed the static settings from the network configuration and restarted network manager service

which ip do you get, using dhcp?

do you know, what the output means?

1 Like