Cant access to eva bootloader via ftp

Hi fellows.

I hve an AVM Fritz!box 7430 Router here and tried to set up Openwrt. Its frustrating cause this time (I set up a Fritz!box 4040 one year before), becuse I even cant access the ftp server.

So what I did:

(I have to mention, that I had to unbrick the device once. So the Ip changed of the device)

  1. Set my ip configuration to 192.168.188.2 (new sub Ip of the OEM)
  2. Openend the two windows cmd of windows
  3. In the first window I ping the 192.168.188.1
  4. When I got respond in the first command window, I fired the command: ftp open 192.168.188.1 in the first window.

Rssult is nothing is. Connetion denied.

I also tried:

Ftp -n -v 192.192.168.188.1

What is the correct command to access eva via ftp?

Regards

Thomas

It appears you're using the wrong address... at least according to the information in the installation section:
https://openwrt.org/toh/avm/avm_fritz_box_7430#installation

2 Likes

Thank you for ur advice. But i checked it and its the rright adress. Fritz!Os changed the internal IP adress to another sub IP adress as mentioned in the debrick manual also.

Ijust need to know how to access the ftp server on eva. Wich command its responding with username and passwort adam2?

So, i found that information I was looking for in another forum. Maybe I should watch out there in the future.

"Das AVM-Recovery-Programm mag bei einer tatsächlich statisch konfigurierten IP(v4)-Adresse offenbar doch keine Segmente, die von 192.168.178.0/24 abweichen. Ich kann es nicht beschwören, ob das früher nicht doch anders war - aber Stand heute
(und zurück bis zur 06.5x, soweit habe ich mit dem Recovery-Programm getestet) muß es bei der Verwendung des AVM-Programms (das gilt also nicht für andere Tools und/oder manuellen Zugriff auf den Bootloader per FTP, wenn zuvor irgendein
Tool mit "discovery feature" verwendet wurde) UND bei statisch konfigurierter IPv4-Adresse dann doch eine sein, die zum Segment 192.168.178.0/24 paßt und es darf nicht die erste aus dem Segment sein.
Die gute Nachricht ist aber, daß auch bei statisch konfigurierten Adressen nicht nur die "primäre" Adresse in Betracht gezogen wird, sondern auch alle anderen konfigurierten. Wer also häufiger mal mit FRITZ!Boxen in Kontakt ist, der hat i.d.R. ohnehin
auf seinen Netzwerk-Interfaces vermutlich schon eine zusätzliche Adresse aus den Segmenten 192.168.178.0/24 (für den Zugriff aufs GUI einer "frischen" Box) und 192.168.188.0/24 konfiguriert, wobei man letztere immer dann braucht, wenn man eine
FRITZ!Box mit halbwegs aktueller Firmware auf "LAN1"-Router umgestellt hat ... denn AVM setzt das LAN-Segment einer solchen Box dann automatisch erst einmal auf 192.168.188.0/24 - mit der Box als 192.168.188.1 - und man muß/müßte dann erst
wieder sein Interface umkonfigurieren. Aber auch das gilt eben nur für statisch konfigurierte Interfaces ... sowie das Interface DHCP verwendet und bereits eine Adresse hat (dabei ist es dann auch egal, ob es diese von einem DHCP-Server bezogen
oder sie selbst per APIPA zugewiesen hat), paßt sich das Recovery-Programm an diese Adresse an und setzt dann die FRITZ!Box passend dazu."

I will follow the instruction there and will share my results here, ...

Okay.

For now I followed your advice and chanced back the ip from 192.168.188.1 in the fritzOS UI to 192.168.178.1.

I restarted to connect to ftp after several seconds pluging energy into the device.

Result: ftp:connect refused connection.

I use windows 10

Command terminal

Thank you

I'm answering here your questions via messages:

Okay. I hung a switch inbeetween and tried to reach 192.168.178.1 over ftp. Nothing changes. It denies my connection to it.

I set my network setting, have no wifi on, turn of the firewall.

Nothing changes.

I can reach the fritzos normal but no access to ftp.

Any ideas?

Loosing patience here.

What's the client IP when you do this ?

Post a screenshot, will you ?

https://openwrt.org/docs/guide-user/installation/generic.flashing.ftp

image

I had to set up my switch also with a bridge. Possibly I have to set the ip there also to 192.168.178.2? I´ve red that a switch does not affect any of ip or protocol at all, correct?

No one else?

you been wrong! The IP of the device had been changed since I unbricked it. You know some other issues?