Can't access router or make it go to failsafe mode (Archer A9 V6)

I installed OpenWrt on a Archer A9 V6. Eventually figured out 2.4 ghz wasn't supported, so I figured I would roll it back to the OEM software. I downloaded the firmware from tp-link site, went into LuCI and uploaded the .bin. Router reset, now it has become inaccessible. I can plug in an ethernet cord and my pc recognizes it is plugged in. The web interface (still uses the static IP I assigned it in LuCI before it bricked) gets to the first page before the login where it just says " [LuCI - Lua Configuration Interface]) but never loads past that page. The ssh connection times out. When I turn it own the power light goes straight to solid green. I've tried pressing the wps and the reset button the entire time, but nothing seems to kick it into failsafe mode. The lan port lights work when I plug in devices. When I push the reset button, the wps light does come on for a few seconds.

All of TP-links recovery methods don't seem to be working either.

So, likely you now have the TP-Link OEM firmware, so why should OpenWrt-specific failsafe work any more?

You might try with a different browser, just to make sure that there are no cache issues.

At this point, you are probably no longer actually running openwrt anymore.

If the device appears to not work, you will likely need serial access to debug.

Best router-specific recovery instructions are given in the original commit giving support for the device:

Read advice in

Flash instruction (TFTP based recovery in second-stage U-Boot):

  1. Rename 'factory' image to 'ArcherA9v6_tp_recovery.bin'
  2. Setup a TFTP server on your PC with IP
  3. Press and hold the reset button for ~5 sec while turning on power.
  4. The device will download image, flash it and reboot.

Flash instruction (web based recovery in first-stage U-Boot):

  1. Use 'CTRL+C' during power-up to enable CLI in first-stage U-Boot.
  2. Connect a PC with IP set to to one of the LAN ports.
  3. Issue 'httpd' command and visit in browser.
  4. Use the 'factory' image.

If you would like to restore vendor's firmware, follow one of the
recovery methods described above.

Also, I believe that tp-link sets the default address of many of their devices to Make sure your computer is connected by Ethernet and set to obtain an ip address via dhcp. What happens?


I only assume its still the TP-Link firmware because the landing page that comes before the login page is still loading. I've tried this on both Chrome and Firefox

Sorry, it was late and I was really tired last night. I have tried the TFTP method last night. I could not get a response from the router at all. Most of the guides explaining that method talk about watching the log to make sure a request is being received. As I mentioned holding the reset button doesn't seem to affect the router. So for what ever reason, As far as the second method goes. How do I use CTRL+C on a router with no keyboard? Plug in a keyboard into the usb slot?

My PC receives no default gateway when I connect to the router with ethernet.

If I plug the PC directly I don't receive any gatway address. If I set a static ip of (required by the recovery guides) it doesn't change my ability to get a response from the router.

Ok... at this point, you'll probably need a USB serial adapter to debug further.

Serial connection inside the router.

The TFTP server method mentioned above should be there as it is in the u-boot bootloader, so it should be there for both OpenWrt and OEM firmware. But it requires setting a fixed IP and running the TFTP server on PC, so many steps where mistakes can be made.