Can't access NAS in LAN

Hello. I'm new with OpenWRT and not super experienced in networks overall so appreciate any help.
I've installed OpenWRT on router and everything works ok.
I have also connected PC and NAS to this router with LAN.
And however PC works well, internet and Wi-Fi are ok, NAS doesn't work.
I can't discover it in the network (with linux utilities or with "routes" in LuCI). It's just invisible, not obtaining any IP.
With original firmware NAS worked ok.
Where should I start to understand problem better?

Tcpdump the traffic, see if there are dhcp requests coming in.

Can you please provide more details for newbie? How to do this?
I've installed tcpdump into router but I have many devices in the network

Something like this...

If you dump to file, don't write it to the flash, it'll kill it.

1 Like

Ok thank you.
I've attached Wireshark and filtered out with udp.port == 68.
I've checked with other devices - DHCP requests are coming ok.
But with NAS nothing. Tried to reboot it and nothing come.

You sure you didn't have it running with a static IP?

You should be able to use arp on a client, to map an IP to its mac, to access the admin interface.

1 Like

Ok, I did the simplest thing I could: just changed net mask back to work with static ip of NAS.
Now everything working good.
Thank you very much for the idea.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.