Cant access nanopi r4se


i was trying to install openwrt on my nanopi r4se using a tf card, and now i cannot connect to it through the web interface or ssh, although i can ping it. ive tried resetting it, loading the tf card with openwrt and freindlywrt and cannot get anything to work. any suggestions on how to fix this?


If you have two OSes failing on you, the issue's probably not with them...

Oops! I guess I didn't read the OP very well.

I wonder if the pingability is just a fail-safe mode (if it is the default address). The Friendlyelec wiki has troubleshooting info. Good luck.

Original post:
The R4SE is not supported by OpenWRT like the R4S is.

Some people have had success getting the SE units to boot OpenWrt from an sd card using instructions based on those on the Friendlyelec support wiki.

There are a few other forum threads that might be of help as well that should show up in a search.

Good luck!

it was working fine until tried installing openwrt

the issue stared after i tried to load openwrt w emmc. getting nothing from it when i try loading openwrt or friendlywrt using sd card and the mask buttom unfortunately

edit: nvm, i was just able to log into friendlywrt for some reason. no idea why, only tried the same things i did last night

1 Like

I have R4S and not the R4SE but I have been following threads about the R4SE. If I recall correctly, no one has gotten the OpenWrt images to run from the eMMC. They only can run OpenWrt from a tf card.

yeah, and it seems that once they do get it running, they have to press the mask button eveytime the boot it up. might just return mine and get the r4s instead, how have you been liking yours?

1 Like

I like mine a lot. I don't put much load on it but it runs for many weeks at a time with no attention needed. It should be fine when I upgrade to 500Mb/s or more on the WAN with FTTH in 6 months. I have been looking at running other services on it as well but might setup a separate server for that so the network security stays easy to understand on the primary router/firewall.

i just upgraded to fiber, so that is why i got mine. using my old archer c7 as an access point, ive been able to to get up to 500mb/s down, but with quite a bit of latency. need to upgrade that next, and then it should be great for fiber speeds

1 Like

It seems that I passed on some incorrect/incomplete info. User jabss says that it is possible to have the r4se boot OpenWrt (or other systems) from the sd card without pressing the mask button if you corrupt/overwrite the bootloader on the eMMC. This makes the eMMC unavailable as a boot source until the bootloader is fixed.

Details of fixing/replacing the FriendlyWrt setup on the eMMC is on their wiki. Mention of getting the r4se to boot OpenWrt from the sd card at power-on is mentioned in this thread: Nanopi R4S (4GB) install problems - #16 by jabss

A strategy for a reversible change is this:
Find the starting block and size for the eMMC bootloader and document it. Use dd to copy the whole bootloader to a file on the sd card or /tmp. Copy it to multiple backup locations off the device. Document the start, size backup file locations.
use dd to overwrite the first block or more of the eMMC bootloader with nulls or random data. Test booting without the mask button.
If you ever want to restore booting from the eMMC, copy the same blocks overwritten from the backup file to the block/byte offset on the eMMC or use FriendlyWrt's restore tools.


hey, spence. i ended up returning the r4se, and getting a r4s to just to simplify the setup. thank for detailed follow up though!

1 Like

Yeah, I think I suspected that from other posts. I also added the update for others that might come across this thread.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.