Cant access my access point page from pc

so i have a tp-link access point connected to my nanopi r6s. for some reason i cant get into the login page of my access point from my pc which is hardwired to the same router my access point is wired to. i can access the web page thru my devices that are connected to the AP via wifi. i was able to log in via pc to the web page seamlessly before but now i cant and i dont know why. the ap is in the same subnet as my router and it shows up on my routers page. ive exhausted all my options such as rebooting and resetting plenty of times. if anyone knows how to get this working again id appreciate it

If you can provide more details, that would be very helpful. Specifically, a basic topology diagram (a photo of a drawing on paper is fine) and the configs of each device. This will help us understand you setup and hopefully will make it easy to spot any issues.

Please connect to your OpenWrt device using ssh and copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

ubus call system board
cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall
config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.x.x'
        option netmask '255.0.x.x'

config globals 'globals'
        option ula_prefix 'fd00:ab:cd::/xx'

config device
        option name 'eth2'
        option macaddr '8e:94:49:xx:xx:xx'

config interface 'wan'
        option device 'eth2'
        option proto 'dhcp'
        option peerdns '0'
        list dns '1.1.1.1'
        list dns '1.0.0.1'

config interface 'wan6'
        option device 'eth2'
        option proto 'dhcpv6'
        option reqaddress 'try'
        option reqprefix 'auto'
        option peerdns '0'
        list dns '2606:4700:4700::1111'
        list dns '2606:4700:4700::1001'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth1'
        list ports 'eth0'

config device
        option name 'eth1'
        option macaddr '8e:94:49:xx:xx:xx'

config device
        option name 'eth0'
        option macaddr '8e:94:49:xx:xx:xx'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.x.x'
        option netmask '255.255.xxx.x'
        option ip6assign '60'
        list dns '1.1.1.1'
        list dns '1.0.0.1'
        list dns '2606:4700:4700::1111'
        list dns '2606:4700:4700::1001'

cat: /etc/config/wireless: No such file or directory

config dnsmasq
        option domainneeded '1'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option cachesize '1000'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
        option localservice '1'
        option ednspacket_max '1232'
        option confdir '/tmp/dnsmasq.d'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv4 'server'
        option dhcpv6 'server'
        option ra 'server'
        list ra_flags 'managed-config'
        list ra_flags 'other-config'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

config host
        option name 'AP'
        list mac '40:AE:30:xx:xx:xx'
        option ip '192.168.x.x'
        option leasetime 'infinite'


config defaults
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        option synflood_protect '1'

config zone
        option name 'lan'
        list network 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'

config zone
        option name 'wan'
        list network 'wan'
        list network 'wan6'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option fullcone4 '1'
        option fullcone6 '1'
        option masq '1'
        option mtu_fix '1'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-IGMP'
        option src 'wan'
        option proto 'igmp'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-MLD'
        option src 'wan'
        option proto 'icmp'
        option src_ip 'fe80::/xx'
        list icmp_type '130/0'
        list icmp_type '131/0'
        list icmp_type '132/0'
        list icmp_type '143/0'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Input'
        option src 'wan'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        list icmp_type 'router-solicitation'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'router-advertisement'
        list icmp_type 'neighbour-advertisement'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Forward'
        option src 'wan'
        option dest '*'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-IPSec-ESP'
        option src 'wan'
        option dest 'lan'
        option proto 'esp'
        option target 'ACCEPT'

config rule
        option name 'Allow-ISAKMP'
        option src 'wan'
        option dest 'lan'
        option dest_port '500'
        option proto 'udp'
        option target 'ACCEPT'

config rule
        option name 'Reject-IPv6'
        option family 'ipv6'
        option src 'wan'
        option dest '*'
        option target 'REJECT'
        option enabled '0'

config redirect
        option dest 'lan'
        option target 'DNAT'
        option name 'wz1'
        option src 'wan'
        option src_dport '3074'
        option dest_ip '192.168.x.xxx'
        option dest_port '3074'

config redirect
        option dest 'lan'
        option target 'DNAT'
        option name 'wz2'
        list proto 'tcp'
        option src 'wan'
        option src_dport '3075'
        option dest_ip '192.168.x.xxx'
        option dest_port '3075'

config redirect
        option dest 'lan'
        option target 'DNAT'
        option name 'wz3'
        option src 'wan'
        option src_dport '27015-27030'
        option dest_ip '192.168.x.xxx'
        option dest_port '27015-27030'

config redirect
        option dest 'lan'
        option target 'DNAT'
        option name 'wz4'
        list proto 'tcp'
        option src 'wan'
        option src_dport '27036-27037'
        option dest_ip '192.168.x.xxx'
        option dest_port '27036-27037'

config redirect
        option dest 'lan'
        option target 'DNAT'
        option name 'wz5'
        list proto 'udp'
        option src 'wan'
        option src_dport '4380'
        option dest_ip '192.168.x.xxx'
        option dest_port '4380'

config redirect
        option dest 'lan'
        option target 'DNAT'
        option name 'wz6'
        list proto 'udp'
        option src 'wan'
        option src_dport '27000-27036'
        option dest_ip '192.168.x.xxx'
        option dest_port '27000-27036'

mind you my router doesnt have wifi abilities, hency why i use an AP, sometimes when i reboot the router i can access the web page of the ap from my pc then after a minute its not reachable

basically modem >>> nanopi r6s>>> access point

Ok. How about the configs from the ap?

static ip with same subnet and the ap ip is outside the dhcp range of my router. even with being inside the dhcp pool, it still isnt accessible

Can you share the config? Otherwise we have no way to know the details of that device.

Also, you do not need to redact rfc1918 addresses.

how do i fix that? the rfc1918 addresses

should i redact the ip addresses? when sharing config

Simply don’t redact them. 192.168.x.x and the subnet mask - no need to redact.

But please post the complete config of the ap. No redactions should be necessary except for the ssid and passphrase.

oh ok i will post now. was just updating the firmware to new openwrt rc5 for the r6s

1 Like

update after the firmware rc5 i can somehow access my ap. will monitor for now and see if it goes back to the original issue

nvm lol its doing it again

There was nothing on the main router which could cause the behavior you are experiencing. So let’s see that ap.

so the ap is now on dynamic ip receiving from the router. now when i try to access the login page via phone. it says connection is not private. it thiks the router ap is an attacker

That might be an over ambitious browser complaining about the self-signed cert.

But we can’t begin to diagnose anything until we see the full configuration.

Oh. It’s not openwrt. You’ll have to ask tp-link as it is their firmware.

ahhh ok no worries. also one question, i know its irrelevent but i see flow control is on for eth1 and 2 but npot eth0. is it best to have it enabled across all ports