Can't access Main OpenWrt router management interface from 2nd Openwrt router

I can't access Main Openwrt router management interface from 2nd Openwrt router unless i'm connected directly from the main router lan port.
2nd router is connected to the main router via lan port.
the two routers are using the same subnet. 192.168.1.1 for the main router, 192.168.1.2 for the 2nd router

Check your firewall settings. Not an expert, maybe someone else here might help you.

i actually disabled the both routers' firewall simultaneously to see what's happening but i did not work in my case

How are the two routers connected to each other? Is it LAN-LAN, or LAN-WAN?
What is the intent of the 2nd router? Is it supposed to be a dumb AP, or is it serving some other purpose?

router 1 lan port -> router 2 wan port
it was supposed to be used as an AP but also a switch for my pc

You need to connect LAN - LAN if this is your intention.

EDIT: as an FYI: it is probably possible to physically use the WAN port if you need the extra port, but that requires a minor configuration change.

will router 2 receive internet connection even though there's no cable connected to the wan port?
also what config change is needed to use the wan port if possible?

That depends on the configuration, but in general it is not required for most cases with a dumb AP. The router in this configuration is acting as a simple switch and AP, and doesn't need to do any routing. Therefore, it doesn't need to have anything connected to the WAN port at all. And the upstream connection will be switched to all of the downstream devices (connected to the switch or AP), so the router itself doesn't need to have internet access. But if you want it to have internet access (as a device -- remember, this doesn't affect downstream devices), you simply need to set the gateway and dns addresses in the LAN interface (pointing to your main router).

You need to reassign that physical port to operate as a standard LAN port.

I'd need to see your network configuration to advise on the specifics.

Please copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

cat /etc/config/network

Also, don't forget that you must disable the DHCP server on the 2nd router.

This did the trick. Thank you so much!

i already disabled the dhcp on the 2nd router

how can i do that?
should i just bridge the wan port to lan?

No, at least not this way.

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option packet_steering '1'
        option ula_prefix 'fdbc:f8fb:4f79::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ip6assign '60'
        list ipaddr '192.168.1.5/24'
        option gateway '192.168.1.3'
        list dns '192.168.1.3'

config interface 'wan'
        option device 'wan'
        option proto 'dhcp'

config interface 'wan6'
        option device 'wan'
        option proto 'dhcpv6'

Thanks. Remove the option device 'wan' lines for wan and wan6 interfaces. Then you can add wan to the bridge.

It will look like this:

thank you so much for your help

can i ask something else? maybe it's related to this solution
when i connect this router at my mesh network
i can't access this router unless i disconnect the lan cable from router 1 so i'm wondering what's the problem?

It's hard to say what is going on without more details. Probably best to open a new thread on this topic.