Can't access Luci with browsers

I have just updated OpenWrt on a Linksys WRT3200ACM router. I can access the router on 192.168.1.1 using ssh but not with Chrome or Edge. I get the error message " Bad Gateway The process did not produce any response". The router seems to be working normally. This is very strange because I didn't have this problem yesterday. I haven't made any updates to the browsers or Windows.

I also have the same problem when I plug the machine directly into the router. I have tried resetting the network. It is really strange because I am able to access other websites normally,

Did you update to a SNAPSHOT version?

Hi,
I used the Firmware OpenWrt upgrade from: https://openwrt.org/toh/linksys/linksys_wrt3200acm. It worked fine yesterday, so I don't think there is a problem with the upgrade.

Thanks,
Chris.

What day did you upgrade OpenWrt, and when was the last time it worked?

1 Like

I upgraded it yesteday. It was working this morning. I didn't do anything to either the installation or the PC and it stopped working this morning! I have rebooted the machine, reset the network etc. I haven't rebooted the router because I am worried that I might not get back in!

I took a gamble and rebooted the router. It now works OK. Now wonder what the problem was.

Update - The Luci menu came up but is still woudn't connect. Will try an reset.

OK. I think I have solved it. The Linksys WRT3200ACM has a dual partition.
https://openwrt.org/docs/guide-user/troubleshooting/vendor_specific_rescue

  1. turn the power off; 2) 3 X switch the power on for 2s; 3) turn on again and it is on the alternative partition.

I went into settings. I configured two of the channels and when I went into the third it didn't save properly. It then timed out and I am now back to square one. If I turn the router off and on again I get the luci login, but it the eventually times out. I am baffled.

Try clearing the history (cookies/cache) in your browsers.

Thanks, I've given that a try, but it doesn't work.

I have managed to go back to the Linksys WRT3200ACM firmware which I was able to do from the command line:

cd /tmp
wget link-to-stock-firmware
sha256sum /tmp/stock-firmware-filename
sysupgrade -F -n /tmp/stock-firmware-filename

e.g.

cd /tmp
wget  http://downloads.linksys.com/downloads/firmware/FW_WRT3200ACM_1.0.6.186168_prod.img
sysupgrade -F -n /tmp/FW_WRT3200ACM_1.0.6.186168_prod.img

From what old OpenWrt version did you update to 19.07.3?
Did you update with or without keeping settings?

[quote="tmomas, post:12, topic:68136"]
Hi,
I updated from the previous version 19.07.2 installed on 10th May without keeping settings.
Having reverted to Linksys firmware I am being reminded of how much extra functionality OpenWRT has. But the experience of not being able to connect to the router via Luci was scarry and occured with a vanila installation with carefully checked checksums. All I had done was set up two of the wifi channels when the communication with luci stopped. I can only assume there is a bug.I hadn't got to the stage of reinstalling NORD VPN, the printer, SQM, USB etc., which took me about a day to do first time. So at the moment, I am sadly going to stick to Linksys for reliability and easy updating. I might well try OpenWrt again in the future when I have more time.

I would also like to send a big thank you to the various forum members who helped me along the way.