Can't access jellyfin from lan devices

i can't seem to access my jellyfin server which is on lan. i port forwarded it, and can access it with the public ip, even inside the lan. can't seem to find a solution anywhere.

more information is required.

How are you trying to access your jellyfin server?
Let's see your config:

Please copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall
[quote="psherman, post:2, topic:159534"]
`cat /etc/config/network`
[/quote]


config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0'
        option igmp_snooping '1'

config interface 'lan'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option device 'eth0.99'
        option delegate '0'
        option ipaddr '192.168.1.1'
        list dns '1.1.1.1'
        list dns '1.0.0.1'
        option gateway '192.168.1.0'

config interface 'WAN'
        option device 'eth0.10'
        option proto 'pppoe'
        option username 
        option password '
        option ipv6 'auto'
        option peerdns '0'
        list dns '1.1.1.1'
        list dns '1.0.0.1'
        option delegate '0'

config device
        option name 'eth0.99'
        option type '8021q'
        option ifname 'eth0'
        option vid '99'
        option acceptlocal '1'
        option promisc '1'
        option multicast '1'
        option ipv6 '0'

config device
        option name 'eth0.10'
        option type '8021q'
        option ifname 'eth0'
        option vid '10'
        option multicast '1'
        option ipv6 '0'

config device
        option name 'pppoe-WAN'
        option multicast '1'

config device
        option name 'eth0'
        option multicast '1'
        option ipv6 '0'



config dnsmasq
        option localise_queries '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
        option ednspacket_max '1232'
        option confdir '/tmp/dnsmasq.d'
        option rebind_protection '1'
        option localservice '0'
        option rebind_localhost '1'
        option nonwildcard '0'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv4 'server'
        option ra 'server'
        list ra_flags 'managed-config'
        list ra_flags 'other-config'
        option force '1'
        option dns_service '0'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

config dhcp 'WAN'
        option interface 'WAN'
        option ignore '1'


config defaults
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option synflood_protect '1'

config zone
        option name 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        list network 'lan'

config zone
        option name 'wan'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'
        list network 'wan'
        list network 'wan6'
        list network 'WAN'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-IGMP'
        option src 'wan'
        option proto 'igmp'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-MLD'
        option src 'wan'
        option proto 'icmp'
        option src_ip 'fe80::/10'
        list icmp_type '130/0'
        list icmp_type '131/0'
        list icmp_type '132/0'
        list icmp_type '143/0'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Input'
        option src 'wan'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        list icmp_type 'router-solicitation'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'router-advertisement'
        list icmp_type 'neighbour-advertisement'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Forward'
        option src 'wan'
        option dest '*'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rulePreformatted text
        option name 'Allow-IPSec-ESP'
        option src 'wan'
        option dest 'lan'
        option proto 'esp'
        option target 'ACCEPT'

config rule
        option name 'Allow-ISAKMP'
        option src 'wan'
        option dest 'lan'
        option dest_port '500'
        option proto 'udp'
        option target 'ACCEPT'

config redirect
        option dest 'lan'
        option target 'DNAT'
        option name 'torrent'
        option src 'wan'
        option src_dport '3788'
        option dest_port '3788'
        option dest_ip '192.168.1.170'

config redirect
        option dest 'lan'
        option target 'DNAT'
        option name 'openwrt'
        option src 'wan'
        option src_dport '8888'
        option dest_ip '192.168.1.1'
        option dest_port '80'

config redirect
        option dest 'lan'
        option target 'DNAT'
        option name 'jellyfin'
        option src 'wan'
        option src_dport '9999'
        option dest_ip '192.168.1.150'
        option dest_port '8096'

config redirect
        option dest 'lan'
        option target 'DNAT'
        option name 'voobly'
        option src 'wan'
        option src_dport '16000'
        option dest_ip '192.168.1.150'
        option dest_port '16000'
        list proto 'udp'

have no wireless network, have seperate aps for that.

The gateway in your lan interface is invalid. Delete that line.

You can also delete the DNS entries in the lan, they don't do anything.
And remove the delegate line, too.

You didn't answer how you are trying to access your jellyfin server... you said that you are able to access it from outside your network, and you also said you can reach it from inside your network using the public IP... is that correct? So under what circumstances can you not access it? How are you trying to reach it (i.e. what IP address are you using), and from what device(s) on your lan are you unable to reach it? Is the jellyfin server wired or wireless? What about the other devices that are trying to access it?

1 Like

yes, i can access from outside the network. i can also access from inside the network using public ip address and forwarded port. what i can't access is from local ip, like 192.168.1.150:8096. i am trying to access it from laptop and also my phone and not being able to access it. jellyfin server is connected to an ap which is connected to with wire to openwrt.

Your router is not involved in this connection at all. All of this happens at L2 (switching).

Can you draw a diagram of your network topology? (a photo of a sketch on paper is sufficient).

2 Likes

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.