Can't access Interface

I installed OpenWRT on my FB 7330 directly from the origina OS and was able to take a quick tour of the features and to set the user/password credentials.

Now I cannot log in... I tried the default IP, with no luck. I can see the openwrt WLAN, but I'm unable to get to the interface, even if I plug an ethernet cord.

Any suggestion on how to recover/reinstall/find out the IP of the device?

Thanks

It's not an IP conflict with some other router/device on the same LAN?

1 Like

What image did you use (what version and was it a snapshot/master, official stable release, official release candidate)?

How are you trying to log-in? web (LuCI interface) or ssh?

Does your computer get an IP address when it connects via ethernet? If so, what is that IP?

What port are you physically connecting to? According to the device info page, LAN2 does not work.

Did anything change between the time that you were able to access the device and now? If so, what changed?

1 Like

Already tried to plug it directly to the pc via Ethernet and switching off WLAN, but couldn’t access it…

I used this> http://downloads.openwrt.org/releases/19.07.7/targets/lantiq/xway/openwrt-19.07.7-lantiq-xway-avm_fritz7320-squashfs-sysupgrade.bin and worked flawlessly;
Tried to log via LuCI;
I get this IP: http://169.254.112.42/
I turned it off and on again...

Your computer is not getting an IP address from the router via DHCP. If you were, it would be in the 192.168.1.0/24 range.

Make sure you are connected to LAN1, and verify that you have a known good cable. It is often good to make sure nothing else is connected -- just a direct connection between your router and your computer and that is all... this prevents IP address conflicts and other potential issues.

If you still don't get a DHCP address, try setting your computer's network interface with a manual/static IP address. Set the IP address: 192.168.1.10, subnet mask 255.255.255.0, router/gateway 192.168.1.1, dns 192.168.1.1.

1 Like

Make sure you are connected to LAN1, and verify that you have a known good cable. It is often good to make sure nothing else is connected -- just a direct connection between your router and your computer and that is all... this prevents IP address conflicts and other potential issues.
If you still don't get a DHCP address, try setting your computer's network interface with a manual/static IP address. Set the IP address: 192.168.1.10, subnet mask 255.255.255.0, router/gateway 192.168.1.1, dns 192.168.1.1.

Tried this, didn't work. Still can't access...
Is there a way to hard reset it or reinstall everything?

  • Factory reset = after the router has booted up - hold down the reset button for ~10 seconds. This will return the router to a clean slate. No harm no foul. You should be able to log into 192.168.1.1 at this point.

  • Turn your NIC on/off to refresh it (or just reboot your computer) and clear your web browser cache.

  • like @psherman said make sure there are no other computers/routers/switches connected - just the router and lan cable to your computer and reboot everything.

  • Factory reset = after the router has booted up, hold down the reset button for ~10 seconds. This will return the router to a clean slate. No harm no foul.

The FB 7330 doesn't have a reset button

  • like @psherman said make sure there are no other computers/routers/switches connected - just the router and lan cable to your computer and reboot everything.

Yes, pc and device only through ethernet cable, WiFi off...

  • try to ssh in and issue commands

Soft Factory Reset

If you want a clean slate, there’s no need to flash again; just enter the following commands. Your device's settings will be reset to defaults like when OpenWrt was first installed.

Issuing “firstboot” or “jffs2reset” command will attempt to delete all files from the jffs2 overlay partition. Note that this “soft reset” is performed with file system actions, so in some cases it is not enough.

firstboot && reboot now

Note: If the commands above (all on one line) don't work, try those commands on separate lines in the terminal.

Note: for most routers, “firstboot” actually just issues a “jffs2reset” command, so there is not much difference compared to the “hard reset” advice below.

Note: if you're issuing this command inside a bash script, remember to add the option -y to force firstboot:

firstboot -y && reboot now

1 Like

How are you trying to access the router? LuCI or SSH?

Does it respond to pings (ping 192.168.1.1)?

1 Like

How are you trying to access the router? LuCI or SSH?

Via browser.

Does it respond to pings (ping 192.168.1.1)?

Doesn’t seem to respond if I ping it…

What are the LEDs doing? That may indicate if the device is booting properly or not.

Since the router isn't responding to pings or anything else, it is possible that it is currently in a bricked state. You may need to use the serial port to recover the device.

1 Like

What are the LEDs doing? That may indicate if the device is booting properly or not.

Since i turned the WiFi off, only "Power/DSL" is on and static.

Since the router isn't responding to pings or anything else, it is possible that it is currently in a bricked state. You may need to use the serial port to recover the device.

How can I do that?

When you first power it on, does it blink in a pattern before becoming solid/static on?
Are there any LEDs for the LAN ports? Are those lit up?

You will probably need a serial to USB adapter to use this port. Your router does have a set of serial pads -- typically you'll solder some wires or a header to those pads.

Yes, it blinks a few times and then it becomes static. If I plug/unplug the ethernet it blinks. If i turn on the WLAN it blinks.

Is there a less "invasive" way to recover it? I might as well throw it away...

Furthermore, if I turn the WLAN on, I can se the OpenWRT SSID and I can connect to it, but I can't log into it. Like is there something that tells you the correct IP of the device?

Based on this, you clearly have OpenWrt running (it is not bricked). When you connect via wifi, what IP address (if any) do you get on your wireless interface on your computer?

1 Like

Connect to the SSID. Then try to ssh in. If you are using windows download PuTTY. If you have a linux laptop use that and launch a terminal / CLI.

ssh root@192.168.1.1

It's alive - but he probably has to reinstall LuCI? We shall see.

YES! I got in LuCI through the WiFi!
The problem was that DHCP was off and on my pc I had a dynamic IP... Thanks for the help!