Can't access cable modem page from LAN, on a Arris CM8200A

OK, set that up, there were a few minor Luci field differences... and... I get the OpenWRT sign in. I seem to be getting sent to 192.168.1.1, not 192.168.100.254.

config interface 'modem'
        option proto 'static'
        option ifname '@wan'
        option ipaddr '192.168.100.X'
        option netmask '255.255.255.0'
2 Likes

And for your /etc/config/firewall you need an entry thus

config zone
        option name 'wan'
        ...[other entries]...
        option network 'wan wan6 modem'
1 Like

OK, am copying the existing stuff and files, so I can see what's what, if I need to go back. Might also check against what Luci puts there... maybe somethings buggy. I'm kind of Luci handicapped, sadly haven't been learning command line stuff, and forgetting a lot from the 1.4-2.0 kernel days...

Blockquote ```
config interface 'modem'
option proto 'static'
option ifname '@wan'
option ipaddr '192.168.100.X'
option netmask '255.255.255.0'

Well, have been poking at it with the Luci interface, and looking at it thru the command line/uci, and I seem to get the results matching what you gave me, except I have the ipaddr as the full address, not the 192.168.100.X. OTOH, you probably mean that to be whatever address I might map it to, and whether it's 1 or 2 or 254, I still get the same result. I can ping it, OK, but when I hit it with the browser, I get the OpenWRT signup page, which seems to mean I actually go to 192.168.1.1.

Very confused now...

Collect the diagnostics and post it to pastebin.com redacting the private parts:

uci show network; uci show firewall; \
ip address show; ip route show table all; ip rule show; iptables-save
2 Likes
1 Like

Is your modem running bridge mode?

1 Like

Ha, Trendy!! Neat trick, that. Opened the page and was all "wow, a modernized page very similar to that extremely dated one I was looking at last night...." and then I realize it's the SAME page, and Thomas had majorly overhauled it just a few hours ago.... :wink: Will read it over and see what's new in there...

Vgatera.. I'll get to that, probably later tonight...

Krazeh.. I don't think it it is, or even could, be. Brand new CM8200a, pretty sure it's a bare cable modem.

1 Like

Kudos and thanks to @vgaetera who modernized the instructions and uses uci instructions to make it a lot faster and easier.

3 Likes

OK did the pastebin signup tango, and a load of pasting... I hope I haven't sanitized stuff you needed to see, probably cleaned a few things I didn't need to...
Pastebin Link

And following the updated page... sadly, it seems it's pretty much the same instructions I'd tried earlier, more or less. And, it still doesn't work, I type the assigned modem address, (192.168.100.2) and the router box's OpenWRT page promptly pops up. (192.168.1.1)

I have only tried the Luci page set of instructions, will look at the uci based stuff, to see how it compares with what I tried last night.

1 Like

So following the Luci info, the only thing I see somewhat different, is when I go to the Firewall Settings tab I see "LAN" and "WAN, WAN6, Modem" as the choices and picked the latter.

Looking further, I see in the entirely different section of Network - Firewall - General Settings... I see firewall zones. Does something need to be created here?

And I assume that you all assume and expect that this is the standard, vanilla router setup where WAN - LAN thru NAT and DHCP server, right?

uci add_list bcp38.@bcp38[0].nomatch="192.168.100.0/24"
uci commit bcp38
/etc/init.d/bcp38 restart
/etc/init.d/firewall restart
3 Likes

Nope... It even occurred to me that my running BCP38, which is not stock, might have something to do with it, flipped the Luci interface "enable" box back off, didn't work.

And, ran your uci commands... nope, still going to the router page instead of the modem.

Well, that was interesting... slipped and mis entered a line there, completely lost the router. No communication at all.. Internet was down for the house, and I was lucky to have an old SD disk laying next to the router, which I was able to plug in and get the router back relatively fast, or there would have been household discord! Running 19.07.05 now, same problem... also have BCP38 running on that one.

This is very strange, from what little I know, it should be easy... I had first tried doing a static route, and found a bit online about that. Didn't understand that very well either, so I was just reading and trying things... and had no success.

Guess I have to start truly educating myself on basic Linux Networking again... think I have some 20yr old books I could dust off...

# OpenWrt
opkg update
opkg install tcpdump
tcpdump -evni any tcp port 80

# PC
curl -v 192.168.100.1
nmap -sV -p 80 192.168.100.1

Uh, it's late and I'm getting confused. SSH into OpenWrt, got tcpdump running, went back and banged on the 192.168.100.2 with the browser a few times. Got lots of traffic, but I don't have curl available on OpenWrt and have a Win10 box on the other end and don't seem to have it there, where I can use it. Seems to be in the Win command line, but i'm using Ktty to ssh into the router. Just eyeballing it, I dont' see any traffic with that IP. Oddly, I did hanve a smart switch in line, that took it's own IP, , thought maybe it's doing something to stuff it shouldnt, plugged the pc into the dumb switch at the router egress... No difference but I'm still seeing traffic to and from 192.168.10.1. edit: that should be 192.168.1.10

Really confused now, will do some reading in to tcpdump use... this is my first time...

'00:19:55.759869 Out 00:01:2e:83:5a:da ethertype IPv4 (0x0800), length 108: (tos 0x0, ttl 64, id 20893, offset 0, flags [DF], proto TCP (6), length 92)
    192.168.100.2.80 > 192.168.1.10.59146: Flags [P.], cksum 0xe6ab (incorrect -> 0xd3bd), seq 1:53, ack 335, win 237, length 52: HTTP, length: 52
        HTTP/1.1 307 Temporary Redirect
        Connection: close

OK, well, that didn't format very well... Just dropped a huge text paste into an editor, and searched around. There's other stuff, but this is who it's being pointed at. The interesting thing is, that's my smart switch. That also is not there at the moment. It's the address that should be where it's web interface is, moved so it won't conflict with the 192.168.1.1 that the router is on. Somehow, there has to be some cross connection there.. I see 193.168.1.10 in the Routes table, but never have seen a 192.168.100.x.
Hope those are some clues. I'll figure out or just make a collection of everything with the modem IP on it, tomorrow. Hope this has a clue or two for you.

    192.168.1.10.59146 > 192.168.100.2.80: Flags [S], cksum 0x1418 (correct), seq 1113870315, win 64240, options [mss 1460,nop,wscale 8,nop,nop,sackOK], length 0
    192.168.1.10.59146 > 192.168.100.2.80: Flags [S], cksum 0x1418 (correct), seq 1113870315, win 64240, options [mss 1460,nop,wscale 8,nop,nop,sackOK], length 0
    192.168.100.2.80 > 192.168.1.10.59146: Flags [S.], cksum 0xe683 (incorrect -> 0x41e0), seq 2291651184, ack 1113870316, win 29200, options [mss 1460,nop,nop,sackOK,nop,wscale 7], length 0
    192.168.100.2.80 > 192.168.1.10.59146: Flags [S.], cksum 0x41e0 (correct), seq 2291651184, ack 1113870316, win 29200, options [mss 1460,nop,nop,sackOK,nop,wscale 7], length 0
    192.168.1.10.59146 > 192.168.100.2.80: Flags [.], cksum 0xd4ae (correct), ack 1, win 8212, length 0
    192.168.1.10.59146 > 192.168.100.2.80: Flags [.], cksum 0xd4ae (correct), ack 1, win 8212, length 0
    192.168.1.10.59146 > 192.168.100.2.80: Flags [P.], cksum 0xedf9 (correct), seq 1:335, ack 1, win 8212, length 334: HTTP, length: 334
        Host: 192.168.100.2
    192.168.1.10.59146 > 192.168.100.2.80: Flags [P.], cksum 0xedf9 (correct), seq 1:335, ack 1, win 8212, length 334: HTTP, length: 334
        Host: 192.168.100.2
    192.168.100.2.80 > 192.168.1.10.59146: Flags [P.], cksum 0xe6ab (incorrect -> 0xd3bd), seq 1:53, ack 335, win 237, length 52: HTTP, length: 52
    192.168.100.2.80 > 192.168.1.10.59146: Flags [P.], cksum 0xd3bd (correct), seq 1:53, ack 335, win 237, length 52: HTTP, length: 52
    192.168.100.2.80 > 192.168.1.10.59146: Flags [FP.], cksum 0xe69b (incorrect -> 0x2aa2), seq 53:89, ack 335, win 237, length 36: HTTP
    192.168.100.2.80 > 192.168.1.10.59146: Flags [FP.], cksum 0x2aa2 (correct), seq 53:89, ack 335, win 237, length 36: HTTP
    192.168.1.10.59146 > 192.168.100.2.80: Flags [.], cksum 0xd307 (correct), ack 90, win 8212, length 0

Extra pastage...

This way you can see the original redirect location:

tcpdump -Xvni any host 192.168.100.1 and tcp port 80

Also check this:

ipset list
1 Like