Cannot use PowerLine feature on TL-WPA8631P v3

I have flashed OpenWRT on a AV1300 PowerLine adapter, but I cannot get the thing to go into pairing mode?

I am assuming the button configuration matches the original layout? but pushed the pair button does not enter pairing mode as far as I can tell. Or there is no LED feedback?

Any ideas?

Pretty much stock firmware other then some network config changes.


I'm not seeing this device in the table of hardware or the firmware selector. Can you elaborate on which device this is?

Also, what is the output of:
ubus call system board

1 Like

Sorry didnt see your reply :frowning:

        "kernel": "5.10.161",
        "hostname": "OpenWrt",
        "system": "MediaTek MT7621 ver:1 eco:3",
        "model": "TP-Link TL-WPA8631P v3",
        "board_name": "tplink,tl-wpa8631p-v3",
        "rootfs_type": "squashfs",
        "release": {
                "distribution": "OpenWrt",
                "version": "22.03.3",
                "revision": "r20028-43d71ad93e",
                "target": "ramips/mt7621",
                "description": "OpenWrt 22.03.3 r20028-43d71ad93e"


Also just a few questions,

  1. If I want to go back to stock, how do I run the tplink-safeloader tool? Do I need to install it on the device? or do I need to compile it on a linux machine?
  2. This device obviously has a "brother" to pair to, does it also need to be on OpenWRT to work?
  3. Will I get a flashing led to confirm it is in pairing mode?

Thank you

You'll need to install a package and then map the button to it. Information is under the BTN_1 section. This is not a feature that is present by default on OpenWrt.

You'll build the image on a computer (ideally a linux box) and then copy the image file to the router. On the router, you'll run the sysupgrade command which will flash the device with the image you've copied over. Details here.

Honestly I don't know. There's no harm in trying it with the stock firmware on one side and OpenWrt on the other... if it doesn't work, you'd probably need to have both sides running the same firmware.

Guessing here... probably not. The LEDs are software controlled, and so you'd need to tell the PLC utils software to blink the LED. I could be wrong, though.

Can you elaborate a bit more on how to do this? Like where to map the button?


The package that needs to be installed and code to set it up with the button is all shown in the link. Is the info there unclear? If so, where are you stuck/confused?

Ok sorry gotcha,

yea ok i tried that, still no luck from the button.

to be honest I can just flash this device back to stock as I dont need openwrt on them anymore.

Can you help me with that process?

how can I download the tplink-safeloader on linux? wget?

I am just getting an error when trying to compile?

gcc tplink-safeloader.c

TP-Link Stock Firmware Converter (

that doesnt work

Where do I run this command? On the device itself with openWRT?

staging_dir/host/bin/tplink-safeloader -z wpa8631pv3_eu-up-ver3-0-0-P1-20210514-rel45003-APPLC.bin -o oem-sysupgrade.bin

You run on the machine where your copy of tplink-safeloader exists.

I may be mistaken; but the Wiki says:

using the tool tplink-safeloader from the OpenWrt Image Builder

So, what are you compiling?

Why don't you run plctool manually to join the network? If that works, you can map it to the button. I have the predecessor of this device and I never mapped it to the button because I simply don't need it. You could even run plctool on your computer connected to the LAN port.

Going back to stock, what exactly didn't work with the web-based stock firmware converter? Did you get an error message from it or when trying to sysupgrade? Just saying "it doesn't work" is not really helpful.

1 Like

Nah it just spits the file out at 0kb in size.

Then I read somewhere its for v4 devices or above only.

Ill give the plctool a shot but ideally I want to go back to original firmware as this device wont really be used for anything special.

sorry where is the OpenWrt Image Builder, is it on the device itself as part of the OpenWRT firmware?

When browsing:


Ok sorry and where does this get installed? Is it a binary or source?