Cannot see hosted service with external IP and NAT loopback

I've tried following this guide here: https://unix.stackexchange.com/questions/282086/how-does-nat-reflection-nat-loopback-work
My iptables look like this now:

# Generated by iptables-save v1.8.7 on Sun May 29 21:01:58 2022
*nat
:PREROUTING ACCEPT [0:0]
:INPUT ACCEPT [0:0]
:OUTPUT ACCEPT [0:0]
:POSTROUTING ACCEPT [0:0]
:DOCKER - [0:0]
[383754:19965003] -A PREROUTING -m addrtype --dst-type LOCAL -j DOCKER
[0:0] -A PREROUTING -s 192.168.1.0/24 -d 67xxxxxxx -i br-lan -p tcp -m tcp --dport 27015 -j DNAT --to-destination 192.168.1.106
[0:0] -A PREROUTING -s 192.168.1.0/24 -d 67.xxxxxxx -i br-lan -p tcp -m tcp --dport 27015 -j DNAT --to-destination 192.168.1.106
[0:0] -A PREROUTING -s 192.168.1.0/24 -d 67.xxxxxxx -i br-lan -p tcp -m tcp --dport 7777 -j DNAT --to-destination 192.168.1.106
[0:0] -A PREROUTING -s 192.168.1.0/24 -d 67.xxxxxxx -i br-lan -p tcp -m tcp --dport 7778 -j DNAT --to-destination 192.168.1.106
[49:2597] -A PREROUTING -s 192.168.1.0/24 -d 67.xxxxxxx -i br-lan -p udp -m udp --dport 27015 -j DNAT --to-destination 192.168.1.106
[12:636] -A PREROUTING -s 192.168.1.0/24 -d 67.xxxxxxx -i br-lan -p udp -m udp --dport 7777 -j DNAT --to-destination 192.168.1.106
[0:0] -A OUTPUT ! -d 127.0.0.0/8 -m addrtype --dst-type LOCAL -j DOCKER
[0:0] -A OUTPUT ! -d 127.0.0.0/8 -m addrtype --dst-type LOCAL -j DOCKER
[0:0] -A POSTROUTING -s 172.17.0.0/16 ! -o docker0 -j MASQUERADE
[0:0] -A POSTROUTING -s 192.168.1.0/24 -d 192.168.1.106/32 -o br-lan -p tcp -m tcp --dport 27015 -j SNAT --to-source 192.168.1.1
[0:0] -A POSTROUTING -s 192.168.1.0/24 -d 192.168.1.106/32 -o br-lan -p tcp -m tcp --dport 7777 -j SNAT --to-source 192.168.1.1
[0:0] -A POSTROUTING -s 192.168.1.0/24 -d 192.168.1.106/32 -o br-lan -p tcp -m tcp --dport 7778 -j SNAT --to-source 192.168.1.1
[0:0] -A POSTROUTING -s 192.168.1.0/24 -d 192.168.1.106/32 -o br-lan -p udp -m udp --dport 27015 -j SNAT --to-source 192.168.1.1
[0:0] -A POSTROUTING -s 192.168.1.0/24 -d 192.168.1.106/32 -o br-lan -p udp -m udp --dport 7777 -j SNAT --to-source 192.168.1.1
[0:0] -A DOCKER -i docker0 -j RETURN
COMMIT
# Completed on Sun May 29 21:01:58 2022

I still can't find my service.

It appears the UDP PREROUTING are the only rules doing anything. So I need a corresponding POSTROUTING rule to solve this?