Cannot scan on 5G on TL-WR902AC

I just installed OpenWRT on my TP-Link TL-WR902AC, and it works except for a few things I am still trying to work out. To begin with the biggest issue: Inability to scan on 5G to create a WISP (2.4G works fine)

# iwinfo wlan0 scan
Scanning not possible

So, when I do just iwinfo I get:
# iwinfo
wlan0 ESSID: "SomeNET_5G"
Access Point: D4:AA:BB:CC:DD:EE
Mode: Master Channel: 116 (5.580 GHz)
Tx-Power: 27 dBm Link Quality: 68/70
Signal: -42 dBm Noise: -115 dBm
Bit Rate: 6.0 MBit/s
Encryption: WPA2 PSK (CCMP)
Type: nl80211 HW Mode(s): 802.11nac
Hardware: 168C:0050 0000:0000 [Generic MAC80211]
TX power offset: unknown
Frequency offset: unknown
Supports VAPs: yes PHY name: phy0

wlan1 ESSID: "MyWiFi"
Access Point: D4:AA:BB:CC:DD:EF
Mode: Client Channel: 11 (2.462 GHz)
Tx-Power: 17 dBm Link Quality: 62/70
Signal: -48 dBm Noise: -88 dBm
Bit Rate: 39.0 MBit/s
Encryption: WPA2 PSK (CCMP)
Type: nl80211 HW Mode(s): 802.11bgn
Hardware: unknown [Generic MAC80211]
TX power offset: unknown
Frequency offset: unknown
Supports VAPs: yes PHY name: phy1

wlan1-1 ESSID: "SomeNET"
Access Point: D6:AA:BB:CC:DD:EF
Mode: Master Channel: 11 (2.462 GHz)
Tx-Power: 17 dBm Link Quality: unknown/70
Signal: unknown Noise: -88 dBm
Bit Rate: unknown
Encryption: WPA2 PSK (CCMP)
Type: nl80211 HW Mode(s): 802.11bgn
Hardware: unknown [Generic MAC80211]
TX power offset: unknown
Frequency offset: unknown
Supports VAPs: yes PHY name: phy1

/etc/config/wireless:
config wifi-device 'radio0'
option type 'mac80211'
option hwmode '11a'
option path 'pci0000:00/0000:00:00.0'
option htmode 'VHT80'
option channel 'auto'
option legacy_rates '1'
option country 'NL'
option noscan '1'

config wifi-iface 'default_radio0'
option device 'radio0'
option network 'lan'
option mode 'ap'
option ssid 'SomeNET_5G'
option encryption 'psk2'
option key 'MyWiFiPass'

config wifi-device 'radio1'
option type 'mac80211'
option path 'platform/qca953x_wmac'
option disabled '0'
option channel '11'
option country 'NL'
option noscan '1'
option legacy_rates '0'
option hwmode '11g'
option htmode 'HT40'

config wifi-iface 'default_radio1'
option device 'radio1'
option network 'lan'
option mode 'ap'
option ssid 'SomeNET'
option encryption 'psk2'
option key 'MyWiFiPass'

config wifi-iface
option network 'wwan'
option ssid 'MyWiFi'
option encryption 'psk2'
option device 'radio1'
option mode 'sta'
option bssid '50:ZZ:YY:XX:WW:7A'
option key 'RhuideanAiel'
option disassoc_low_ack '0'

If you aren't on a DFS channel, I assume the scanning works fine?
I've seen this before on other devices.

Damn, I thought it was on a non-DFS channel... You are correct, that was it...

2 Likes

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.