Cannot satisfy the following dependencies for kmod-nf-nathelper-extra

Hello,

I am getting a weird error, since the versions are the same...

root@digi:~# opkg install kmod-nf-nathelper-extra 
Installing kmod-nf-nathelper-extra (4.14.63-1) to root...
Downloading http://cdn.corifeus.com/openwrt/18.06.1/targets/mvebu/cortexa9/packages/kmod-nf-nathelper-extra_4.14.63-1_arm_cortex-a9_vfpv3.ipk
Collected errors:
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-nf-nathelper-extra:
 * 	kernel (= 4.14.63-1-cf9aa3d8a5c1a024d789c6f82b2f3737) * 	kernel (= 4.14.63-1-cf9aa3d8a5c1a024d789c6f82b2f3737) * 
 * opkg_install_cmd: Cannot install package kmod-nf-nathelper-extra.
root@digi:~# 

How come? The exact versions, still it does not allow to install the package.

messages in the output of opkg generally mean that the kernel version you have installed is not the same as the repo from which you're drawing packages. Very often this is due to a "new" build's packages being posted after you installed.

http://cdn.corifeus.com/ suggests that you're not using an OpenWrt-project build. You may need to contact the person responsible for that custom build. (Or re-flash with the build version that is "current" for that source)

thanks, the build git versions were mixed up, now it is perfect. thanks very much!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.