Cannot ping devices in the same local network

Your laptop is 192.168.3.x?

No, that ip range is being given by the AP adapter of the OpenWRT.
I'm not using that interface.

It's connected to my router as a wifi client

The only lan I see is called wlan. It is a bridge but has no ethernet in it. I see the radios are in wlan.

Where is the interface for ethernet?

And the firewall... someone better than me needs to look at this.

In this instance, I'm not using ethernet.
The interface being used is the wifi client (wwan) interface.

The ethernet is connected between my PC and my router.
My OpenWRT device is connected via wifi to the same router.

Okay, can you diagram the whole network; things just got complicated.

For illustration purposes, I added IP info similar to my local network, but changed the first 2 octets for security reasons

Read this and make sure windows firewall is not blocking ping.

That worked.

1 Like

Glad to help.

It blocks ping by default. This should be the solved answer.

I don't see an option for resolved. Maybe because I wasn't the original post?
Do you see anything in my configurations that would prevent a ping to

You can't because you are not the OP.

try to ping That is If you get a ping it is a DNS issue..

It works using DHCP, but not a static IP

What have you put as your DNS server in the static config?

I have as the DNS

use and try again.

Same result using as the DNS

Does the gateway have a DNS assigned? Whatever router you are using.

If yes, use the gateway ip address as DNS server. Try again.

Setting DNS to the gateway IP also has no effect.
Also removing the DNS entry altogether doesn't work.

But you can surf so it seems isolated and I would not worry about it.

It is not like your ping time will vary wildly after the first hop to the gateway.