Cannot ping AP or STA

I have OpenWRT on two TP-LINK routers. One is AP and the other is STA. I use hostapd to run the AP in AP mode and wpa_supplicant to run the STA. Both of them work through wlan2 interface. The content of /etc/config/wireless for AP is:

config wifi-device 'radio2'
	option type 'mac80211'
	option path 'soc/1b900000.pci/pci0002:00/0002:00:00.0/0002:01:00.0'
	option freq '60480'
	option disabled '0'

config wifi-iface 'default_radio2'
	option device 'radio2'
	option encryption 'none'
	option mode 'ap'
	option network 'wlan2'
	option ifname 'wlan2'
	option ssid 'Mobicom1'

For STA it is:

config wifi-device 'radio2'
	option type 'mac80211'
	option path 'soc/1b900000.pci/pci0002:00/0002:00:00.0/0002:01:00.0'
	option freq '60480'
	option disabled '0'

config wifi-iface 'default_radio2'
	option device 'radio2'
	option encryption 'none'
	option mode 'sta'
	option network 'wlan2'
	option ifname 'wlan2'
	option ssid 'Mobicom1'

The contents of /etc/config/network for AP is

config interface 'wlan2'
	option ifname 'wlan2'
	option proto 'static'
	option ipaddr '192.168.100.2'
	option netmask '255.255.255.0'

And for the STA:

config interface 'wlan2'
	option ifname 'wlan2'
	option proto 'static'
	option ipaddr '192.168.100.3'
	option netmask '255.255.255.0'

The contents of hostapd config file:

ctrl_interface=/var/run/hostapd
interface=wlan2
driver=nl80211
logger_syslog=-1
logger_syslog_level=2
logger_stdout=-1
logger_stdout_level=2
ssid=Mobicom1
country_code=US
hw_mode=ad
channel=2

The contents of wpa_supplicant config file:

network={
                frequency=60480
                ssid="Mobicom1"
                key_mgmt=NONE
}

I cannot ping any of them from the other device. I have tried using ifconfig wlan2 192.168.100.2 netmask 255.255.255.0 up but it did not work.

What's the model and revision of the router? Do they support WDS? Or you don't want to use WDS?

What is that "option freq"? I have never seen it before, and it does not appear on the documentation.

2 Likes

It's TP-LINK Talon AD7200. I don't want to use WDS. It should work as it is.

That specifies the frequency at which the radio works.