Cannot Mount NTFS USB3 drive over 2TB in 21.02

WRT3200ACM with OpenWRT 21.02.1
Installed: block-mount and kmod-fs-ntfs
When attempting to MOUNT a Seagate 5TB USB3 drive formatted NTFS, I get the System Log error:

kern.err kernel: [ 130.763669] ntfs: (device sda2): parse_ntfs_boot_sector(): Volume size (5TiB) is too large for this architecture. Maximum supported is 2TiB. Sorry.

This combination worked in 19.07 to mount to this same drive.

Presumably you've been using ntfs-3g previously, not the old in-kernel NTFS module (which is rather unmaintained and supports only very basic write access; kernel >=5.15 will ship with the new ntfs3 driver developed by Paragon Software).

Yes I used ntfs-3g in 19.07. Correct me if I am wrong but ntfs-3g does not contain anything that allows the Mounting of the drive. I tried using just block-mount and ntfs-3g and could not mount the drive.

ntfs-3g run fine also with 21.02 version

i use blkid block-mount e2fsprogs fstools
kmod-fs-autofs4 kmod-fs-ext4 kmod-fs-reiserfs kmod-fs-vfat kmod-usb-core kmod-usb-storage kmod-usb-storage-extras kmod-usb3 kmod-usb-storage-uas lsblk ntfs-3g

mount points in luci -> anonymous mount automount swap automount filesystems check files

after reboot mount all disks / partitions is automatic

not use kmod-fs-ntfs

luci samba
network share tag name: for me USB
path /mnt

Did you format the drive by chance? The 2tb limit refers to partition size rather than drive size, so if you had multiple partitions less than 2tb before and reformatted to one partition of 5tb that would explain the error.

You state "not use kmod-fs-ntfs".
Without kmod-fs-ntfs there is not a mount utilty for ntfs.
ntfs-3g does not provide the ntfs mount capability.

The drive has always been a single 5TB partition. That has not changed.

sorry but i have always installed only ntfs-3g + the kmod's indicated
the mounting of all my disks has always been automatic and are writeable without script

# opkg list_installed | grep ntfs
ntfs-3g - 2021.8.22-2-fuseint
ntfs-3g-utils - 2021.8.22-2-fuseint

# ls -al /sbin/mount.ntfs-3g 
lrwxrwxrwx    1 root     root            18 Nov  7 05:14 /sbin/mount.ntfs-3g -> ../usr/bin/ntfs-3g

# opkg search /sbin/mount.ntfs-3g
ntfs-3g - 2021.8.22-2-fuseint