"Cannot install package uwsgi" with 23.05.0

I have Linksys WRT1900AC v1 / Linksys Mamba and Xiaomi Redmi Router AX6000 (OpenWrt U-Boot layout). Both are currently running 23.05.0-rc4 which was gradually upgraded from earlier versions. Both are running luci-ssl-nginx among other things.

Now I cannot request a build of 23.05.0 (released version) with luci-ssl-nginx. I tried requesting a build both via firmware selector (by customizing packages) and via attended sysupgrade. It ends up with the same error either way.

Collected errors:
 * pkg_hash_check_unresolved: cannot find dependency uwsgi for nginx-mod-luci
 * pkg_hash_check_unresolved: cannot find dependency uwsgi-luci-support for nginx-mod-luci
 * pkg_hash_fetch_best_installation_candidate: Packages for nginx-mod-luci found, but incompatible with the architectures configured
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for luci-ssl-nginx:
 * 	uwsgi
 * 	uwsgi-luci-support
 * opkg_install_cmd: Cannot install package luci-ssl-nginx.
make[2]: *** [Makefile:189: package_install] Error 255
make[1]: *** [Makefile:154: _call_manifest] Error 2
make: *** [Makefile:274: manifest] Error 2

Interestingly, even requesting a previous build (such as 23.05.0-rc3 or 23.05.0-rc4) now fails with the same error. (Of course, if I remove luci-ssl-nginx from the list of packages, build passes. But that's not what I mean to install.)

So, apparently, there's some issue with uwsgi that was introduced very recently.

1 Like
1 Like

Hi there!

Still not working for me on ipq40xx/generic and OpenWrt 23.05.0 when trying to install luci-ssl-nginx. Had no issues with previous versions :-(.

LuCI with OpenSSL as the SSL backend (libustream-openssl). OpenSSL cmd tools (openssl-util) are used by nginx for SSL key generation.

Required dependency package uwsgi is not available in any repository.
Required dependency package uwsgi-luci-support is not available in any repository.

Obiously the build failed? https://downloads.openwrt.org/releases/faillogs-23.05/arm_cortex-a7_neon-vfpv4/packages/

Update: download uwsgi* from here: https://downloads.openwrt.org/snapshots/packages/arm_cortex-a7_neon-vfpv4/packages/ , copy to /tmp/ and and install manually_

opkg install /tmp/uwsgi-syslog-plugin_2.0.22-1_arm_cortex-a7_neon-vfpv4.ipk
opkg install /tmp/uwsgi-cgi-plugin_2.0.22-1_arm_cortex-a7_neon-vfpv4.ipk
opkg install /tmp/uwsgi-luci-support_2.0.22-1_arm_cortex-a7_neon-vfpv4.ipk

opkg install nginx-ssl nginx-ssl-util luci-nginx nginx-mod-luci


Thanks. I have not tried your proposed solution, because I'm a little bit worried about performing upgrade from luci-ssl-nginx-enabled build to the one without the package. It sounds like a lot of configurations may get out of order with this change.

Do you think there's a hope for a fix to eventually make it to Firmware Selector so that the package can be embedded into sysupgrade image? Or my best bet is to wait for a new version, say, 23.05.1?

Hopefully configurations remain! I installed it like that (pulling uwsgi from snapshot and installing after copying to OpenWRT, afterwards an opkg install of nginx from the "official" repository) and currently luci is served via nginx :-). I was hoping that uwsgi will be fixed in the current release as well, but I'm not sure who could take care of that. 23.05.1 should fix it, for sure (as it works in the current snapshot versions) - there was just a build issue!
Remark: I'm not sure whether your architecture is cortex-a7_neon-vfpv4 as well, if not you would need a different download path...

For the time being I try to configure nginx for domain forwarding - but always fail (I failed with rc versions as well, so not related to the uwsgi "workaround" but rather a user problem :slight_smile: ).

Ok, I've been checking for a few days, and finally image generation (with all of my requested packages) succeeded today as normal, via firmware selector. Upgraded successfully via attended sysupgrade. I guess, the issue is now officially resolved. Thanks everyone who helped!

1 Like