Cannot install package luci

router: TP-Link Archer C59 v2
OpenWrt device page:

I had OpenWrt and luci GUI installed fine, but encountered a problem so I reset the firmware (using the reset button on the router). Afterwards, I could not connect to luci GUI ("page cannot be displayed), so I used PuTTY (SSH) to log in and issue commands "opkg update" and "opkg install luci" but get error "cannot install package luci".

I then performed sysupgrade to 19.07.1 firmware listed on the OpenWrt product page (see above) and tried again to install luci, but still getting same error.

Collected errors:
 * opkg_download: Failed to download, wget returned 8.

Collected errors:
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for luci:
 *      libiwinfo20200105
 * opkg_install_cmd: Cannot install package luci.

19.07.1 includes LuCI.

Have you tried a simple factory reset?

Otherwise, try using sysupgrade to install 19.07.1 again, but add ' -n ' to the command line.

eg. sysupgrade -n /tmp/****sysupgrade.bin


"sysupgrade -n" did the trick... thank you so much :slight_smile:

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.