Cannot install package: kmod-nf-nathelper-extra


I have problem to install kmod-nf-nathelper-extra package for multiply PPTP connections:

Installing kmod-nf-nathelper-extra (4.4.92-1) to root...
Collected errors:
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-nf-nathelper-extra:
 * 	kernel (= 4.4.92-1-45d282495a15974d60f8edb091d0e2a9) * 	kernel (= 4.4.92-1-45d282495a15974d60f8edb091d0e2a9) * 
 * opkg_install_cmd: Cannot install package kmod-nf-nathelper-extra.

I have version:
LEDE 17.01.4
Кernel Version 4.4.92

cat /etc/openwrt_version

Try this on command line:

opkg update
opkg install kmod-nf-nathelper-extra --force-depends

I can't see anything wrong from your output, except perhaps upgrading to 17.01.5.

Out of curiosity, why are you running a 1+ yr old firmware that is no longer supported? It would be more beneficial to you to upgrade to OpenWrt 18.06.1.

  • The dependency issue is likely due to buildbot compiling new packages over a year ago and one of the required dependencies required for kmod-nf-nathelper-extra is compiled against a different kernel version.
    • General rule of thumb: If you don't know precisely why you're receiving a dependency satisfaction error, forcing the installation of the package isn't a good idea since it can wreck havoc, and brick, a router when dealing with kernel mods.

  • Easiest, most efficient, and secure solution: upgrade to the most current firmware version, 18.06.1
1 Like

OK, i upgrade to last version:

|Firmware Version|OpenWrt 18.06.1 r7258-5eb055306f / LuCI openwrt-18.06 branch (git-18.228.31946-f64b152)|
|Kernel Version|4.9.120|

but i don't see "Services" tab to configure\safe remove "USB devices".
How to manage USB devices in new version?

OK, I need to install SMB packages:

opkg update
opkg install luci-app-samba

This appears unrelated to your original PPTP question. In the future, please make a new thread for each inquiry.

1 Like