Cannot install LEDE on Linksys EA8500

Linksys router is on stock firmware v1.1.7.182977

Trying to install LEDE firmware downloaded from here:

I am getting this error: "This firmware file won't work on this router. If you downloaded it from it might have become corrupted. Please try downloading the file again."

I tired downloading again and the same error. I did do a checksum of the file and it was matching.

Btw I also tried to downgrade the router to stock v1.1.4.169978 and I am getting the same error. The only file that is not giving me any error is the latest stock firmware v1.1.7.182977.


1 Like

Try using TFTP.

There are several tutorials on YouTube...

Looks like its on a locked firmware from version Need to get a USB to TTL cable for loading other firmwares:

Now thinking whether to return it and get something else or buy the cable! :slight_smile:

Get the firmware past a certain point. I tried it on 1.1.5.x and it worked fine. This guides says to get it to at least .

I am on v1.1.7.182977. Another post talking about the same issue:

The router won't allow me to downgrade to v1.1.4.169978!

Try downgrading to one of the 1.1.5.x OSes. If nothing else, there are instructions on the page I linked tell you how to do the other ways if the easy way doesn't work.

I managed to implement mrjcd's instructions that OP mentioned above on one of my two EA8500 routers, but I replaced the stock firmware with DD-WRT (as did mrjcd), and implementing those superb instructions was a pain; I did this before I discovered LEDE.

I'm guessing the same procedure would work with the LEDE firmware instead of the DD-WRT firmware, but have not tried this yet.

Hope this helps.

@risole opened new thread here...

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.