Cannot enter LUCI with official 23.05.02 x86_64 image running in a VM

version: 23.05.02
arch: x86_64
device: unRaid VM

I tried official download image and compile official tag v23.05.02 image. Both were connectable via SSH and stuck at "LuCI - Lua Configuration Interface".

I am sure that luci and uhttpd are installed and working normally, and there is no port conflict with uhttpd. And I disabled all ipv6 setting on lan( even not disabled can't get in LUCI either). Because i use ipv4 in LAN and access LUCI via ipv6 got error code 502 in F12 console.

using uhttpd default config

sounds like a client issue to me....

i tried firefox and chrome both can't access

You changed the subenet address of OpenWrt
OpenWrt has gone into DHCP server mode and your device is in the wrong subnet because it is not receiving DHCP from router.

One way or another the browser is in a different subnet than OpenWrt.



Your network was using 192.168.x.1 but now the network is using 192.168.y.1.

what @LilRedDog said.

try the IPs using an incognito tab in your browser.

The SSH connection between openwrt and other devices may prove that they are on the same subnet,

I disabled openwrt DHCP server because i had a main router as DHCP server. And i set static IP(192.168.3.x) to all important devices( main router, PC, unRaid, openwrt etc).

Besides, i tried openwrt default IP( and set PC's IP( g、Gateway( Same as when ip is 192.168.3.x can connect via SSH and stuck at LUCI

I tried an incognito tab in both Firefox and Chrome, stuck same as before is the most insane router address I have ever seen.

But, if you insist.

the '120' have special meaning to me for easy memory :joy:

1 Like

The router is not there or you are not in the 192.168.3.x subnet

Due to the connection between PC and openwrt . Them should in same subnet.

Well, your browser disagrees.

Does not really matter what I think, convince Chrome.

Just for fun, run ipconfig in command prompt and send the screenshot.

1 Like

What's the output of service uhttpd info?

openwrt ifconfig and ping PC

PC ipconfig and ping openwrt

ipconfig says local address is and the gateway is
You are pinging yourself?

Please clean up/reconcile your configurations' outputs against what you think it is supposed to be configured as.

IOW: Why do you think LuCI is @ when your PC thinks the gateway is @

1 Like

aaaand if you by accident connected the wan port of the openwrt device to an exisiting lan, you won't get anywhere - there's a firewall in place.


plus, the whole thing appears to be running in a VM.

get the VM out of the equation, boot openwrt off an USB flash drive, see if it works on bare metal.


Right, and what's the output of service uhttpd info?

1 Like