Cannot enable 80211v on 5G radio

Hi... I installed openwrt on TpLink Archer A7 router, and now i'm trying to enable band steering with usteer... I changed wpad-mbedtls to wpad package, installed usteer and when i tried to put these lines on /etc/config/wireless file (ifaces section of LMFCAB SSID):

option bss_transition '1'
option ieee80211k '1

And restart wireless with wifi instruction, only 2.4G interface is enabled, and 5G interface is disabled:

If I comment option bss_transition '1' instruction on 5G SSID, 5G iface goes online

Anyone has a clue about what is happening? this is my /etc/config/wireless:

config wifi-device 'radio0'
        option type 'mac80211'
        option channel '48'
        option hwmode '11a'
        option path 'pci0000:00/0000:00:00.0'
        option htmode 'VHT80'
        option cell_density '0'
        option country 'CO'
        option beacon_int '97'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'LFAMCB'
        option encryption 'psk2+ccmp'
        option key 'xxxxxxx'
        option disassoc_low_ack '0'
        #option bss_transition '1'
        option ieee80211k '1'

config wifi-device 'radio1'
        option type 'mac80211'
        option channel '11'
        option hwmode '11g'
        option path 'platform/ahb/18100000.wmac'
        option htmode 'HT20'
        option cell_density '0'
config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid 'LFAMCB'
        option encryption 'psk2+ccmp'
        option key 'xxxxxxxx'
        option bss_trasition '1'
        option ieee80211k '1'

config wifi-iface 'wifinet2'
        option device 'radio0'
        option mode 'ap'
        option ssid 'LFAMCB-GUEST'
        option encryption 'psk2+ccmp'
        option network 'guest'
        option key 'xxxxxxx'
        option isolate '1'

config wifi-iface 'wifinet3'
        option device 'radio1'
        option mode 'ap'
        option ssid 'LFAMCB-GUEST'
        option encryption 'psk2+ccmp'
        option network 'guest'
        option key 'xxxxxxxx'
        option ieee80211r '1'
        option ft_over_ds '0'
        option ft_psk_generate_local '1'
        option isolate '1'

Thanks in advance,

I would recommend against 802.11k/v/r unless you have a demonstrated need for it. It is usually best to allow the client devices to select the band that is best at any given moment based on its own internal logic and the signal quality that it measures.

Some client devices don't work well when you use these standards, and typically they are only useful if you have a very large fleet of APs.

What is shown in the system log when you do "wifi up"? Any errors?

KV can be enabled on the fly IF you have wpad-mbedtls in place of wpad-basic-mbedtls

1 Like

Thanks a lot to everyone... the problem was that I didn't reboot router after replacing wpad-mbedtls with wpad. After a reboot, 5G radio and ifaces are working ok, and k/v protocols are functional (devices are making band steering i suppose using usteer info).

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.