Cannot connect to wireless AP

Hi all. Im having issues with my Netgear wireless extender. Although OpenWrt installs perfectly and can be configured it does not connect and after a while it is impossible to even get to LuCI through wifi or ethernet, TX and RX are both 00 and there is no evidence at all of it working.

I followed the instructions at https://openwrt.org/docs/guide-user/network/wifi/dumbap

My main router in Linksys WRT3200 running rc3, but that is behaving perfectly well. It could be that the unit - bought secondhand on ebay - is defective, but before I throw it out, could someone per has review my configuration (captured before it failed again, as I knew it would...)

root@OpenWrt:~# cat /etc/config/dhcp

config dnsmasq
	option domainneeded '1'
	option boguspriv '1'
	option filterwin2k '0'
	option localise_queries '1'
	option rebind_protection '1'
	option rebind_localhost '1'
	option local '/lan/'
	option domain 'lan'
	option expandhosts '1'
	option nonegcache '0'
	option authoritative '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'

	option nonwildcard '1'
	option localservice '1'
	option ednspacket_max '1232'

config dhcp 'lan'
	option interface 'lan'
	option start '100'
	option limit '150'
	option leasetime '12h'
	option dhcpv4 'server'
	option ignore '1'

config dhcp 'wan'
	option interface 'wan'
	
	option nonwildcard '1'
	option localservice '1'
	option ednspacket_max '1232'

config dhcp 'lan'
	option interface 'lan'
	option start '100'
	option limit '150'
	option leasetime '12h'
	option dhcpv4 'server'
	option ignore '1'

config dhcp 'wan'
	option interface 'wan'
option nonwildcard '1'
	option localservice '1'
	option ednspacket_max '1232'

config dhcp 'lan'
	option interface 'lan'
	option start '100'
	option limit '150'
	option leasetime '12h'
	option dhcpv4 'server'
	option ignore '1'

config dhcp 'wan'
	option interface 'wan'
	option ignore '1'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'
	option loglevel '4'

And...

root@OpenWrt:~# cat /etc/config/wireless

config wifi-device 'radio0'
	option type 'mac80211'
	option path 'pci0000:00/0000:00:00.0/0000:01:00.0'
	option channel '36'
	option band '5g'
	option htmode 'VHT80'
	option cell_density '0'

config wifi-device 'radio1'
	option type 'mac80211'
	option path 'platform/10180000.wmac'
	option channel '1'
	option band '2g'
	option htmode 'HT20'
	option cell_density '0'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option encryption 'psk2'
	option key 'XXXXXX'
	option ssid 'OpenWRT'

config wifi-iface 'wifinet2'
	option device 'radio0'
	option mode 'sta'
	option network 'wwan'
	option ssid 'OpenWRT2'
	option encryption 'psk2'
	option key 'XXXXXX

'And

oot@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdd4:9aa9:2bab::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth0'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ipaddr '10.31.58.1'
	option gateway '10.31.58.250'
	list dns '10.31.58.250'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '0'

config interface 'wwan'
	option proto 'dhcp'

I have cat /etc/config/firewall if that helps too, although, as per instruction, firewall is disabled

The dumb AP setup is for connecting the routers wired via ethernet.

It looks like you want to connect the routers wirelessly?

If so you have to look for a wireless bridge setup e.g.:

WDS is the superior option but between a Netgear and a Linksys this is probably not possible.

Ah!!!! yes, Im connecting wirelessly. Thank you for pointing me in the right direction, I'll give it a go...

1 Like