Cannot connect to ISP using PPPoE (tried multiple things already), 23.05 fw

Hello,

I tried to follow some guides here and on other pages, but I am not successful in getting this to work. It always ends on "connection attempt failed" on the WLAN interface and in the system log it says:

  • No default route present, overriding ra_lifetime
  • Timeout waiting for PADO packets
  • Unable to complete PPPoE Discovery
  • Exit

I tried multiple things, nothing works. What I tried:

*.factory reset router (Flint 2 with vanilla OpenWRT 23.05))

  • delete all default WLANs
  • create a new WLAN interface with custom device name eth1.848 and my credentials
  • create a new device on ETH1 (my wan port) with with VLAN 802.1q and VLAN ID 848, then setting up new WLAN in Interfaces based on this device and setting up my credentials
  • probably couple more, but I factory reset couple of times and start from fresh
  • provider support said that the VLAN ID has to be "tagged", but when creating the new device, I have no option to set up "tagged", I am only able to input the number
  • I can only set up "tagged" when accessing the properties of default br-lan and if I add wan ports (both eth0 and eth1) to that bridge and try to save it, it does not go through

I think there is something going on between my switch on eth0 and wan port on eth1 (wan port of the router). Or maybe I have to setup new bridge somehow. I dunno anymore. Spend couple of hours on it without moving forward.

Any help much appreciated. Thanks a lot.

as asked on reddit, have you already looked for your ISPs name here at the forum ?

there's also https://openwrt.org/docs/guide-user/network/wan/isp-configurations

have you, just to be safe, also cloned the WAN MAC from your old router onto the MT6000 ?

  • I did look for the ISP threads. There is not much, but from those that are available, I wasn't able to get it to work.
  • Basically my configuration should be the same or very similar as here: https://openwrt.org/docs/guide-user/network/wan/isp-configurations#o2, however my ISP did not tell me anything about settings for the DSL like shown there and I dont know (probably) how to set that up in Luci
  • my ISP (different to O2), which is just a provider on top of the underlying ISP providing the 848 VLAN ID (the same goes with O2) said I just need the username, password and VLAN ID 848. (thanks for the link btw)
  • I didnt copy any WAN MAC as I dont have where to copy from - this is a new installation without any previous router

Then post your /etc/config/network and /etc/config/firewall.

I am not sure whats sensitive, so I redacted some stuff

Network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'redacted'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'
        list ports 'lan5'

config device
        option name 'lan1'
        option macaddr 'redacted'

config device
        option name 'lan2'
        option macaddr 'redacted'

config device
        option name 'lan3'
        option macaddr 'redacted'

config device
        option name 'lan4'
        option macaddr 'redacted'

config device
        option name 'lan5'
        option macaddr 'redacted'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config device
        option name 'eth1'
        option macaddr 'redacted'

config interface 'wan'
        option device 'eth1.848'
        option proto 'pppoe'
        option username 'redacted'
        option password 'redacted'
        option ipv6 'auto'

config interface 'wan6'
        option device 'eth1.848'
        option proto 'pppoe'
        option username 'redacted'
        option password 'redacted'
        option ipv6 'auto'

Firewall

config defaults
        option syn_flood        1
        option input            REJECT
        option output           ACCEPT
        option forward          REJECT
# Uncomment this line to disable ipv6 rules
#       option disable_ipv6     1

config zone
        option name             lan
        list   network          'lan'
        option input            ACCEPT
        option output           ACCEPT
        option forward          ACCEPT

config zone
        option name             wan
        list   network          'wan'
        list   network          'wan6'
        option input            REJECT
        option output           ACCEPT
        option forward          REJECT
        option masq             1
        option mtu_fix          1

config forwarding
        option src              lan
        option dest             wan

# We need to accept udp packets on port 68,
# see https://dev.openwrt.org/ticket/4108
config rule
        option name             Allow-DHCP-Renew
        option src              wan
        option proto            udp
        option dest_port        68
        option target           ACCEPT
        option family           ipv4

# Allow IPv4 ping
config rule
        option name             Allow-Ping
        option src              wan
        option proto            icmp
        option icmp_type        echo-request
        option family           ipv4
        option target           ACCEPT

config rule
        option name             Allow-IGMP
        option src              wan
        option proto            igmp
        option family           ipv4
        option target           ACCEPT

# Allow DHCPv6 replies
# see https://github.com/openwrt/openwrt/issues/5066
config rule
        option name             Allow-DHCPv6
        option src              wan
        option proto            udp
        option dest_port        546
        option family           ipv6
        option target           ACCEPT

config rule
        option name             Allow-MLD
        option src              wan
        option proto            icmp
        option src_ip           redacted
        list icmp_type          '130/0'
        list icmp_type          '131/0'
        list icmp_type          '132/0'
        list icmp_type          '143/0'
        option family           ipv6
        option target           ACCEPT

# Allow essential incoming IPv6 ICMP traffic
config rule
        option name             Allow-ICMPv6-Input
        option src              wan
        option proto    icmp
        list icmp_type          echo-request
        list icmp_type          echo-reply
        list icmp_type          destination-unreachable
        list icmp_type          packet-too-big
        list icmp_type          time-exceeded
        list icmp_type          bad-header
        list icmp_type          unknown-header-type
        list icmp_type          router-solicitation
        list icmp_type          neighbour-solicitation
        list icmp_type          router-advertisement
        list icmp_type          neighbour-advertisement
        option limit            1000/sec
        option family           ipv6
        option target           ACCEPT

# Allow essential forwarded IPv6 ICMP traffic
config rule
        option name             Allow-ICMPv6-Forward
        option src              wan
        option dest             *
        option proto            icmp
        list icmp_type          echo-request
        list icmp_type          echo-reply
        list icmp_type          destination-unreachable
        list icmp_type          packet-too-big
        list icmp_type          time-exceeded
        list icmp_type          bad-header
        list icmp_type          unknown-header-type
        option limit            1000/sec
        option family           ipv6
        option target           ACCEPT

config rule
        option name             Allow-IPSec-ESP
        option src              wan
        option dest             lan
        option proto            esp
        option target           ACCEPT

config rule
        option name             Allow-ISAKMP
        option src              wan
        option dest             lan
        option dest_port        500
        option proto            udp
        option target           ACCEPT


### EXAMPLE CONFIG SECTIONS
# do not allow a specific ip to access wan
#config rule
#       option src              lan
#       option src_ip   192.168.45.2
#       option dest             wan
#       option proto    tcp
#       option target   REJECT

# block a specific mac on wan
#config rule
#       option dest             wan
#       option src_mac  redacted
#       option target   REJECT

# block incoming ICMP traffic on a zone
#config rule
#       option src              lan
#       option proto    ICMP
#       option target   DROP

# port redirect port coming in on wan to lan
#config redirect
#       option src                      wan
#       option src_dport        80
#       option dest                     lan
#       option dest_ip          192.168.16.235
#       option dest_port        80
#       option proto            tcp

# port redirect of remapped ssh port (22001) on wan
#config redirect
#       option src              wan
#       option src_dport        22001
#       option dest             lan
#       option dest_port        22
#       option proto            tcp

### FULL CONFIG SECTIONS
#config rule
#       option src              lan
#       option src_ip   192.168.45.2
#       option src_mac  redacted
#       option src_port 80
#       option dest             wan
#       option dest_ip  194.25.2.129
#       option dest_port        120
#       option proto    tcp
#       option target   REJECT

#config redirect
#       option src              lan
#       option src_ip   192.168.45.2
#       option src_mac  redacted
#       option src_port         1024
#       option src_dport        80
#       option dest_ip  194.25.2.129
#       option dest_port        120
#       option proto    tcp

Who exactly is your provider (link to service you pay for)

We cannot bindly guess between 4k vlans

padi/pado is used to discover pppoe concentrator, message means it failed.

My provider is https://www.cetin.cz/. Their VLANID is 848. The connection should be the same or similar to what I found above in this link: https://openwrt.org/docs/guide-user/network/wan/isp-configurations#o2 (it points to a provider called O2, they are selling licence, but use the network of Cetin).

Also not sure it helps, but my router is connectin to Zyxel terminator, which is connected to their modem.

no ipv6 according to google

---https://www.cetin.cz/documents/105239/0/4_ZTE+H6645P_Základní+nastavení_logo%2C+open.pdf

Allright, that would mean I can disable Wan6. But what about IpV4 WAN? How does that influence it?

Post log fragments when restarting WAN. Probably you need to wait some cooldown period after trying to make two pppoe sessions at once.

Has the userid of PPPoE been used elsewhere before using it on the openwrt?
If so then copy the WAN MAC address of the previous router in the openwrt.

Or call the ISP for accepting new MAC address of the openwrt router.

Unpower CPE, when that is UP start OpenWRT with WAN disables, and enable WAN.

Well I am not 100% sure about this one, but the userID according to my ISP shoudnt even matter at all at this point. I personally connected to this with a completely new connection. It was just installed today.

Also, according to them, they are not blocking any new mac address.

No matter what I did, I always got to the same point of this.

No default route present, overriding ra_lifetime
Timeout waiting for PADO packets
Unable to complete PPPoE Discovery
Exit

And I tried like 10 different ways how to work it out. Then I went back to stock settings and tried again. I must be doing something wrong and I suspect it will have something with switch between lan or wan or something.

Theoreticaly, is it possible I am missing some package?

Nope, pppoe is installed in default image.

I tried to switch eth1 to eth0 for the PPPoE connection and got some different results from the log:

daemon.notice netifd: VLAN 'eth0.848' link is up
daemon.notice netifd: Interface 'wan' has link connectivity
daemon.notice netifd: Interface 'wan' is setting up now
daemon.notice netifd: Network device 'eth1' link is down
daemon.info pppd[21890]: Plugin pppoe.so loaded.
daemon.info pppd[21890]: PPPoE plugin from pppd 2.4.9
daemon.notice pppd[21890]: pppd 2.4.9 started by root, uid 0
daemon.info dnsmasq[1]: read /etc/hosts - 12 names
daemon.info dnsmasq[1]: read /tmp/hosts/dhcp.cfg01411c - 4 names
daemon.info dnsmasq[1]: read /tmp/hosts/odhcpd - 2 names
daemon.info dnsmasq-dhcp[1]: read /etc/ethers - 0 addresses
daemon.warn odhcpd[1984]: No default route present, overriding ra_lifetime!

Not sure if this leads anywhere. I still feel like the PPPoE connection might be set up almost correctly either on eth1 or eth0, but maybe I need to setup some interface or bridge correctly, so it takes tagged traffic from the terminator or something like that and then distributes it where it should?

You have to figure out which port is connected where.

I mean, there are only two ports connected. Terminator to router - WAN. Eth0/Eth1, the same physical port. Then there is only my PC connected to router on LAN port. Nothing else connected.

i had similar issue,maybe it could help: VLAN tagging, and VLAN tag 10 on Openwrt 23.05.5 - #6 by brada4

1 Like

The discovery packets are small, MTU comes in play with bulk transfers.

The essence: add 11Q VLAN separately, then use that interface. Wire protocol is same but you have more control e.g. about MTU at each pass.