Cannot connect to freshly flashed access point

I am new to OpenWrt. I just flashed my TP-Link AP EAP245 v1 following instructions at:;a=commit;h=b11ad48764404d6eefc01b5acf9e54c9f6f00973

using factory firmware at:

I got the upgrade result:

./uclited-patched -u

Begin Debug Mode Fireware Upgrade
Upgrade fireware size is 5268643 bytes
Upgrade fireware md5 checksum is correct!
Now upgrade fireware...
Firmware upgrade successfully! Please reboot manually.

I then unplugged and replugged the AP. After it booted, I cannot access it at either directly connected to the computer with static ip, or connected it to a spare router with DHCP. With the router, I used the computer to access the router DHCP list which only listed the computer. The AP status LED is green (AP must be in working order?)

I just connected the AP to the "live" router (network 192.168.0.XXX) and I could see the AP listed as:
Hostname: Unknown(unknown)
IP adress: fe80::52c7:bfff:fe76:e5
Type: Self-assigned

Try using http://[fe80::52c7:bfff:fe76:e5] in Chrome but "Site can't be reached".

Any help would be appreciated.

@nano69an, welcome to the community!

Did you flash a Snapshot?

(They don't have a web GUI, you must install it.)

Can you ping

1 Like

Yes this snapshot firmware:

Ping us unreacheable for and many others.

What's your ip, when you do the ping?

My computer is set to static ip when connected directly to the AP. I also connected to a spare router with ip, and it provides my computer with ip (computer set to receive ip from DHCP server from the router). Ping failed for both situation.

Did I brick the AP by unplugging it after successfully flashed the firmware? I should have used "reboot" command. But then the router shows the internet is active for this AP but there is no ip address.

I ping from a computer with ip
Don't what to do now... I think the AP is bricked but how can I tell? Can someone confirm? My router said the port connected to this AP is active. But there is no ip address so I can't access it.
I don't know what device used to debrick from this instruction:

* Serial port can be soldered on PCB J3 (1: TXD, 2: RXD, 3: GND, 4: VCC)
    * Bridge unpopulated resistors R225 (TXD) and R237 (RXD).
      Do NOT bridge R230.
    * Use 3.3V, 115200 baud, 8n1
* Interrupt bootloader by holding CTRL+B during boot
* tftp initramfs to flash via the LuCI web interface
    setenv ipaddr # default, change as required
    setenv serverip # default, change as required
    tftp 0x80800000 initramfs.bin
    bootelf $fileaddr

Appreciate some help.

if you want to connect to the serial console, you'll need an USB TTL 3.3v adapter.

something like this

you could also try using arp on your computer, and assign an IP to the device.

From the looks of it, installing the factory firmware upgrade worked. Replugging the AP should be the same as rebooting it, there isn't any unmounting of disks to be done, or things like that.

Can you ping the LL IPv6 address you're seeing? Note that you may need to add the interface name, because link-local addresses can be on any link:

$ ping -6 fe80::52c7:bfff:fe4f:e0a6
PING fe80::52c7:bfff:fe4f:e0a6(fe80::52c7:bfff:fe4f:e0a6) 56 data bytes
ping: sendmsg: Invalid argument

$ ping -6 fe80::52c7:bfff:fe4f:e0a6%enp0s31f6
PING fe80::52c7:bfff:fe4f:e0a6%enp0s31f6(fe80::52c7:bfff:fe4f:e0a6%enp0s31f6) 56 data bytes
64 bytes from fe80::52c7:bfff:fe4f:e0a6%enp0s31f6: icmp_seq=1 ttl=64 time=0.808 ms

The same probably holds for the http connection to the bare IPv6 address.

Edit: Looks like Firefox doesn't support LL IPv6 addresses, don't know the situation on Chrome.

As suggested, tried ping with IPv6 address but destination not reachable.
Also tried this but nothing is displayed on the tftpd log viewer window.
OK I will try to debrick with with the debrick instructions below. I will have to buy the USB TTL 3.3v adapter.

I don't fully understand the debrick instructions. Here is what I think the steps are:

Hardware mod:

  • Open EAP245v1
  • Connect USB TTL addapter to PCB J3 (1:TX, 2:RX, 3:GND, 4:3.3V)
  • Solder coper wire from R237 to connect RX
  • Solder coper wire from R225 to connect TX
  • Connect an ethernet cable between your computer and one of the LAN ports
  • Set computer IP address to static

Client side (connected via serial to the EAP245):

  • When the boot starts, hit ctrl-b key to stop autoboot.
  • enter commands:
setenv serverip
setenv ipaddr

Server side:

  • Copy "openwrt-ath79-generic-tplink_eap245-v1-squashf-factory.bin" to folder "/tmp"
  • Start TFTP with command (correct command?):
# dnsmasq --port=0 --enable-tftp --tftp-root=/tmp --tftp-no-blocksize --user=root --group=root

I am lost from here... How do I get the firmware to program the EAP245 at address 0x80800000? What are the commands for:

tftp 0x80800000 initramfs.bin
bootelf $fileaddr

Thank you for any help.

Instead of http you should try ssh. Since snapshots have no http interface. You will have to include the name of the interface on your computer that is connected to the network as well, with %eth0 at the end etc

ssh returned a timeout message after a few minutes:
ssh: connect to host fe80::52c7:bfff:fe76:e5%wlx0022758ee757 port 22: Connection timed out.

Tried: nmap -v -Pn -6 fe80::...

Scanning fe80::52c7:bfff:fe76:e5 [1000 ports]
Connect Scan Timing: About 15.50% done; ETC: 17:50 (0:02:49 remaining)
Connect Scan Timing: About 30.50% done; ETC: 17:50 (0:02:19 remaining)
Connect Scan Timing: About 45.50% done; ETC: 17:50 (0:01:49 remaining)
Connect Scan Timing: About 60.50% done; ETC: 17:50 (0:01:19 remaining)
Connect Scan Timing: About 75.50% done; ETC: 17:50 (0:00:49 remaining)
Completed Connect Scan at 17:50, 201.37s elapsed (1000 total ports)
Nmap scan report for fe80::52c7:bfff:fe76:e5
Host is up.
All 1000 scanned ports on fe80::52c7:bfff:fe76:e5 are filtered

Read data files from: /snap/nmap/2280/bin/../share/nmap
Nmap done: 1 IP address (1 host up) scanned in 201.65 seconds

What to do now?

It has worked for me since Firefox enabled IPv6 support. But it is true that you cannot specify an interface in your URL though - nor can you in Chrome either. Unless I misunderstood your post, it just doesn't match the information you linked from Mozilla BugZIlla.

Maybe it could work if you only have one IPv6-capable interface? Bare IPv6-addresses work, but since you can't specify a zone-id (which is what the Mozilla ticket is about), I wouldn't expect a bare IPv6-LL address to work in Firefox.

You'll need to copy the OpenWrt initramfs file, not the factory install file, to /tmp (note the destination filename)

cp tplink_eap245-v1-initramfs-kernel.bin /tmp/initramfs.bin

Then, on the serial console you should be able to run the tftp and bootelf commands as you listed before. The filename used for the tftp command should match the one of the file present in your TFTP-root (i.e. your /tmp directory).