Cannot connect to Batman Mesh

Guys,

i would like to learn more about Mesh network (with Batman-ADV), in order not to mess up the home network i dug out the old TP-link 1043 and used that for my experiments
I understand that it is a not recommended router (v1) and that it makes little sense to have only 1 node, but the idea is that if i start small i use this setup as a proof-of-concept without getting lynched by the family if something fails :wink:

current setup: ISP modem with DMZ, openwrt on archer c7 routing guest/standard wifis, laptop/pc/mobiles scattered around the house
mesh attempt: ISP modem with DMZ, openwrt on 1043 with mesh/batman enabled, laptop connected to mesh
mesh target: ISP modem with DMZ, openwrt on archer c7 with mesh/batman enabled, unused routers (like the 1043) working as mesh node in the different rooms, laptop/pc/mobiles connected to the mesh

unfortunately i cannot get my laptop to connect to the mesh

I initially though that the problem was with authentication and the candela firmware, so i removed encryption and i installed the non ct kmod-ath10k

but still i cannot get any connection, the laptop sees the mesh as a "normal" wifi, but no connection is established.
as it happened in the past, i probably made some silly mistake and i would really appreciate if someone could point me in the right direction

sorry if my explanation is not extremely clear, i hope this is enough to give you an idea of what i am trying to accomplish, if more info is needed please let me know

thanks in advance

M

openwrt version on 1043: OpenWrt SNAPSHOT, r11237-d1072096f4

i installed kmod-batman-adv, wpad-mesh-openssl, batctl
removed wpad-mini (couldn't find wpad-basic)

root@OpenWrt:~# iw phy | fgrep mesh * mesh point * #{ managed } <= 2048, #{ AP, mesh point } <= 8, #{ P2P-client, P2P-GO } <= 1, #{ IBSS } <= 1,

wireless config looks like this:

config wifi-device 'radio0'
        option type 'mac80211'
        option channel '11'
        option hwmode '11g'
        option path 'platform/ahb/180c0000.wmac'
        option htmode 'HT20'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrt'
        option encryption 'none'

config wifi-iface 'mesh0'
        option device 'radio0'
        option ifname 'mesh0'
        option network 'nwi_mesh0'
        option mode 'mesh'
        option mesh_fwding '0'
        option mesh_id 'SMASH_THE_MESH'
        option encryption 'none'

this is what ip link gives:

root@OpenWrt:~# ip link
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP qlen 1000
    link/ether 54:e6:fc:9a:36:8e brd ff:ff:ff:ff:ff:ff
5: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    link/ether 54:e6:fc:9a:36:8e brd ff:ff:ff:ff:ff:ff
6: eth0.1@eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-lan state UP qlen 1000
    link/ether 54:e6:fc:9a:36:8e brd ff:ff:ff:ff:ff:ff
8: eth0.2@eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    link/ether 54:e6:fc:9a:36:8e brd ff:ff:ff:ff:ff:ff
9: br-vlan211: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    link/ether 2e:fe:2b:09:ea:64 brd ff:ff:ff:ff:ff:ff
10: bat0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-vlan211 state UNKNOWN qlen 1000
    link/ether 2e:fe:2b:09:ea:64 brd ff:ff:ff:ff:ff:ff
13: mesh0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 2304 qdisc noqueue master bat0 state UP qlen 1000
    link/ether 54:e6:fc:9a:36:8e brd ff:ff:ff:ff:ff:ff
14: wlan0-1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-lan state UP qlen 1000
    link/ether 56:e6:fc:9a:36:8e brd ff:ff:ff:ff:ff:ff

" iw dev mesh0 station dump" didn't give me anything, so i tried only iw dev:

phy#0
	Interface wlan0-1
		ifindex 14
		wdev 0x5
		addr 56:e6:fc:9a:36:8e
		ssid OpenWrt
		type AP
		channel 11 (2462 MHz), width: 20 MHz, center1: 2462 MHz
		txpower 23.00 dBm
		multicast TXQ:
			qsz-byt	qsz-pkt	flows	drops	marks	overlmt	hashcol	tx-bytes	tx-packets
			0	0	585	0	0	0	0	39857		585
	Interface mesh0
		ifindex 13
		wdev 0x4
		addr 54:e6:fc:9a:36:8e
		type mesh point
		channel 11 (2462 MHz), width: 20 MHz, center1: 2462 MHz
		txpower 23.00 dBm
		multicast TXQ:
			qsz-byt	qsz-pkt	flows	drops	marks	overlmt	hashcol	tx-bytes	tx-packets
			0	0	623	0	0	0	0	67456		623

this is my network config:

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd11:e6f9:4536::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1'
        option proto 'static'
        option ipaddr '192.168.2.2'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option ifname 'eth0.2'
        option proto 'static'
        option ipaddr '192.168.1.64'
        option netmask '255.255.255.0'
        option gateway '192.168.1.254'
        option dns '192.168.1.254'

config interface 'wan6'
        option ifname 'eth0.2'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '1 2 3 4 5t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '0 5t'


config interface 'bat0'
        option proto 'batadv'
        option routing_algo 'BATMAN_IV'
        option aggregated_ogms 1
        option ap_isolation 0
        option bonding 0
        option fragmentation 1
        #option gw_bandwidth '10000/2000'
        option gw_mode 'off'
        #option gw_sel_class 20
        option log_level 0
        option orig_interval 1000
        option bridge_loop_avoidance 1
        option distributed_arp_table 1
        option multicast_mode 1
        option network_coding 0
        option hop_penalty 30
        option isolation_mark '0x00000000/0x00000000'

config interface 'nwi_mesh0'
        option mtu '2304'
        option proto 'batadv_hardif'
        option master 'bat0'


config interface 'vlan211'
        option type 'bridge'
        option stp '1'
        option ifname 'eth0.1 bat0'
        option proto 'static'
        option ipaddr '192.168.2.11'
        option netmask '255.255.255.0'
        option delegate '0'

and eventually the outcome from batctl n

root@OpenWrt:~# batctl n
[B.A.T.M.A.N. adv openwrt-2019.3-0, MainIF/MAC: mesh0/54:e6:fc:9a:36:8e (bat0/2e:fe:2b:09:ea:64 BATMAN_IV)]
IF            

A mesh node interface can only connect to other mesh nodes. It broadcasts beacon frames similar to those from an AP but will not make "normal" STA connections.

1 Like

thanks,
I thought that normal client could connect to mesh nodes directly and that it would have been enough to have a bridged vlan to get everybody connected
i got probably confused by this:
on-_and_off-mesh_access

no problem, i will setup also the archer with mesh and batman-adv and see if the two nodes can connect

reading better the 802.11s wiki and the linked article from cwnp, i believe i need to setup a "Mesh Gate" to give to non mesh clients access to the mesh network.
is there a chance you could give me some more pointers on how to achieve this?

thanks a lot

M

For a bridged setup, see https://openwrt.org/docs/guide-user/network/wifi/mesh/batman

802.11s routing and batman-adv running over an 802.11s mesh are two, entirely different routing protocols.

sorry for being thick, i did try to have a go at bridged batmand-adv but i am missing something

i prepared this picture to represent my layout:

the two routers work fine
the 3 wifi's are ok
i can run batctl n from both routers and they both see the neighbouring nodes
i understand i need to "connect" the batman interfaces to the lan or wifi, so i added two vlans
vlan1111 in my mind was meant to bridge the LAN and the BAT0 interface of the entry node
and vlan2222 was supposed to bridge the LAN and the BAT0 of the exit node

but i must have done something wrong because i cannot ping one router from the other

apologies if i have done something utterly stupid, i have a mechanical background and i have probably confused myself with all this... :wink:

these are the two vlans

if anyone could share some pointers it would be much appreciated

thanks

PS. the 1043 router will not need have any wired clients, it should basically work as a repeater
i understand that i could remove wan/lan but i didn't want to add to many variable before getting batman-adv to work...

config interface 'vlan1111'
        option type 'bridge'
        option stp '1'
        option ifname 'eth1.1111 bat0.1111'
        option proto 'static'
        option ipaddr '192.168.2.11'
        option netmask '255.255.255.0'
        option delegate '0'
config interface 'vlan2222'
        option type 'bridge'
        option stp '1'
        option ifname 'eth0.2222 bat0.2222'
        option proto 'static'
        option ipaddr '192.168.2.2'
        option netmask '255.255.255.0'
        option delegate '0'

Concept-wise, you're on the right track. "1111" and "2222" are just example numbers, but as long as you're not trying to run them through your switch, you won't need to mess around with option vid in your switch config.

From your diagram, to get "wifi2" to look like it's one with "main wifi", you just need to add a batman interface to the existing "LAN" bridges on each of the two routers.

As long as the VLAN on the batman tunnel is the same on both ends, it doesn't matter much what VLAN you pick. Since you're already using VLAN 1 for your LAN, that is an understandable choice. Adding bat0.1 to the existing ifname list for both routers for the LAN bridge should get you going.

1 Like

thanks Jeff,

i added bat0.1 on both vlan1's (see below) but still i can't ping
do i need maybe to play with the ip address?

it has been a long day and i think it will be wiser to take another look at this tomorrow with fresher eyes

thanks a lot for your support, much appreciated

M
on the archer router:

config interface 'vlan1'
        option type 'bridge'
        option stp '1'
        option ifname 'bat0.1'
        option proto 'static'
        option ipaddr '192.168.2.11'
        option netmask '255.255.255.0'
        option delegate '0'

on the 1043

config interface 'vlan1'
        option type 'bridge'
        option stp '1'
        option ifname 'bat0.1'
        option proto 'static'
        option ipaddr '192.168.2.22'
        option netmask '255.255.255.0'
        option delegate '0'

Use the existing "LAN" bridge, not a new bridge.

If you look at your routing table (ip route) and your links (ip link), you'll likely see that you have two interfaces on the same subnet. This is generally "not good".

Working with a "fresh" config from a device on my bench

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0.1'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'

that section would be changed to

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0.1 bat0.1'
	option stp '1'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'

(with different IPv4 addresses on the two devices and your choice of what to do around IPv6 addressing and advertising)

First you should connect the two routers with an Ethernet cable between the LAN ports, this will confirm that you have the second one configured properly as a "dumb AP" Then you can add a bat interface (with the same VLAN number on both ends) to the existing br-lan and disconnect the cable, they should still be connected by wireless now.

Turn on STP on the lan bridges so if you ever do have wired and radio connected at the same time there won't be a network loop, which is really bad (it will DoS itself).

@jeff and @mk24

Thanks! you suggestions were great...

I stumbled on some issues which were linked to dnsmasq and the /etc/host file, I must confess this took longer then expected to understand... :blush:

in the end i got it (almost) working, I can now connect to "wifi2" from the 1043 router and this is acting as if it was the "main wifi" on the archer router.

I said almost because in order to understand where the issue was, today i set the mesh encryption to 'none'
once things started to work with no encryption, i tried to set encryption to psk2+ccmp as per the wiki, but i couldn't get to ping the two nodes
i tried again with simple psk2 but still no luck so i reverted back to 'none'

i blamed it on having ath10k-ct on the archer and ath10k (non ct) on the 1043, so I tried to remove the non-ct driver from the 1043 and i bumped into the next problem.
opkg fails due to "failed to download..." so i realised that even if i can connect to the internet through the node on the 1043 router, i cannot ping google from there (192.168.2.2)

could be a simplistic view, but if 192.168.2.2 can ping 192.168.2.1 but not 8.8.8.8 and the clients of 192.168.2.2 have access to the internet, i feel that this won't be a difficult issue to solve

i will study a bit more the issue and let you know, if you have any suggestion please let me know

next steps for me are:

  • get internet connectivity for 192.168.2.2
  • get encryption to work

thanks a lot

M

Requires wpad-mesh on most builds.

802.11s, as I recall, requires the non-CT drivers for the Archer C7 (at least on my v2 models). It wouldn't surprise me if the same for the 1043.

i have "wpad-mesh-openssl - 2019-08-08-ca8c2bd2-1" on both routers, this should be ok...

regarding the CT vs non-CT, at the moment the archer is stock, i believe it comes with CT drivers as default, (on the 1043 i had to remove them and opkg install the non-CT version, which i forgot to do on the archer)
so if I am not wrong, by not replacing the CT on the archer I should have confirmed that a mesh with CT and non-CT works
if you think that this could be the issue with the encryption, i can try to remove the CT from archer and replace them with the non-CT and report back

thanks

M

I just recall that when the switch to -CT as default was made, I needed to swap back to the non-CT drivers and firmware on my Archer C7v2s. It was existing config, with wpa2+ccpm, so I didn't test further. As I recall, 802.11s not being supported with the -CT drivers on Wave 1 chips was confirmed on the mailing list (I don't recall if that was openwrt-devel or linux-wireless)

sorry it took a while to run some test
i now have NON-CT on both routers

I tried with sae, sae-mixe,psk2+tkip+ccmp,psk2+ccmp,psk2 and psk encryption and none of these encryptions works

in some occasion i get a painfully slow connection which lasts for a tiny bit, then browsing internet becomes impossible

as soon as i revert to "none" internet is back (even though still i cannot ping anything outside my network from router 2)

hope this helps

thanks
M

You'll need to change the names as you see fit, but the following works reliably on an Archer C7v2

ath10k-firmware-qca988x - 20190618-1
kmod-ath10k - 4.19.57+5.2-rc7-1-1

Tue Jul 23 03:21:02 2019 Build Time -- based on commit 11617bcb3b (2019-07-22 21:48:34 +0200)

config wifi-iface 'mesh0'
        option device 'radio5'
        option ifname 'mesh0'
        option network 'nwi_mesh0'
        option mode 'mesh'
        option mesh_id '<redacted>'
        option mesh_fwding '0'
        option encryption 'psk2+ccmp'
        option key '<redacted>'
Station 32:23:03:xx:xx:xx (on mesh0)
        inactive time:  10 ms
        rx bytes:       3066375383
        rx packets:     30447470
        tx bytes:       24020666
        tx packets:     195899
        tx retries:     0
        tx failed:      2374
        rx drop misc:   109
        signal:         -72 [-74, -84, -78] dBm
        signal avg:     -69 [-73, -82, -77] dBm
        Toffset:        987925323412 us
        tx bitrate:     234.0 MBit/s VHT-MCS 5 80MHz VHT-NSS 1
        rx bitrate:     390.0 MBit/s VHT-MCS 4 80MHz short GI VHT-NSS 2
        rx duration:    1682544024 us
        last ack signal:-95 dBm
        avg ack signal: -94 dBm
        mesh llid:      0
        mesh plid:      0
        mesh plink:     ESTAB
        mesh local PS mode:     ACTIVE
        mesh peer PS mode:      ACTIVE
        mesh non-peer PS mode:  ACTIVE
        authorized:     yes
        authenticated:  yes
        associated:     yes
        preamble:       long
        WMM/WME:        yes
        MFP:            yes
        TDLS peer:      no
        DTIM period:    2
        beacon interval:100
        connected time: 1191999 seconds
Station 32:23:03:yy:yy:yy (on mesh0)
[...]

thanks, i have the identical setting (see below)

but maybe i spotted one issue, i did change the kmod-ath10k (removed the CT) but i didn't know about the firmware
in my case i have for the archer c7:
"ath10k-firmware-qca988x-ct"
and
"kmod-ath10k"

i will install the matching firmware and let you know

thanks
M

config wifi-iface 'mesh0'
        option device 'radio1'
        option ifname 'mesh0'
        option network 'nwi_mesh0'
        option mode 'mesh'
        option mesh_fwding '0'
        option mesh_id 'xxxxxxx'
        option encryption 'none'
#        option encryption 'psk'
#       option key 'xxxxxxxxx'
1 Like

sorry, bad news
drivers and firmware are aligned (non-ct)
but still psk2+ccmp yields no connection
it is enough to restore encryption to "none", run a "wifi reload" and i have internet connection

could it be something to do with the 1043?
i didn't know about "firmware" so i didn't install/replace anything there..

M

Possible. Are there any clues in the logs of either device?

these are the last entries on the logread from the archer with the failing psk2+ccmp setting

Thu Oct 24 21:41:07 2019 daemon.notice netifd: Interface 'nwi_mesh0' is disabled
Thu Oct 24 21:41:07 2019 daemon.notice netifd: Interface 'nwi_mesh0' has link connectivity loss
Thu Oct 24 21:41:08 2019 kern.info kernel: [26281.549333] batman_adv: bat0: Interface deactivated: mesh0
Thu Oct 24 21:41:08 2019 kern.info kernel: [26281.554907] batman_adv: bat0: Removing interface: mesh0
Thu Oct 24 21:41:08 2019 daemon.notice netifd: Interface 'nwi_mesh0' is now down
Thu Oct 24 21:41:08 2019 daemon.notice hostapd: wlan1-1: interface state ENABLED->DISABLED
Thu Oct 24 21:41:08 2019 daemon.notice hostapd: wlan1-2: AP-DISABLED
Thu Oct 24 21:41:08 2019 daemon.notice hostapd: wlan1-2: CTRL-EVENT-TERMINATING
Thu Oct 24 21:41:08 2019 daemon.notice netifd: Network device 'wlan1-2' link is down
Thu Oct 24 21:41:08 2019 daemon.notice netifd: Interface 'guest' has link connectivity loss
Thu Oct 24 21:41:08 2019 daemon.notice netifd: Interface 'guest' is now down
Thu Oct 24 21:41:08 2019 daemon.notice netifd: Interface 'guest' is disabled
Thu Oct 24 21:41:08 2019 daemon.notice hostapd: wlan1-1: AP-STA-DISCONNECTED 04:4f:4c:d3:66:2d
Thu Oct 24 21:41:08 2019 daemon.notice hostapd: wlan1-1: AP-DISABLED
Thu Oct 24 21:41:08 2019 daemon.notice hostapd: wlan1-1: CTRL-EVENT-TERMINATING
Thu Oct 24 21:41:08 2019 daemon.notice hostapd: nl80211: deinit ifname=wlan1-1 disabled_11b_rates=0
Thu Oct 24 21:41:08 2019 kern.info kernel: [26281.706309] device wlan1-1 left promiscuous mode
Thu Oct 24 21:41:08 2019 kern.info kernel: [26281.711102] br-lan: port 4(wlan1-1) entered disabled state
Thu Oct 24 21:41:08 2019 daemon.notice netifd: Network device 'wlan1-1' link is down
Thu Oct 24 21:41:09 2019 daemon.notice netifd: radio1 (18947): sh: out of range
Thu Oct 24 21:41:09 2019 daemon.notice netifd: radio1 (18947): Usage:	iw [options] dev <devname> set channel <channel> [NOHT|HT20|HT40+|HT40-|5MHz|10MHz|80MHz]
Thu Oct 24 21:41:09 2019 daemon.notice netifd: radio1 (18947): Options:
Thu Oct 24 21:41:09 2019 daemon.notice netifd: radio1 (18947): 	--debug		enable netlink debugging
Thu Oct 24 21:41:09 2019 user.notice mac80211: Failed command: iw dev mesh0 set channel 6 HT40
Thu Oct 24 21:41:09 2019 daemon.err hostapd: Configuration file: /var/run/hostapd-phy1.conf
Thu Oct 24 21:41:09 2019 kern.info kernel: [26283.313989] IPv6: ADDRCONF(NETDEV_UP): wlan1-1: link is not ready
Thu Oct 24 21:41:10 2019 kern.info kernel: [26283.378526] br-lan: port 4(wlan1-1) entered blocking state
Thu Oct 24 21:41:10 2019 kern.info kernel: [26283.384143] br-lan: port 4(wlan1-1) entered disabled state
Thu Oct 24 21:41:10 2019 kern.info kernel: [26283.390056] device wlan1-1 entered promiscuous mode
Thu Oct 24 21:41:10 2019 kern.info kernel: [26283.395250] br-lan: port 4(wlan1-1) entered blocking state
Thu Oct 24 21:41:10 2019 kern.info kernel: [26283.400821] br-lan: port 4(wlan1-1) entered listening state
Thu Oct 24 21:41:10 2019 daemon.notice hostapd: wlan1-1: interface state UNINITIALIZED->COUNTRY_UPDATE
Thu Oct 24 21:41:10 2019 daemon.err hostapd: Using interface wlan1-1 with hwaddr 62:e3:27:78:85:37 and ssid "XXX"
Thu Oct 24 21:41:10 2019 kern.info kernel: [26283.618081] IPv6: ADDRCONF(NETDEV_CHANGE): wlan1-1: link becomes ready
Thu Oct 24 21:41:10 2019 daemon.err hostapd: Using interface wlan1-2 with hwaddr 66:e3:27:78:85:37 and ssid "XXX"
Thu Oct 24 21:41:10 2019 kern.info kernel: [26283.685723] IPv6: ADDRCONF(NETDEV_UP): wlan1-2: link is not ready
Thu Oct 24 21:41:10 2019 kern.info kernel: [26283.914898] IPv6: ADDRCONF(NETDEV_CHANGE): wlan1-2: link becomes ready
Thu Oct 24 21:41:10 2019 daemon.notice hostapd: wlan1-1: interface state COUNTRY_UPDATE->ENABLED
Thu Oct 24 21:41:10 2019 daemon.notice hostapd: wlan1-1: AP-ENABLED
Thu Oct 24 21:41:10 2019 kern.info kernel: [26284.207867] IPv6: ADDRCONF(NETDEV_UP): mesh0: link is not ready
Thu Oct 24 21:41:11 2019 daemon.notice wpa_supplicant[19164]: Successfully initialized wpa_supplicant
Thu Oct 24 21:41:11 2019 daemon.notice netifd: radio1 (18947): command failed: Link has been severed (-67)
Thu Oct 24 21:41:11 2019 kern.info kernel: [26284.775410] br-lan: port 4(wlan1-1) entered disabled state
Thu Oct 24 21:41:11 2019 user.notice mac80211: Failed command: iw dev mesh0 set mesh_param mesh_fwding 0
Thu Oct 24 21:41:11 2019 daemon.notice netifd: Interface 'guest' is enabled
Thu Oct 24 21:41:11 2019 daemon.notice netifd: Interface 'guest' is setting up now
Thu Oct 24 21:41:11 2019 daemon.notice netifd: Interface 'guest' is now up
Thu Oct 24 21:41:11 2019 daemon.notice netifd: Interface 'nwi_mesh0' is enabled
Thu Oct 24 21:41:11 2019 user.notice firewall: Reloading firewall due to ifup of guest (wlan1-2)
Thu Oct 24 21:41:12 2019 daemon.err wpa_supplicant[19171]: Using interface mesh0 with hwaddr 60:e3:27:78:85:37 and ssid "XXX"
Thu Oct 24 21:41:12 2019 daemon.notice wpa_supplicant[19171]: mesh0: interface state UNINITIALIZED->ENABLED
Thu Oct 24 21:41:12 2019 daemon.notice wpa_supplicant[19171]: mesh0: AP-ENABLED
Thu Oct 24 21:41:12 2019 daemon.notice wpa_supplicant[19171]: mesh0: joining mesh XXX
Thu Oct 24 21:41:12 2019 daemon.notice netifd: Network device 'mesh0' link is up
Thu Oct 24 21:41:12 2019 daemon.notice netifd: Interface 'nwi_mesh0' has link connectivity
Thu Oct 24 21:41:12 2019 daemon.notice netifd: Interface 'nwi_mesh0' is setting up now
Thu Oct 24 21:41:12 2019 kern.info kernel: [26285.835150] IPv6: ADDRCONF(NETDEV_CHANGE): mesh0: link becomes ready
Thu Oct 24 21:41:12 2019 daemon.notice wpa_supplicant[19171]: mesh0: CTRL-EVENT-CONNECTED - Connection to 00:00:00:00:00:00 completed [id=0 id_str=]
Thu Oct 24 21:41:12 2019 daemon.notice wpa_supplicant[19171]: mesh0: MESH-GROUP-STARTED ssid="XXX" id=0
Thu Oct 24 21:41:12 2019 kern.info kernel: [26285.939026] batman_adv: bat0: Adding interface: mesh0
Thu Oct 24 21:41:12 2019 kern.info kernel: [26285.944284] batman_adv: bat0: Interface activated: mesh0
Thu Oct 24 21:41:12 2019 daemon.notice netifd: Interface 'nwi_mesh0' is now up
Thu Oct 24 21:41:12 2019 daemon.info dnsmasq[18459]: exiting on receipt of SIGTERM
Thu Oct 24 21:41:12 2019 daemon.info dnsmasq[19266]: started, version 2.80 cachesize 150
Thu Oct 24 21:41:12 2019 daemon.info dnsmasq[19266]: compile time options: IPv6 GNU-getopt no-DBus no-i18n no-IDN DHCP no-DHCPv6 no-Lua TFTP no-conntrack no-ipset no-auth no-DNSSEC no-ID loop-detect inotify dumpfile
Thu Oct 24 21:41:12 2019 daemon.warn dnsmasq[19266]: warning: interface guest does not currently exist
Thu Oct 24 21:41:12 2019 daemon.info dnsmasq[19266]: using local addresses only for domain test
Thu Oct 24 21:41:12 2019 daemon.info dnsmasq[19266]: using local addresses only for domain onion
Thu Oct 24 21:41:12 2019 daemon.info dnsmasq[19266]: using local addresses only for domain localhost
Thu Oct 24 21:41:12 2019 daemon.info dnsmasq[19266]: using local addresses only for domain local
Thu Oct 24 21:41:12 2019 daemon.info dnsmasq[19266]: using local addresses only for domain invalid
Thu Oct 24 21:41:12 2019 daemon.info dnsmasq[19266]: using local addresses only for domain bind
Thu Oct 24 21:41:12 2019 daemon.info dnsmasq[19266]: using nameserver 208.67.220.222#53
Thu Oct 24 21:41:12 2019 daemon.info dnsmasq[19266]: using nameserver 208.67.222.220#53
Thu Oct 24 21:41:12 2019 daemon.info dnsmasq[19266]: using nameserver 208.67.220.220#53
Thu Oct 24 21:41:12 2019 daemon.info dnsmasq[19266]: using nameserver 208.67.222.222#53
Thu Oct 24 21:41:12 2019 daemon.info dnsmasq[19266]: using local addresses only for domain guest
Thu Oct 24 21:41:12 2019 daemon.warn dnsmasq[19266]: no servers found in /tmp/resolv.conf.guest, will retry
Thu Oct 24 21:41:12 2019 daemon.info dnsmasq[19266]: read /etc/hosts - 12 addresses
Thu Oct 24 21:41:12 2019 daemon.info dnsmasq[19266]: read /tmp/hosts/dhcp.main - 1 addresses
Thu Oct 24 21:41:12 2019 daemon.info dnsmasq[19266]: read /tmp/hosts/dhcp.guest - 0 addresses
Thu Oct 24 21:41:12 2019 daemon.info dnsmasq[19266]: read /etc/hosts-restricted/hosts - 388 addresses
Thu Oct 24 21:41:12 2019 daemon.info dnsmasq[19266]: read /etc/hosts - 12 addresses
Thu Oct 24 21:41:12 2019 daemon.info dnsmasq[17301]: read /etc/hosts - 12 addresses
Thu Oct 24 21:41:12 2019 daemon.info dnsmasq[17301]: read /tmp/hosts/dhcp.main - 1 addresses
Thu Oct 24 21:41:12 2019 daemon.info dnsmasq[17301]: read /tmp/hosts/dhcp.guest - 0 addresses
Thu Oct 24 21:41:12 2019 daemon.info dnsmasq-dhcp[17301]: read /etc/ethers - 0 addresses
Thu Oct 24 21:41:12 2019 daemon.info dnsmasq[19266]: read /tmp/hosts/dhcp.main - 1 addresses
Thu Oct 24 21:41:12 2019 daemon.info dnsmasq[19266]: read /tmp/hosts/dhcp.guest - 0 addresses
Thu Oct 24 21:41:12 2019 daemon.info dnsmasq[19266]: read /etc/hosts-restricted/hosts - 388 addresses
Thu Oct 24 21:41:13 2019 daemon.notice hostapd: handle_probe_req: send failed
Thu Oct 24 21:41:13 2019 daemon.notice hostapd: handle_probe_req: send failed
Thu Oct 24 21:41:13 2019 daemon.notice hostapd: handle_probe_req: send failed
Thu Oct 24 21:41:13 2019 daemon.notice hostapd: handle_probe_req: send failed
Thu Oct 24 21:41:14 2019 kern.warn kernel: [26287.795357] br-lan: received packet on bat0.1 with own address as source address (addr:60:e3:27:78:85:37, vlan:0)
Thu Oct 24 21:41:14 2019 daemon.notice hostapd: handle_probe_req: send failed
Thu Oct 24 21:41:15 2019 daemon.info dnsmasq[19266]: exiting on receipt of SIGTERM
Thu Oct 24 21:41:15 2019 daemon.info dnsmasq[19442]: started, version 2.80 cachesize 150
Thu Oct 24 21:41:15 2019 daemon.info dnsmasq[19442]: compile time options: IPv6 GNU-getopt no-DBus no-i18n no-IDN DHCP no-DHCPv6 no-Lua TFTP no-conntrack no-ipset no-auth no-DNSSEC no-ID loop-detect inotify dumpfile
Thu Oct 24 21:41:15 2019 daemon.info dnsmasq-dhcp[19442]: DHCP, IP range 192.168.3.100 -- 192.168.3.119, lease time 1h
Thu Oct 24 21:41:15 2019 daemon.info dnsmasq-dhcp[19442]: DHCP, sockets bound exclusively to interface wlan1-2
Thu Oct 24 21:41:15 2019 daemon.info dnsmasq[19442]: using local addresses only for domain test
Thu Oct 24 21:41:15 2019 daemon.info dnsmasq[19442]: using local addresses only for domain onion
Thu Oct 24 21:41:15 2019 daemon.info dnsmasq[19442]: using local addresses only for domain localhost
Thu Oct 24 21:41:15 2019 daemon.info dnsmasq[19442]: using local addresses only for domain local
Thu Oct 24 21:41:15 2019 daemon.info dnsmasq[19442]: using local addresses only for domain invalid
Thu Oct 24 21:41:15 2019 daemon.info dnsmasq[19442]: using local addresses only for domain bind
Thu Oct 24 21:41:15 2019 daemon.info dnsmasq[19442]: using nameserver 208.67.220.222#53
Thu Oct 24 21:41:15 2019 daemon.info dnsmasq[19442]: using nameserver 208.67.222.220#53
Thu Oct 24 21:41:15 2019 daemon.info dnsmasq[19442]: using nameserver 208.67.220.220#53
Thu Oct 24 21:41:15 2019 daemon.info dnsmasq[19442]: using nameserver 208.67.222.222#53
Thu Oct 24 21:41:15 2019 daemon.info dnsmasq[19442]: using local addresses only for domain guest
Thu Oct 24 21:41:15 2019 daemon.warn dnsmasq[19442]: no servers found in /tmp/resolv.conf.guest, will retry
Thu Oct 24 21:41:15 2019 daemon.info dnsmasq[19442]: read /etc/hosts - 12 addresses
Thu Oct 24 21:41:15 2019 daemon.info dnsmasq[19442]: read /tmp/hosts/dhcp.main - 1 addresses
Thu Oct 24 21:41:15 2019 daemon.info dnsmasq[19442]: read /tmp/hosts/dhcp.guest - 1 addresses
Thu Oct 24 21:41:15 2019 daemon.info dnsmasq[19442]: read /etc/hosts-restricted/hosts - 388 addresses
Thu Oct 24 21:41:15 2019 daemon.info dnsmasq-dhcp[19442]: read /etc/ethers - 0 addresses
Thu Oct 24 21:41:15 2019 daemon.info dnsmasq[19442]: read /etc/hosts - 12 addresses
Thu Oct 24 21:41:15 2019 daemon.info dnsmasq[17301]: read /etc/hosts - 12 addresses
Thu Oct 24 21:41:15 2019 daemon.info dnsmasq[17301]: read /tmp/hosts/dhcp.main - 1 addresses
Thu Oct 24 21:41:15 2019 daemon.info dnsmasq[17301]: read /tmp/hosts/dhcp.guest - 1 addresses
Thu Oct 24 21:41:15 2019 daemon.info dnsmasq-dhcp[17301]: read /etc/ethers - 0 addresses
Thu Oct 24 21:41:15 2019 daemon.info dnsmasq[19442]: read /tmp/hosts/dhcp.main - 1 addresses
Thu Oct 24 21:41:15 2019 daemon.info dnsmasq[19442]: read /tmp/hosts/dhcp.guest - 1 addresses
Thu Oct 24 21:41:15 2019 daemon.info dnsmasq[19442]: read /etc/hosts-restricted/hosts - 388 addresses
Thu Oct 24 21:41:15 2019 daemon.info dnsmasq-dhcp[19442]: read /etc/ethers - 0 addresses
Thu Oct 24 21:41:16 2019 kern.warn kernel: [26289.475026] br-lan: received packet on bat0.1 with own address as source address (addr:60:e3:27:78:85:37, vlan:0)
Thu Oct 24 21:41:16 2019 kern.info kernel: [26289.606733] br-lan: port 4(wlan1-1) entered blocking state
Thu Oct 24 21:41:16 2019 kern.info kernel: [26289.612302] br-lan: port 4(wlan1-1) entered listening state
Thu Oct 24 21:41:16 2019 daemon.notice netifd: Network device 'wlan1-1' link is up
Thu Oct 24 21:41:16 2019 daemon.notice netifd: Network device 'wlan1-2' link is up
Thu Oct 24 21:41:16 2019 daemon.notice netifd: Interface 'guest' has link connectivity
Thu Oct 24 21:41:18 2019 kern.info kernel: [26291.634968] br-lan: port 4(wlan1-1) entered learning state
Thu Oct 24 21:41:19 2019 daemon.info dnsmasq[19442]: read /etc/hosts - 12 addresses
Thu Oct 24 21:41:19 2019 daemon.info dnsmasq[17301]: read /etc/hosts - 12 addresses
Thu Oct 24 21:41:19 2019 daemon.info dnsmasq[17301]: read /tmp/hosts/dhcp.main - 1 addresses
Thu Oct 24 21:41:19 2019 daemon.info dnsmasq[17301]: read /tmp/hosts/dhcp.guest - 1 addresses
Thu Oct 24 21:41:19 2019 daemon.info dnsmasq-dhcp[17301]: read /etc/ethers - 0 addresses
Thu Oct 24 21:41:19 2019 daemon.info dnsmasq[19442]: read /tmp/hosts/dhcp.main - 1 addresses
Thu Oct 24 21:41:19 2019 daemon.info dnsmasq[19442]: read /tmp/hosts/dhcp.guest - 1 addresses
Thu Oct 24 21:41:19 2019 daemon.info dnsmasq[19442]: read /etc/hosts-restricted/hosts - 388 addresses
Thu Oct 24 21:41:19 2019 daemon.info dnsmasq-dhcp[19442]: read /etc/ethers - 0 addresses
Thu Oct 24 21:41:20 2019 kern.info kernel: [26293.714924] br-lan: port 4(wlan1-1) entered forwarding state
Thu Oct 24 21:41:20 2019 kern.info kernel: [26293.720690] br-lan: topology change detected, propagating
Thu Oct 24 21:41:26 2019 kern.warn kernel: [26299.722303] br-lan: received packet on bat0.1 with own address as source address (addr:60:e3:27:78:85:37, vlan:0)
Thu Oct 24 21:41:29 2019 daemon.notice wpa_supplicant[19171]: mesh0: new peer notification for 54:e6:fc:9a:36:8e
Thu Oct 24 21:41:29 2019 daemon.notice wpa_supplicant[19171]: mesh0: mesh plink with 54:e6:fc:9a:36:8e established
Thu Oct 24 21:41:29 2019 daemon.notice wpa_supplicant[19171]: mesh0: MESH-PEER-CONNECTED 54:e6:fc:9a:36:8e
Thu Oct 24 21:41:36 2019 kern.warn kernel: [26309.954785] br-lan: received packet on bat0.1 with own address as source address (addr:60:e3:27:78:85:37, vlan:0)
Thu Oct 24 21:41:38 2019 daemon.info hostapd: wlan1-1: STA 04:4f:4c:d3:66:2d IEEE 802.11: authenticated
Thu Oct 24 21:41:38 2019 daemon.info hostapd: wlan1-1: STA 04:4f:4c:d3:66:2d IEEE 802.11: associated (aid 1)
Thu Oct 24 21:41:38 2019 daemon.notice hostapd: wlan1-1: AP-STA-CONNECTED 04:4f:4c:d3:66:2d
Thu Oct 24 21:41:38 2019 daemon.info hostapd: wlan1-1: STA 04:4f:4c:d3:66:2d RADIUS: starting accounting session 8EC0C4D82029F5BB
Thu Oct 24 21:41:38 2019 daemon.info hostapd: wlan1-1: STA 04:4f:4c:d3:66:2d WPA: pairwise key handshake completed (RSN)
Thu Oct 24 21:41:38 2019 daemon.info dnsmasq-dhcp[17301]: DHCPREQUEST(br-lan) 192.168.2.27 04:4f:4c:d3:66:2d
Thu Oct 24 21:41:38 2019 daemon.info dnsmasq-dhcp[17301]: DHCPACK(br-lan) 192.168.2.27 04:4f:4c:d3:66:2d HUAWEI_P9_lite
Thu Oct 24 21:41:38 2019 daemon.info dnsmasq-dhcp[17301]: DHCPREQUEST(br-lan) 192.168.2.27 04:4f:4c:d3:66:2d
Thu Oct 24 21:41:38 2019 daemon.info dnsmasq-dhcp[17301]: DHCPACK(br-lan) 192.168.2.27 04:4f:4c:d3:66:2d HUAWEI_P9_lite
Thu Oct 24 21:41:46 2019 kern.warn kernel: [26320.202362] br-lan: received packet on bat0.1 with own address as source address (addr:60:e3:27:78:85:37, vlan:0)
Thu Oct 24 21:41:57 2019 kern.warn kernel: [26330.434467] br-lan: received packet on bat0.1 with own address as source address (addr:60:e3:27:78:85:37, vlan:0)
Thu Oct 24 21:42:05 2019 daemon.info dnsmasq-dhcp[17301]: DHCPREQUEST(br-lan) 192.168.2.199 9c:6c:15:42:24:48
Thu Oct 24 21:42:05 2019 daemon.info dnsmasq-dhcp[17301]: DHCPACK(br-lan) 192.168.2.199 9c:6c:15:42:24:48 win-phone
Thu Oct 24 21:42:07 2019 kern.warn kernel: [26340.682454] br-lan: received packet on bat0.1 with own address as source address (addr:60:e3:27:78:85:37, vlan:0)
Thu Oct 24 21:42:17 2019 kern.warn kernel: [26350.914198] br-lan: received packet on bat0.1 with own address as source address (addr:60:e3:27:78:85:37, vlan:0)

and this is the same but with the setting reverted back to encrytption 'none'

Thu Oct 24 21:49:17 2019 daemon.notice wpa_supplicant[19171]: mesh0: MESH-PEER-DISCONNECTED 54:e6:fc:9a:36:8e
Thu Oct 24 21:49:27 2019 kern.warn kernel: [26780.988584] br-lan: received packet on bat0.1 with own address as source address (addr:60:e3:27:78:85:37, vlan:0)
Thu Oct 24 21:49:37 2019 kern.warn kernel: [26791.231679] br-lan: received packet on bat0.1 with own address as source address (addr:60:e3:27:78:85:37, vlan:0)
Thu Oct 24 21:49:38 2019 daemon.notice netifd: Interface 'nwi_mesh0' is disabled
Thu Oct 24 21:49:38 2019 daemon.notice netifd: Interface 'nwi_mesh0' has link connectivity loss
Thu Oct 24 21:49:38 2019 kern.info kernel: [26792.267764] batman_adv: bat0: Interface deactivated: mesh0
Thu Oct 24 21:49:38 2019 kern.info kernel: [26792.273411] batman_adv: bat0: Removing interface: mesh0
Thu Oct 24 21:49:38 2019 daemon.notice netifd: Interface 'nwi_mesh0' is now down
Thu Oct 24 21:49:39 2019 daemon.notice hostapd: wlan1-1: interface state ENABLED->DISABLED
Thu Oct 24 21:49:39 2019 daemon.notice hostapd: wlan1-2: AP-DISABLED
Thu Oct 24 21:49:39 2019 daemon.notice hostapd: wlan1-2: CTRL-EVENT-TERMINATING
Thu Oct 24 21:49:39 2019 daemon.notice wpa_supplicant[19171]: mesh0: MESH-GROUP-REMOVED mesh0
Thu Oct 24 21:49:39 2019 daemon.notice wpa_supplicant[19171]: mesh0: leaving mesh
Thu Oct 24 21:49:39 2019 daemon.notice wpa_supplicant[19171]: mesh0: interface state ENABLED->DISABLED
Thu Oct 24 21:49:39 2019 daemon.notice wpa_supplicant[19171]: mesh0: AP-DISABLED
Thu Oct 24 21:49:39 2019 daemon.notice netifd: Network device 'wlan1-2' link is down
Thu Oct 24 21:49:39 2019 daemon.notice netifd: Interface 'guest' has link connectivity loss
Thu Oct 24 21:49:39 2019 daemon.notice netifd: Interface 'guest' is now down
Thu Oct 24 21:49:39 2019 daemon.notice netifd: Interface 'guest' is disabled
Thu Oct 24 21:49:39 2019 daemon.notice hostapd: wlan1-1: AP-STA-DISCONNECTED 04:4f:4c:d3:66:2d
Thu Oct 24 21:49:39 2019 daemon.notice hostapd: wlan1-1: AP-DISABLED
Thu Oct 24 21:49:39 2019 daemon.notice hostapd: wlan1-1: CTRL-EVENT-TERMINATING
Thu Oct 24 21:49:39 2019 daemon.notice hostapd: nl80211: deinit ifname=wlan1-1 disabled_11b_rates=0
Thu Oct 24 21:49:39 2019 kern.info kernel: [26792.427235] IPv6: ADDRCONF(NETDEV_UP): mesh0: link is not ready
Thu Oct 24 21:49:39 2019 kern.info kernel: [26792.438081] device wlan1-1 left promiscuous mode
Thu Oct 24 21:49:39 2019 kern.info kernel: [26792.442932] br-lan: port 4(wlan1-1) entered disabled state
Thu Oct 24 21:49:39 2019 daemon.err wpa_supplicant[19171]:  Failed to stop hostapd AP interfaces
Thu Oct 24 21:49:39 2019 daemon.notice wpa_supplicant[19171]: nl80211: deinit ifname=mesh0 disabled_11b_rates=0
Thu Oct 24 21:49:39 2019 daemon.notice wpa_supplicant[19171]: mesh0: CTRL-EVENT-TERMINATING
Thu Oct 24 21:49:39 2019 daemon.notice wpa_supplicant[19171]: ELOOP: remaining socket: sock=24 eloop_data=0x8018a0 user_data=0 handler=0x46ebdd
Thu Oct 24 21:49:39 2019 daemon.notice netifd: Network device 'wlan1-1' link is down
Thu Oct 24 21:49:39 2019 daemon.notice netifd: radio1 (19748): sh: out of range
Thu Oct 24 21:49:39 2019 daemon.notice netifd: radio1 (19748): Usage:	iw [options] dev <devname> set channel <channel> [NOHT|HT20|HT40+|HT40-|5MHz|10MHz|80MHz]
Thu Oct 24 21:49:39 2019 daemon.notice netifd: radio1 (19748): Options:
Thu Oct 24 21:49:39 2019 daemon.notice netifd: radio1 (19748): 	--debug		enable netlink debugging
Thu Oct 24 21:49:39 2019 user.notice mac80211: Failed command: iw dev mesh0 set channel 6 HT40
Thu Oct 24 21:49:40 2019 daemon.err hostapd: Configuration file: /var/run/hostapd-phy1.conf
Thu Oct 24 21:49:40 2019 kern.info kernel: [26794.101624] IPv6: ADDRCONF(NETDEV_UP): wlan1-1: link is not ready
Thu Oct 24 21:49:40 2019 kern.info kernel: [26794.181813] br-lan: port 4(wlan1-1) entered blocking state
Thu Oct 24 21:49:40 2019 kern.info kernel: [26794.187488] br-lan: port 4(wlan1-1) entered disabled state
Thu Oct 24 21:49:40 2019 kern.info kernel: [26794.193427] device wlan1-1 entered promiscuous mode
Thu Oct 24 21:49:40 2019 kern.info kernel: [26794.198538] br-lan: port 4(wlan1-1) entered blocking state
Thu Oct 24 21:49:40 2019 kern.info kernel: [26794.204106] br-lan: port 4(wlan1-1) entered listening state
Thu Oct 24 21:49:40 2019 daemon.notice hostapd: wlan1-1: interface state UNINITIALIZED->COUNTRY_UPDATE
Thu Oct 24 21:49:40 2019 daemon.err hostapd: Using interface wlan1-1 with hwaddr 62:e3:27:78:85:37 and ssid "XXX"
Thu Oct 24 21:49:41 2019 kern.info kernel: [26794.489571] IPv6: ADDRCONF(NETDEV_CHANGE): wlan1-1: link becomes ready
Thu Oct 24 21:49:41 2019 daemon.err hostapd: Using interface wlan1-2 with hwaddr 66:e3:27:78:85:37 and ssid "XXX"
Thu Oct 24 21:49:41 2019 kern.info kernel: [26794.538958] IPv6: ADDRCONF(NETDEV_UP): wlan1-2: link is not ready
Thu Oct 24 21:49:41 2019 kern.info kernel: [26794.795485] IPv6: ADDRCONF(NETDEV_CHANGE): wlan1-2: link becomes ready
Thu Oct 24 21:49:41 2019 daemon.notice hostapd: wlan1-1: interface state COUNTRY_UPDATE->ENABLED
Thu Oct 24 21:49:41 2019 daemon.notice hostapd: wlan1-1: AP-ENABLED
Thu Oct 24 21:49:41 2019 kern.info kernel: [26795.102356] IPv6: ADDRCONF(NETDEV_UP): mesh0: link is not ready
Thu Oct 24 21:49:42 2019 kern.info kernel: [26795.471359] IPv6: ADDRCONF(NETDEV_CHANGE): mesh0: link becomes ready
Thu Oct 24 21:49:42 2019 daemon.notice netifd: Network device 'wlan1-1' link is up
Thu Oct 24 21:49:42 2019 daemon.notice netifd: Network device 'wlan1-2' link is up
Thu Oct 24 21:49:42 2019 daemon.notice netifd: Interface 'guest' is enabled
Thu Oct 24 21:49:42 2019 daemon.notice netifd: Interface 'guest' is setting up now
Thu Oct 24 21:49:42 2019 daemon.notice netifd: Interface 'guest' is now up
Thu Oct 24 21:49:42 2019 daemon.notice netifd: Interface 'guest' has link connectivity
Thu Oct 24 21:49:42 2019 daemon.notice netifd: Network device 'mesh0' link is up
Thu Oct 24 21:49:42 2019 daemon.notice netifd: Interface 'nwi_mesh0' is enabled
Thu Oct 24 21:49:42 2019 daemon.notice netifd: Interface 'nwi_mesh0' has link connectivity
Thu Oct 24 21:49:42 2019 daemon.notice netifd: Interface 'nwi_mesh0' is setting up now
Thu Oct 24 21:49:42 2019 kern.info kernel: [26795.895414] batman_adv: bat0: Adding interface: mesh0
Thu Oct 24 21:49:42 2019 kern.info kernel: [26795.900653] batman_adv: bat0: Interface activated: mesh0
Thu Oct 24 21:49:42 2019 daemon.notice netifd: Interface 'nwi_mesh0' is now up
Thu Oct 24 21:49:42 2019 user.notice firewall: Reloading firewall due to ifup of guest (wlan1-2)
Thu Oct 24 21:49:42 2019 kern.info kernel: [26796.268334] br-lan: port 4(wlan1-1) entered learning state
Thu Oct 24 21:49:43 2019 daemon.info dnsmasq[19442]: exiting on receipt of SIGTERM
Thu Oct 24 21:49:43 2019 daemon.info dnsmasq[20107]: started, version 2.80 cachesize 150
Thu Oct 24 21:49:43 2019 daemon.info dnsmasq[20107]: compile time options: IPv6 GNU-getopt no-DBus no-i18n no-IDN DHCP no-DHCPv6 no-Lua TFTP no-conntrack no-ipset no-auth no-DNSSEC no-ID loop-detect inotify dumpfile
Thu Oct 24 21:49:43 2019 daemon.warn dnsmasq[20107]: warning: interface guest does not currently exist
Thu Oct 24 21:49:43 2019 daemon.info dnsmasq[20107]: using local addresses only for domain test
Thu Oct 24 21:49:43 2019 daemon.info dnsmasq[20107]: using local addresses only for domain onion
Thu Oct 24 21:49:43 2019 daemon.info dnsmasq[20107]: using local addresses only for domain localhost
Thu Oct 24 21:49:43 2019 daemon.info dnsmasq[20107]: using local addresses only for domain local
Thu Oct 24 21:49:43 2019 daemon.info dnsmasq[20107]: using local addresses only for domain invalid
Thu Oct 24 21:49:43 2019 daemon.info dnsmasq[20107]: using local addresses only for domain bind
Thu Oct 24 21:49:43 2019 daemon.info dnsmasq[20107]: using nameserver 208.67.220.222#53
Thu Oct 24 21:49:43 2019 daemon.info dnsmasq[20107]: using nameserver 208.67.222.220#53
Thu Oct 24 21:49:43 2019 daemon.info dnsmasq[20107]: using nameserver 208.67.220.220#53
Thu Oct 24 21:49:43 2019 daemon.info dnsmasq[20107]: using nameserver 208.67.222.222#53
Thu Oct 24 21:49:43 2019 daemon.info dnsmasq[20107]: using local addresses only for domain guest
Thu Oct 24 21:49:43 2019 daemon.warn dnsmasq[20107]: no servers found in /tmp/resolv.conf.guest, will retry
Thu Oct 24 21:49:43 2019 daemon.info dnsmasq[20107]: read /etc/hosts - 12 addresses
Thu Oct 24 21:49:43 2019 daemon.info dnsmasq[20107]: read /tmp/hosts/dhcp.main - 1 addresses
Thu Oct 24 21:49:43 2019 daemon.info dnsmasq[20107]: read /tmp/hosts/dhcp.guest - 0 addresses
Thu Oct 24 21:49:43 2019 daemon.info dnsmasq[20107]: read /etc/hosts-restricted/hosts - 388 addresses
Thu Oct 24 21:49:43 2019 daemon.info dnsmasq[20107]: read /etc/hosts - 12 addresses
Thu Oct 24 21:49:43 2019 daemon.info dnsmasq[17301]: read /etc/hosts - 12 addresses
Thu Oct 24 21:49:43 2019 daemon.info dnsmasq[17301]: read /tmp/hosts/dhcp.main - 1 addresses
Thu Oct 24 21:49:43 2019 daemon.info dnsmasq[17301]: read /tmp/hosts/dhcp.guest - 0 addresses
Thu Oct 24 21:49:43 2019 daemon.info dnsmasq-dhcp[17301]: read /etc/ethers - 0 addresses
Thu Oct 24 21:49:43 2019 daemon.info dnsmasq[20107]: read /tmp/hosts/dhcp.main - 1 addresses
Thu Oct 24 21:49:43 2019 daemon.info dnsmasq[20107]: read /tmp/hosts/dhcp.guest - 0 addresses
Thu Oct 24 21:49:43 2019 daemon.info dnsmasq[20107]: read /etc/hosts-restricted/hosts - 388 addresses
Thu Oct 24 21:49:44 2019 kern.warn kernel: [26797.788690] br-lan: received packet on bat0.1 with own address as source address (addr:60:e3:27:78:85:37, vlan:0)
Thu Oct 24 21:49:44 2019 kern.info kernel: [26798.348302] br-lan: port 4(wlan1-1) entered forwarding state
Thu Oct 24 21:49:44 2019 kern.info kernel: [26798.354069] br-lan: topology change detected, propagating
Thu Oct 24 21:49:46 2019 daemon.info dnsmasq[20107]: exiting on receipt of SIGTERM
Thu Oct 24 21:49:46 2019 daemon.info dnsmasq[20273]: started, version 2.80 cachesize 150
Thu Oct 24 21:49:46 2019 daemon.info dnsmasq[20273]: compile time options: IPv6 GNU-getopt no-DBus no-i18n no-IDN DHCP no-DHCPv6 no-Lua TFTP no-conntrack no-ipset no-auth no-DNSSEC no-ID loop-detect inotify dumpfile
Thu Oct 24 21:49:46 2019 daemon.info dnsmasq-dhcp[20273]: DHCP, IP range 192.168.3.100 -- 192.168.3.119, lease time 1h
Thu Oct 24 21:49:46 2019 daemon.info dnsmasq-dhcp[20273]: DHCP, sockets bound exclusively to interface wlan1-2
Thu Oct 24 21:49:46 2019 daemon.info dnsmasq[20273]: using local addresses only for domain test
Thu Oct 24 21:49:46 2019 daemon.info dnsmasq[20273]: using local addresses only for domain onion
Thu Oct 24 21:49:46 2019 daemon.info dnsmasq[20273]: using local addresses only for domain localhost
Thu Oct 24 21:49:46 2019 daemon.info dnsmasq[20273]: using local addresses only for domain local
Thu Oct 24 21:49:46 2019 daemon.info dnsmasq[20273]: using local addresses only for domain invalid
Thu Oct 24 21:49:46 2019 daemon.info dnsmasq[20273]: using local addresses only for domain bind
Thu Oct 24 21:49:46 2019 daemon.info dnsmasq[20273]: using nameserver 208.67.220.222#53
Thu Oct 24 21:49:46 2019 daemon.info dnsmasq[20273]: using nameserver 208.67.222.220#53
Thu Oct 24 21:49:46 2019 daemon.info dnsmasq[20273]: using nameserver 208.67.220.220#53
Thu Oct 24 21:49:46 2019 daemon.info dnsmasq[20273]: using nameserver 208.67.222.222#53
Thu Oct 24 21:49:46 2019 daemon.info dnsmasq[20273]: using local addresses only for domain guest
Thu Oct 24 21:49:46 2019 daemon.warn dnsmasq[20273]: no servers found in /tmp/resolv.conf.guest, will retry
Thu Oct 24 21:49:46 2019 daemon.info dnsmasq[20273]: read /etc/hosts - 12 addresses
Thu Oct 24 21:49:46 2019 daemon.info dnsmasq[20273]: read /tmp/hosts/dhcp.main - 1 addresses
Thu Oct 24 21:49:46 2019 daemon.info dnsmasq[20273]: read /tmp/hosts/dhcp.guest - 1 addresses
Thu Oct 24 21:49:46 2019 daemon.info dnsmasq[20273]: read /etc/hosts-restricted/hosts - 388 addresses
Thu Oct 24 21:49:46 2019 daemon.info dnsmasq-dhcp[20273]: read /etc/ethers - 0 addresses
Thu Oct 24 21:49:46 2019 daemon.info dnsmasq[20273]: read /etc/hosts - 12 addresses
Thu Oct 24 21:49:46 2019 daemon.info dnsmasq[17301]: read /etc/hosts - 12 addresses
Thu Oct 24 21:49:46 2019 daemon.info dnsmasq[17301]: read /tmp/hosts/dhcp.main - 1 addresses
Thu Oct 24 21:49:46 2019 daemon.info dnsmasq[17301]: read /tmp/hosts/dhcp.guest - 1 addresses
Thu Oct 24 21:49:46 2019 daemon.info dnsmasq-dhcp[17301]: read /etc/ethers - 0 addresses
Thu Oct 24 21:49:46 2019 daemon.info dnsmasq[20273]: read /tmp/hosts/dhcp.main - 1 addresses
Thu Oct 24 21:49:46 2019 daemon.info dnsmasq[20273]: read /tmp/hosts/dhcp.guest - 1 addresses
Thu Oct 24 21:49:46 2019 daemon.info dnsmasq[20273]: read /etc/hosts-restricted/hosts - 388 addresses
Thu Oct 24 21:49:46 2019 daemon.info dnsmasq-dhcp[20273]: read /etc/ethers - 0 addresses
Thu Oct 24 21:49:48 2019 kern.warn kernel: [26801.468291] br-lan: received packet on bat0.1 with own address as source address (addr:60:e3:27:78:85:37, vlan:0)
Thu Oct 24 21:49:58 2019 kern.warn kernel: [26811.708326] br-lan: received packet on bat0.1 with own address as source address (addr:60:e3:27:78:85:37, vlan:0)
Thu Oct 24 21:50:08 2019 kern.warn kernel: [26821.948033] br-lan: received packet on bat0.1 with own address as source address (addr:60:e3:27:78:85:37, vlan:0)
Thu Oct 24 21:50:18 2019 kern.warn kernel: [26832.188154] br-lan: received packet on bat0.1 with own address as source address (addr:60:e3:27:78:85:37, vlan:0)
Thu Oct 24 21:50:29 2019 kern.warn kernel: [26842.428104] br-lan: received packet on bat0.1 with own address as source address (addr:60:e3:27:78:85:37, vlan:0)

it is the first time i look at log on openwrt, if more is needed please let me know

m

Thu Oct 24 21:41:12 2019 daemon.notice netifd: Interface 'nwi_mesh0' is setting up now
Thu Oct 24 21:41:12 2019 kern.info kernel: [26285.835150] IPv6: ADDRCONF(NETDEV_CHANGE): mesh0: link becomes ready
Thu Oct 24 21:41:12 2019 daemon.notice wpa_supplicant[19171]: mesh0: CTRL-EVENT-CONNECTED - Connection to 00:00:00:00:00:00 completed [id=0 id_str=]
Thu Oct 24 21:41:12 2019 daemon.notice wpa_supplicant[19171]: mesh0: MESH-GROUP-STARTED ssid="<redacted>" id=0

from the "encrypted" logs suggests to me that the mesh comes up properly. I don't see peers connecting though. From my Archer C7v2 (my log format is slightly different as I use syslog-ng):

2019 Jul 23 03:13:26 garage err wpa_supplicant: Using interface mesh0 with hwaddr c4:6e:1f:aa:aa:aa and ssid ""
2019 Jul 23 03:13:26 garage notice wpa_supplicant: mesh0: interface state UNINITIALIZED->ENABLED
2019 Jul 23 03:13:26 garage notice wpa_supplicant: mesh0: AP-ENABLED 
2019 Jul 23 03:13:26 garage notice wpa_supplicant: mesh0: CTRL-EVENT-CONNECTED - Connection to 00:00:00:00:00:00 completed [id=0 id_str=]
2019 Jul 23 03:13:26 garage notice wpa_supplicant: mesh0: MESH-GROUP-STARTED ssid="<redacted>" id=0
2019 Jul 23 03:13:27 garage notice wpa_supplicant: mesh0: new peer notification for 32:23:03:xx:xx:xx
2019 Jul 23 03:13:27 garage notice wpa_supplicant: mesh0: new peer notification for 32:23:03:yy:yy:yy
2019 Jul 23 03:13:27 garage notice wpa_supplicant: mesh0: new peer notification for 32:23:03:zz:zz:zz
2019 Jul 23 03:13:27 garage notice wpa_supplicant: mesh0: mesh plink with 32:23:03:zz:zz:zz established
2019 Jul 23 03:13:27 garage notice wpa_supplicant: mesh0: MESH-PEER-CONNECTED 32:23:03:zz:zz:zz
[...]