Cannot connect the default OpenWrt 5g network after connecting OpenWrt router to my ISP router

Hello there :wave:
this is my message in a bottle, because I don't see what do I have missed. :woozy_face:

I can connect the OpenWrt 5g default ap (after enabling it), here is its working configuration :

config wifi-device 'radio0'
  option type 'mac80211'
  option path 'pci0000:00/0000:00:00.0'
  option channel '36'
  option band '5g'
  option htmode 'VHT80'

config wifi-iface 'default_radio0'
  option device 'radio0'
  option network 'lan'
  option mode 'ap'
  option ssid 'OpenWrt'
  option encryption 'none'

In this first case : no problem, I'm able to join that default « OpenWrt » wireless 5g network :+1:

And then, here is the second case, when trying to connect this « OpenWrt router » to my « Internet service provider (ISP) router », using the LuCI web GUI :

  1. Clicking on "radio0" Scan button
  2. Selecting my ISP router's wireless network (called "boom")
  3. Leaving all default options
  4. Clicking on "Save & Apply" button
  5. Rebooting the OpenWrt router

In this second case : I'm not able anymore to see the default « OpenWrt » wireless 5g network :thinking:

Here is the second case configuration :

config wifi-device 'radio0'
  option type 'mac80211'
  option path 'pci0000:00/0000:00:00.0'
  option channel '36'
  option band '5g'
  option htmode 'VHT80'

config wifi-iface 'default_radio0'
  option device 'radio0'
  option network 'lan'
  option mode 'ap'
  option ssid 'OpenWrt'
  option encryption 'none'

config wifi-iface 'wifinet2'
  option device 'radio0'
  option mode 'sta'
  option network 'wwan'
  option ssid 'boom'
  option encryption 'psk2'
  option key 'this aint my password'

Using OpenWrt 22.03.5 r20134-5f15225c1e on a « TP-Link RE450 v3 ».
Having the same issue using a « TP-Link Archer C7 AC1750 v2 ».

Thanks for reading
Have a great day

  1. Is this a fresh installlation or was there a time this config worked for you?
  2. Have you followed OpenWrt documentation for relaying? - See here: https://openwrt.org/docs/guide-user/network/wifi/relay_configuration. As I see it, you want to extend your main routers wifi?
1 Like

Hey ThiloteE, thanks for the reply

  1. This is a fresh install
  2. I've also tried to follow the OpenWrt Wiki, see bellow

Using LuCI :

  1. Resetting the firmware to its initial state
  2. Defining a specific lan IPv4 address (192.168.20.1), Save & Apply
  3. Scanning for a 5g wireless network, joining (default options), Save & Apply, I can see the Associated Station (ISP router)
  4. Testing IPv4 Ping from the OpenWrt router : working
  5. Updating software lists
  6. Adding luci-proto-relay, Install
  7. Refreshing the LuCI web GUI page
  8. Rebooting OpenWrt router

Now taking the OpenWrt Wiki : Wi-Fi extender / repeater / bridge configuration

  • The LAN interface must be set in a different subnet than the Wi-Fi network you are connecting to : I did that already
  • Disable DHCP for the LAN interface (as it does prevent relayd from working)
    • ok going to Interfaces > lan > DHCP Server > General Setup > Ignore interface
    • then IPv6 Settings
      • RA-Service : disabled
      • DHCPv6-Service : disabled
    • Save
    • Save & Apply
  • Manually opening the LuCI web GUI, using the OpenWrt router IP address (192.168.20.1 in my case)
  • Navigate to the wireless networks page, and click on Scan button for the desired radio
  • Choose the Wi-Fi network you want to connect to from the page and click Join Network
  • Enter the Wi-Fi password, leave the “name of new network” as “wwan” and select lan firewall zone.
    • ok so I select the lan firewall-zone.
  • Set the Mode (...) ok my mode is AC
  • Set the Width to the same value that you set on the Wi-Fi you are connecting to ok checking from my computer with a iw wlp0s20f3 link (where wlp0s20f3 is my personal device name) and I do have a rx bitrate: 175.5 MBit/s VHT-MCS 4 80MHz VHT-NSS 1 so I think 80MHz is my Width, so not changing this option.
  • Do NOT change the wifi channel number ok sure, lol
  • Save
  • Save & Apply
  • Removing redundant WAN interface and firewall zones (Optional) ok skipping that part
  • Configure static IP address on wwan interface
    • General Settings
      • Protocol : Static address
      • Switch protocol
      • address : 192.168.1.30 (remember that wwan IP)
      • netmask : 255.255.255.0
      • gateway : 192.168.1.1 (which is my ISP router)
      • Save
    • Advanced Settings
      • Use custom DNS servers : 192.168.1.1 (which is my ISP router)
  • Testing Connection : all good
  • Installing relayd package : already done that
  • Creating Relay Interface to add the relayd interface that will join/bridge the lan and wwan interfaces
    • Network > Intefaces > Add new interface button
      • Name : repeater_bridge
      • Protocol : Relay bridge
    • Enter the IP address assigned to the WWAN interface
      • Local IPv4 address : 192.168.1.30 (as it is my wwan IP)
      • Relay between networks : lan + wwan
      • Save
  • Save & Apply
  • Reboot the rooter
    • System > Reboot > Perform reboot

But then

I'm still not able to see any wireless AP from my computer :thinking:

And what I see in LuCI is the default OpenWrt AP is disabled :thinking: (and enabling it would still do nothing, that wireless network is not listed on my computer)

Did I miss something in the OpenWrt Wiki ?

Another test (on the 2g radio, this time)

  1. Resetting the firmware to its initial state
  2. Defining a specific lan IPv4 address (192.168.20.1), Save, Save & Apply, Apply
  3. Scanning for a 2g wireless network, joining (default options), Save & Apply, I can see the Associated Station (ISP router)
  4. Testing IPv4 Ping from the OpenWrt router : working
  5. Enabling the default OpenWrt Access Point (iface) on that same radio

Then, unlike my 5g first attempt, I am here able to :

  • See that OpenWrt Access Point
  • Join that access point from my computer
  • And browse the web from my computer !

How could that be so different using 5g instead of 2g ? This is what I really don't get for a couple of days now :laughing:

If you're connecting to your ISP device as a client, set the AP to auto.

This is because the AP needs to know the STA channel first- most importantly, the radio can only use 1 channel, hence why the AP doesn't come up.

If you need channel 36 to be statically set, try setting that on the ISP device.

There's the Travelmate package that may assist also.

Hope this helps.

Hey lleachii, thanks for the reply

Following your directions, here is what I've done :

  1. Scanning for my ISP router using 5g radio, joining. OpenWrt associated, IPv4 Ping ok.

  2. You are saying that If you're connecting to your ISP device as a client, set the AP to auto so I'm going to the default "OpenWrt" AP on 5g radio, Edit, set Operating frequency > Channel > auto, Save, Save & Apply. Then enabling that "OpenWrt" AP 5g radio.

But I'm still not able to see that "OpenWrt" AP 5g from my computer.

I'm still not understanding why the 5GHz is so different from the 2GHz (see that previous test)

But I will give a try to Travelmate, thanks !

1 Like

What channel is the AP?

Doing a nmcli -f NAME,SSID,BSSID,MODE,CHAN,FREQ,RATE,SIGNAL,BARS,SECURITY,IN-USE device wifi on my computer, I see that my ISP router 5g radio is using chan 112 (freq 5560 MHz).

Giving a try with Travelmate

  1. Scanning for my ISP router using 5g radio, joining. OpenWrt associated, IPv4 Ping ok.
  2. System > Software > Update lists
  3. Filter : luci-app-travelmate, Install
  4. Refreshing the LuCI webpage
  5. Services > Travelmate > Interface Wizard
    • The uplink interface name : trm_area
    • The firewall zone name : wan
    • The interface metric : 100
    • Save
    • Waiting for 2 minutes

Same issue, looks like the 2GHz radio AP is working, but not the 5GHz.

Channel 112 is subject to different regulations in different countries. It is essential to set your country code in the wifi config so the driver knows what channels and powers it can use. Set both radios to the same country even if you are leaving one disabled.

In many countries channel 112 is a DFS channel which means that APs have to check for radar signals before they can start up on the air. Some chips and drivers do not allow simultaneous AP and STA mode operation on the same radio on a DFS channel. In one case it was necessary to explicitly set the channel to the one of the other AP that the STA will connect to.

1 Like

Hey mk24, thanks for your reply
Following your directions here are my new tests :

Test A (2g)

  1. Resetting the OpenWrt router to default
  2. Setting a specific lan IPv4 address : 10.0.0.1
  3. Save, Save & Apply, Apply with revert (...)
  4. Scanning for my ISP router's wireless on 802.11bgn (2g)
  5. Found (chan 1), Join, Joining Network (default), Submit, Save, Save & Apply
  6. Waiting for 10 seconds to see if the station is going to be associated ...
  7. Station (ISP router) is properly associated (the Associated Station's Host value is a real private IP )
  8. Now enabling the default/existing OpenWrt AP on 802.11bgn (2g)
  9. Scanning from my computer (with a nmcli -f NAME,SSID,BSSID,MODE,CHAN,FREQ,RATE,SIGNAL,BARS,SECURITY,IN-USE device wifi) : found the OpenWrt SSID (chan 1, freq 2412 MHz, rate 195 Mbit/s) :white_check_mark:

Here is a cat /etc/config/wireless of the above working Test :

config wifi-device 'radio1'
  option type 'mac80211'
  option path 'platform/ahb/18100000.wmac'
  option channel '1'
  option band '2g'
  option htmode 'HT20'
  option cell_density '0'

config wifi-iface 'default_radio1'
  option device 'radio1'
  option network 'lan'
  option mode 'ap'
  option ssid 'OpenWrt'
  option encryption 'none'

config wifi-iface 'wifinet2'
  option device 'radio1'
  option mode 'sta'
  option network 'wwan'
  option ssid 'boom2'
  option encryption 'psk2'
  option key 'total-secret-password'

Test B (5g)

  1. Resetting the OpenWrt router to default
  2. Setting a specific lan IPv4 address : 10.0.0.1
  3. Save, Save & Apply, Apply with revert (...)
  4. Scanning for my ISP router's wireless on 802.11acn (5g)
  5. Found (chan 112), Join, Joining Network (default), Submit
    • :warning: holdon, this is the first time I'm noticing the fact that this Wireless Network connection "wizard" is actually offering a different chan (chan 36) than the one it has just scanned (chan 112) :thinking:
      • so I'm going to the "Advanced Settings" tab and selecting Country Code : FR
      • then back to the "General Setup" tab and selecting the same chan as the one it has just scanned (chan 112)
      • Save, Save & Apply
  6. Waiting for 10 seconds to see if the station is going to be associated ...
  7. Station (ISP router) is properly associated (:roll_eyes: but the Associated Station's Host value is ?, no IP here)
  8. Now enabling the default/existing OpenWrt AP on 802.11acn (5g)
  9. Scanning from my computer (with a nmcli -f NAME,SSID,BSSID,MODE,CHAN,FREQ,RATE,SIGNAL,BARS,SECURITY,IN-USE device wifi) : :x: cannot find the OpenWrt SSID (chan 112, freq 5560 MHz)

Test C (5g)

Now I'm changing my ISP router 5g channel to 64 (instead of the automatic 112 that it decided to use).

  1. Resetting the OpenWrt router to default

  2. Setting a specific lan IPv4 address : 10.0.0.1

  3. Save, Save & Apply, Apply with revert (...)

  4. Scanning for my ISP router's wireless on 802.11acn (5g)

  5. Found (chan 64), Join, Joining Network (default), Submit

    • It's quite strange cause the Wireless Network connection "wizard" has finally chosen a different channel (chan 36) :thinking:. See the the following values (extracted using a cat /etc/config/wireless) :
    config wifi-device 'radio0'
     option type 'mac80211'
     option path 'pci0000:00/0000:00:00.0'
     option channel '36'
     option band '5g'
     option htmode 'VHT80'
     option cell_density '0'
    
    config wifi-iface 'default_radio0'
      option device 'radio0'
      option network 'lan'
      option mode 'ap'
      option ssid 'OpenWrt'
      option encryption 'none'
      option disabled '1'
    
    config wifi-iface 'wifinet2'
      option device 'radio0'
      option mode 'sta'
      option network 'wwan'
      option ssid 'boom'
      option encryption 'psk2'
      option key 'total-secret-password'
    
  6. Station (ISP router) is properly associated (:roll_eyes: but the Associated Station's Host value is ?, no IP here)

  7. Now enabling the default/existing OpenWrt AP on 802.11acn (5g)

  8. Scanning from my computer (with a nmcli -f NAME,SSID,BSSID,MODE,CHAN,FREQ,RATE,SIGNAL,BARS,SECURITY,IN-USE device wifi) : :x: cannot find the OpenWrt SSID (chan 36, freq 5180 MHz)

  9. Changing the AP channel to chan Auto, Save & Apply : :x: cannot find the OpenWrt SSID

  10. Changing the AP channel to chan 64, Save & Apply : :x: cannot find the OpenWrt SSID

Well, I think I'm getting a little bit despaired :weary:

Can you show what is in cat /etc/config/network?

Thanks for the reply, there you go :

2g AP

With this configuration, I am able to browse the web from my computer, connected to the "OpenWrt" AP.

cat /etc/config/network

config interface 'loopback'
  option device 'lo'
  option proto 'static'
  option ipaddr '127.0.0.1'
  option netmask '255.0.0.0'

config globals 'globals'
  option ula_prefix 'fd33:a403:7467::/48'

config device
  option name 'br-lan'
  option type 'bridge'
  list ports 'eth0'

config interface 'lan'
  option device 'br-lan'
  option proto 'static'
  option netmask '255.255.255.0'
  option ip6assign '60'
  option ipaddr '192.168.20.1'

config interface 'wwan'
  option proto 'dhcp'

cat /etc/config/wireless

config wifi-device 'radio1'
  option type 'mac80211'
  option path 'platform/ahb/18100000.wmac'
  option channel '1'
  option band '2g'
  option cell_density '0'
  option htmode 'HT40'

config wifi-iface 'default_radio1'
  option device 'radio1'
  option network 'lan'
  option mode 'ap'
  option ssid 'OpenWrt'
  option encryption 'none'

config wifi-iface 'wifinet2'
  option device 'radio1'
  option mode 'sta'
  option network 'wwan'
  option ssid 'boom2'
  option encryption 'psk2'
  option key 'secret'

5g AP

With this configuration, I am not even able to see the "OpenWrt" AP from my computer.

cat /etc/config/network

config interface 'loopback'
  option device 'lo'
  option proto 'static'
  option ipaddr '127.0.0.1'
  option netmask '255.0.0.0'

config globals 'globals'
  option ula_prefix 'fd6c:2219:faff::/48'

config device
  option name 'br-lan'
  option type 'bridge'
  list ports 'eth0'

config interface 'lan'
  option device 'br-lan'
  option proto 'static'
  option netmask '255.255.255.0'
  option ip6assign '60'
  option ipaddr '192.168.20.1'

config interface 'wwan'
  option proto 'dhcp'

cat /etc/config/wireless

config wifi-device 'radio0'
  option type 'mac80211'
  option path 'pci0000:00/0000:00:00.0'
  option channel '36'
  option band '5g'
  option htmode 'VHT80'
  option cell_density '0'

config wifi-iface 'default_radio0'
  option device 'radio0'
  option network 'lan'
  option mode 'ap'
  option ssid 'OpenWrt'
  option encryption 'none'

config wifi-iface 'wifinet2'
  option device 'radio0'
  option mode 'sta'
  option network 'wwan'
  option ssid 'boom'
  option encryption 'psk2'
  option key 'secret'

Interesting. I am having a hunch what it could be, but i am not sure yet. I am a little confused about what your desired network topology actually is. Your config is closer to a dumb-accesspoint configuration, so i guess you do not actually want to use your OpenWrt device as wifi repeater. Could you please clarify?

Do you desire:

a) main router → wifi → OpenWrt (dumb-accesspoint config) → cable → Client PC
or
b) main router → cable → OpenWrt (dumb-accesspoint config) → wifi → Client PC
or
c) ...

I just checked my dumb AP's config (snapshot from April 2023; kernel 5.15) and it is slightly different. I use following topology:

main router → cable → OpenWrt (dumb-accesspoint config) → wifi → Client PC

cat /etc/config/network

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option packet_steering '1'
	option ula_prefix 'xxxx:xxxx:xxxx::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ip6assign '60'
	option gateway '192.168.178.1'
	list ipaddr '192.168.178.82/24'

Main difference is
list ports 'lan'

Edit: Not sure about all the differences between kernel 5.10 and 5.15, so yeah...

Your config is similar to DumbAP config for switch and dedicated wan devices post 21.01

thanks for the follow up !

yup, I'm just trying to do a ISP router → wifi 5g → OpenWrt → wifi 5g → Client PC

let's see your complete config (all in one post).

Please copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

ubus call system board
cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall

ok, great. Then https://openwrt.org/docs/guide-user/network/wifi/relay_configuration is the way to go i think.

actually it might be best to ignore the config from my last post, as syntax might have changed between kernel 5.10 and kernel 5.15, so yeah.... could trip you up.

Still regarding my will to make my router a repeater :

ISP router → wifi → OpenWrt → wifi → client PC

Here are some attempts and even more cat :smiley_cat: and ubus (thanks Peter Sherman)

2g

Using the LuCI interface, wireless scan & join + enabling default AP is working :white_check_mark:

ubus call system board; \
cat /etc/config/network; \
cat /etc/config/wireless; \
cat /etc/config/dhcp; \
cat /etc/config/firewall;
{
  "kernel": "5.10.176",
  "hostname": "OpenWrt",
  "system": "Qualcomm Atheros QCA956X ver 1 rev 0",
  "model": "TP-Link RE450 v3",
  "board_name": "tplink,re450-v3",
  "rootfs_type": "squashfs",
  "release": {
    "distribution": "OpenWrt",
    "version": "22.03.5",
    "revision": "r20134-5f15225c1e",
    "target": "ath79/generic",
    "description": "OpenWrt 22.03.5 r20134-5f15225c1e"
  }
}

config interface 'loopback'
  option device 'lo'
  option proto 'static'
  option ipaddr '127.0.0.1'
  option netmask '255.0.0.0'

config globals 'globals'
  option ula_prefix 'fdd3:724a:5bb9::/48'

config device
  option name 'br-lan'
  option type 'bridge'
  list ports 'eth0'

config interface 'lan'
  option device 'br-lan'
  option proto 'static'
  option netmask '255.255.255.0'
  option ip6assign '60'
  option ipaddr '192.168.20.1'

config interface 'wwan'
  option proto 'dhcp'


config wifi-device 'radio0'
  option type 'mac80211'
  option path 'pci0000:00/0000:00:00.0'
  option channel '36'
  option band '5g'
  option htmode 'VHT80'
  option disabled '1'

config wifi-iface 'default_radio0'
  option device 'radio0'
  option network 'lan'
  option mode 'ap'
  option ssid 'OpenWrt'
  option encryption 'none'

config wifi-device 'radio1'
  option type 'mac80211'
  option path 'platform/ahb/18100000.wmac'
  option channel '1'
  option band '2g'
  option htmode 'HT20'
  option cell_density '0'

config wifi-iface 'default_radio1'
  option device 'radio1'
  option network 'lan'
  option mode 'ap'
  option ssid 'OpenWrt'
  option encryption 'none'

config wifi-iface 'wifinet2'
  option device 'radio1'
  option mode 'sta'
  option network 'wwan'
  option ssid 'boom2'
  option encryption 'psk2'
  option key 'secret'


config dnsmasq
  option domainneeded '1'
  option boguspriv '1'
  option filterwin2k '0'
  option localise_queries '1'
  option rebind_protection '1'
  option rebind_localhost '1'
  option local '/lan/'
  option domain 'lan'
  option expandhosts '1'
  option nonegcache '0'
  option authoritative '1'
  option readethers '1'
  option leasefile '/tmp/dhcp.leases'
  option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
  option nonwildcard '1'
  option localservice '1'
  option ednspacket_max '1232'

config dhcp 'lan'
  option interface 'lan'
  option start '100'
  option limit '150'
  option leasetime '12h'
  option dhcpv4 'server'
  option dhcpv6 'server'
  option ra 'server'
  list ra_flags 'managed-config'
  list ra_flags 'other-config'

config dhcp 'wan'
  option interface 'wan'
  option ignore '1'

config odhcpd 'odhcpd'
  option maindhcp '0'
  option leasefile '/tmp/hosts/odhcpd'
  option leasetrigger '/usr/sbin/odhcpd-update'
  option loglevel '4'


config defaults
  option syn_flood '1'
  option input 'ACCEPT'
  option output 'ACCEPT'
  option forward 'REJECT'

config zone
  option name 'lan'
  option input 'ACCEPT'
  option output 'ACCEPT'
  option forward 'ACCEPT'
  list network 'lan'

config zone
  option name 'wan'
  option input 'REJECT'
  option output 'ACCEPT'
  option forward 'REJECT'
  option masq '1'
  option mtu_fix '1'
  list network 'wan'
  list network 'wan6'
  list network 'wwan'

config forwarding
  option src 'lan'
  option dest 'wan'

config rule
  option name 'Allow-DHCP-Renew'
  option src 'wan'
  option proto 'udp'
  option dest_port '68'
  option target 'ACCEPT'
  option family 'ipv4'

config rule
  option name 'Allow-Ping'
  option src 'wan'
  option proto 'icmp'
  option icmp_type 'echo-request'
  option family 'ipv4'
  option target 'ACCEPT'

config rule
  option name 'Allow-IGMP'
  option src 'wan'
  option proto 'igmp'
  option family 'ipv4'
  option target 'ACCEPT'

config rule
  option name 'Allow-DHCPv6'
  option src 'wan'
  option proto 'udp'
  option dest_port '546'
  option family 'ipv6'
  option target 'ACCEPT'

config rule
  option name 'Allow-MLD'
  option src 'wan'
  option proto 'icmp'
  option src_ip 'fe80::/10'
  list icmp_type '130/0'
  list icmp_type '131/0'
  list icmp_type '132/0'
  list icmp_type '143/0'
  option family 'ipv6'
  option target 'ACCEPT'

config rule
  option name 'Allow-ICMPv6-Input'
  option src 'wan'
  option proto 'icmp'
  list icmp_type 'echo-request'
  list icmp_type 'echo-reply'
  list icmp_type 'destination-unreachable'
  list icmp_type 'packet-too-big'
  list icmp_type 'time-exceeded'
  list icmp_type 'bad-header'
  list icmp_type 'unknown-header-type'
  list icmp_type 'router-solicitation'
  list icmp_type 'neighbour-solicitation'
  list icmp_type 'router-advertisement'
  list icmp_type 'neighbour-advertisement'
  option limit '1000/sec'
  option family 'ipv6'
  option target 'ACCEPT'

config rule
  option name 'Allow-ICMPv6-Forward'
  option src 'wan'
  option dest '*'
  option proto 'icmp'
  list icmp_type 'echo-request'
  list icmp_type 'echo-reply'
  list icmp_type 'destination-unreachable'
  list icmp_type 'packet-too-big'
  list icmp_type 'time-exceeded'
  list icmp_type 'bad-header'
  list icmp_type 'unknown-header-type'
  option limit '1000/sec'
  option family 'ipv6'
  option target 'ACCEPT'

config rule
  option name 'Allow-IPSec-ESP'
  option src 'wan'
  option dest 'lan'
  option proto 'esp'
  option target 'ACCEPT'

config rule
  option name 'Allow-ISAKMP'
  option src 'wan'
  option dest 'lan'
  option dest_port '500'
  option proto 'udp'
  option target 'ACCEPT'

5g

Using the LuCI interface, wireless scan & join + enabling default AP is .. NOT working :x:

ubus call system board; \
cat /etc/config/network; \
cat /etc/config/wireless; \
cat /etc/config/dhcp; \
cat /etc/config/firewall;
{
  "kernel": "5.10.176",
  "hostname": "OpenWrt",
  "system": "Qualcomm Atheros QCA956X ver 1 rev 0",
  "model": "TP-Link RE450 v3",
  "board_name": "tplink,re450-v3",
  "rootfs_type": "squashfs",
  "release": {
    "distribution": "OpenWrt",
    "version": "22.03.5",
    "revision": "r20134-5f15225c1e",
    "target": "ath79/generic",
    "description": "OpenWrt 22.03.5 r20134-5f15225c1e"
  }
}

config interface 'loopback'
  option device 'lo'
  option proto 'static'
  option ipaddr '127.0.0.1'
  option netmask '255.0.0.0'

config globals 'globals'
  option ula_prefix 'fd3b:f6b0:52d2::/48'

config device
  option name 'br-lan'
  option type 'bridge'
  list ports 'eth0'

config interface 'lan'
  option device 'br-lan'
  option proto 'static'
  option netmask '255.255.255.0'
  option ip6assign '60'
  option ipaddr '192.168.20.1'

config interface 'wwan'
  option proto 'dhcp'


config wifi-device 'radio0'
  option type 'mac80211'
  option path 'pci0000:00/0000:00:00.0'
  option channel '36'
  option band '5g'
  option htmode 'VHT80'
  option cell_density '0'

config wifi-iface 'default_radio0'
  option device 'radio0'
  option network 'lan'
  option mode 'ap'
  option ssid 'OpenWrt'
  option encryption 'none'

config wifi-device 'radio1'
  option type 'mac80211'
  option path 'platform/ahb/18100000.wmac'
  option channel '1'
  option band '2g'
  option htmode 'HT20'
  option disabled '1'

config wifi-iface 'default_radio1'
  option device 'radio1'
  option network 'lan'
  option mode 'ap'
  option ssid 'OpenWrt'
  option encryption 'none'

config wifi-iface 'wifinet2'
  option device 'radio0'
  option mode 'sta'
  option network 'wwan'
  option ssid 'boom'
  option encryption 'psk2'
  option key 'secret'


config dnsmasq
  option domainneeded '1'
  option boguspriv '1'
  option filterwin2k '0'
  option localise_queries '1'
  option rebind_protection '1'
  option rebind_localhost '1'
  option local '/lan/'
  option domain 'lan'
  option expandhosts '1'
  option nonegcache '0'
  option authoritative '1'
  option readethers '1'
  option leasefile '/tmp/dhcp.leases'
  option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
  option nonwildcard '1'
  option localservice '1'
  option ednspacket_max '1232'

config dhcp 'lan'
  option interface 'lan'
  option start '100'
  option limit '150'
  option leasetime '12h'
  option dhcpv4 'server'
  option dhcpv6 'server'
  option ra 'server'
  list ra_flags 'managed-config'
  list ra_flags 'other-config'

config dhcp 'wan'
  option interface 'wan'
  option ignore '1'

config odhcpd 'odhcpd'
  option maindhcp '0'
  option leasefile '/tmp/hosts/odhcpd'
  option leasetrigger '/usr/sbin/odhcpd-update'
  option loglevel '4'


config defaults
  option syn_flood '1'
  option input 'ACCEPT'
  option output 'ACCEPT'
  option forward 'REJECT'

config zone
  option name 'lan'
  option input 'ACCEPT'
  option output 'ACCEPT'
  option forward 'ACCEPT'
  list network 'lan'

config zone
  option name 'wan'
  option input 'REJECT'
  option output 'ACCEPT'
  option forward 'REJECT'
  option masq '1'
  option mtu_fix '1'
  list network 'wan'
  list network 'wan6'
  list network 'wwan'

config forwarding
  option src 'lan'
  option dest 'wan'

config rule
  option name 'Allow-DHCP-Renew'
  option src 'wan'
  option proto 'udp'
  option dest_port '68'
  option target 'ACCEPT'
  option family 'ipv4'

config rule
  option name 'Allow-Ping'
  option src 'wan'
  option proto 'icmp'
  option icmp_type 'echo-request'
  option family 'ipv4'
  option target 'ACCEPT'

config rule
  option name 'Allow-IGMP'
  option src 'wan'
  option proto 'igmp'
  option family 'ipv4'
  option target 'ACCEPT'

config rule
  option name 'Allow-DHCPv6'
  option src 'wan'
  option proto 'udp'
  option dest_port '546'
  option family 'ipv6'
  option target 'ACCEPT'

config rule
  option name 'Allow-MLD'
  option src 'wan'
  option proto 'icmp'
  option src_ip 'fe80::/10'
  list icmp_type '130/0'
  list icmp_type '131/0'
  list icmp_type '132/0'
  list icmp_type '143/0'
  option family 'ipv6'
  option target 'ACCEPT'

config rule
  option name 'Allow-ICMPv6-Input'
  option src 'wan'
  option proto 'icmp'
  list icmp_type 'echo-request'
  list icmp_type 'echo-reply'
  list icmp_type 'destination-unreachable'
  list icmp_type 'packet-too-big'
  list icmp_type 'time-exceeded'
  list icmp_type 'bad-header'
  list icmp_type 'unknown-header-type'
  list icmp_type 'router-solicitation'
  list icmp_type 'neighbour-solicitation'
  list icmp_type 'router-advertisement'
  list icmp_type 'neighbour-advertisement'
  option limit '1000/sec'
  option family 'ipv6'
  option target 'ACCEPT'

config rule
  option name 'Allow-ICMPv6-Forward'
  option src 'wan'
  option dest '*'
  option proto 'icmp'
  list icmp_type 'echo-request'
  list icmp_type 'echo-reply'
  list icmp_type 'destination-unreachable'
  list icmp_type 'packet-too-big'
  list icmp_type 'time-exceeded'
  list icmp_type 'bad-header'
  list icmp_type 'unknown-header-type'
  option limit '1000/sec'
  option family 'ipv6'
  option target 'ACCEPT'

config rule
  option name 'Allow-IPSec-ESP'
  option src 'wan'
  option dest 'lan'
  option proto 'esp'
  option target 'ACCEPT'

config rule
  option name 'Allow-ISAKMP'
  option src 'wan'
  option dest 'lan'
  option dest_port '500'
  option proto 'udp'
  option target 'ACCEPT'

conclusion

Still not understanding why this is working using LuCI for 2g, but not for 5g.

I did try the Wiki's directions « Wi-Fi extender / repeater / bridge configuration », and it was not a success, but maybe I should try them again from scratch, tirelessly.

There is still no country set. In the wifi-iface sections, add a line option country XX replacing XX with your two-letter country code.