Cannot connect OpenWrt router (Redmi ac2100) directly to main router

Hello! So there are two stories in my house. I am running a LAN cable down from the upper story to the bottom story. I had an old Tp-link router setup before. Then I got a Redmi ac2100 router and I want to use this one instead of the Tp-link router. I installed openwrt on the Redmi router. When I connect the LAN cable coming from the main router directly into the Redmi router, my devices say "Connected, no internet". Wireless doesn't work and neither does LAN. But when I connect the LAN cable from the main router into the Tp-link router and then run a cable from the Tp-link router to the Redmi router that has openwrt, the internet starts working fine.

I'm not sure what the issue is. I'm a total newbie. I don't know much about networks. I haven't done much on the router. I have installed luci and I have setup the 2.4ghz and 5ghz wifi connections. I would like to eliminate the tp-link router and use Redmi router in place of it. Here's a diagram of the situation :

Connecting the Redmi router directly to the main router worked before setting up openwrt on the router. I'm sure this is probably an issue in the configuration so if someone can help me fix this issue, that would be really awesome! Thanks.

You probably have routing issues, e.g. the same subnet 192.168.1.x used in several routers while you connect via wan ports or something like that.

As you have a wired cable from the main router to the new location, the easiest approach is the "dumb AP" config is where you dumb down the new OpenWrt router. You set the routers to be in the same subnet and connect the cable to a Lan port also in the OpenWrt router.

You need to tailor that advice to the addresses used by your main router, but the concept is quite generic.


Thanks for your reply! I have followed these steps and that has fixed the issue!

I have one more question. I use the luci interface. I was using "luci-wrtbwmon" before for tracking the internet usage for each device. It doesn't seem to be working now. I was also hoping to use the adblock software in openwrt. It doesn't seem to be working either. Is there any ways to make these work with the dumb ap config?

nlbwmon is your friend.


If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

I understood that if the dump ap uses the same subnet as the main router, conntrack is not involved and nlbwmon will not work. Is there a possibility to get it working without having a different subnet on the ap (so still the routers dhcp can be used ) ?

Yeah, those tools are designed to run in the actual router, not in the secondary access points.

E.g. adblock works by adjusting DNS, and when you use DHCP to get routing info (including DNS server) from the main router, the secondary access point has no real routing role and adblock in it gets bypassed.

Okay, got it. Thanks for explaining it so thoroughly :slight_smile:

Can I fix the original issue of this post without the dumb ap config? Is there some other way to fix it so I can use adblock and usage tracking?

That's not correct.

DNS is a the name resolver, you can run it on any device (with internet access) in your network, doesn't have to be on the actual router.

Just adjust your DHCP settings, and point the DNS to the IP of your dumb AP, and you're good to go.