Cannot change Wifi password

Hello everyone,

I'm first timer with OpenWrt. Problem is that I cannot change the Wifi password. I connect to the AP through wifi using my default password, after that when I try to change the password to something else I get:
"Failed to confirm apply within 30s, waiting for rollback"

  • " Configuration has been rolled back!*

The device could not be reached within 30 seconds after applying the pending changes, which caused the configuration to be rolled back for safety reasons. If you believe that the configuration changes are correct nonetheless, perform an unchecked configuration apply. Alternatively, you can dismiss this warning and edit changes before attempting to apply again, or revert all pending changes to keep the currently working configuration state."

And after that I'm still using the old wifi password.
How can I understand what causes this?

Edit: I shouldn't change wifi passwords without a wire.

If you were connected wired, that would not happen. The problem is that your PC becomes disconnected when the password changes, so the LuCI system thinks that you have made a mistake.

Click the red button to apply unchecked. Your PC will fail to connect; it should eventually ask for the new password. You may need to forget the network on the PC and reconnect from scratch.


I feel so silly for not thinking of this lol.
Thanks and have a good day!

If your problem is solved, feel free to mark the relevant post as the solution; and edit the title to add "[SOLVED]" to the beginning (click the pencil behind the topic).


1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.