Cannot access router

Hi,

I have a TP-Link ac1750 running openwrt. I've had it for a while, everything was fine. I changed the Mac in Interfaces yesterday as I do once a month or so to get a new ip from isp. Today the router is not working. I cannot access 192.168.0.1. I cannot ping it at all. I have tried doing a hard reset on the router, but I still cannot access anything. The lights on the router do come on, power, both signal lights, and lan if connected to PC. I do not have it connected to a modem right now. I am wits end trying to connect to it. Does anyone have any advice?

Thanks.

You could connect to the JTAG port to see what the console output is. There is also a tftp recovery method. Both are listed on the wiki.

What steps did you take to do the hard reset?

1 Like

Hi, I will take a look at jtag tftp. Thanks.

For the hard reset, I have tried holding the reset alone and with wps as well for 30 seconds. I've also done a full 30/30/30 powering it off and on in the middle with reset/wps. Honestly though? I don't think it worked at all. Like I don't even notice a different in lights when doing it.

This page has information on the changes in lights during reset and other modes.

Did the device stop working immediately after you made the config change?

It stopped immediately after the change and reboot. Normally it would boot up fine and have a new ip from my isp. This time, no connection to router at all.

I can get the router to enter failsafe mode. "A faster, 10-per-second blink if the user pressed a button and failsafe mode was triggered" I can reach this point. However, when connecting to pc I can still not ping the ip

Would suggest a bad config then. Try to read the fail safe and factory reset info in the wiki. They should help.

If you have a JTAG, even better, you'll be able to see the console of the router.

Did you do the following?

You must set your computer's ethernet port to use a static IP address in the 192.168.1.0/24 network (valid IPs are 192.168.1.2 - 192.168.1.254, subnet mask 255.255.255.0)

I did. However, I had an even stupider user error of not swapping from modem eth cable for forum back to broken router eth cable lol. :woman_facepalming:

Router is now back up and functional. Thanks for the failsafe info, that solved her. I was just doing tplink recommended reset buttons before. Next I'll restore from my backup and all should be good soon :+1:

Do you have any idea why changing the Mac would have toasted the router? The spot I changed was Network>Interfaces> Devices > br-lan and eth0.2 Mac. Normally this is fine and a quit change + reboot for a new ip?

Depends what you changed it to. If you can replicate it, maybe you can file a bug. I would have thought luci would validate the input.

Maybe you put an invalid character in or you put the same address as another port? Hard to tell because only you know what you changed it to!

Fair enough lol. Yea I might have done something invalid and it didn't validate. Seems odd that would cause the entire router/ip to be offline though and not allow me to ping/ssh in to fix.

Anyways, really appreciate the help! She's fully back up and purring along again with the original mac from my backup.