Cannot access Internet by using IPv6 with OpenWrt as a 2nd-level router and IPv6 relay mode

I'm now having a router from ISP as a first-level router (internal firewall disabled), which retrieves IPv6 /60 prefix from ISP and then assigns /64 prefix and GUA to its clients. My OpenWrt router's WAN port was linked to its LAN port (internal firewall disabled), and the wan6 interface was configured to relay mode to let fisrt-level router assigns IPv6 GUAs to clients of 2nd-level router. But with this setup, the clients of 2nd level router cannot access Internet (actions below was taken on Windows 11):

  • ping to hostname: cannot resolve
  • nslookup: timeout
  • nslookup with 2001:4860:4860::8888 as server: no response from server
  • ping to IPv6 on Internet: transmit failed general failure
  • tracert to IPv6 on Internet: transmit error code 1231
  • ping to IPv6 GUA of 2nd level router: unreachable
  • ping to IPv6 GUA of self: normal
  • ping to fe80::1: unreachable

Clients have already gained IPv6 GUA, and clients who connected to 1st level router directly can access Internet with IPv6 normally. This problem has confused me 3 days, tried the instructions in IPv6 Troubleshooting but nothing helpful, I think I really need some help cause it's necessary for me to use IPv6. Thanks to every kind heart.

/etc/config/network:

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option packet_steering '1'

config interface 'lan0'
        option device 'eth1'
        option proto 'static'
        option ipaddr '10.0.0.1'
        option netmask '255.255.255.0'
        option delegate '0'

config interface 'wan'
        option device 'eth0'
        option proto 'static'
        option ipaddr '192.168.100.7'
        option gateway '192.168.100.1'
        option netmask '255.255.255.0'
        option delegate '0'

config interface 'wan6'
        option proto 'dhcpv6'
        option device 'eth0'
        option reqaddress 'try'
        option reqprefix 'auto'
        option norelease '1'
        option delegate '0'

/etc/config/dhcp:

config dnsmasq                      
        option domainneeded '1'    
        option boguspriv '1'       
        option filterwin2k '0'      
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'               
        option domain 'lan'                                    
        option expandhosts '1'             
        option nonegcache '0'                                  
        option cachesize '1000'     
        option authoritative '1'           
        option readethers '1'                                  
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
        option nonwildcard '1'      
        option localservice '1'
        option ednspacket_max '1232'
        option filter_aaaa '0'
        option filter_a '0'   
                               
config dhcp 'lan0'            
        option interface 'lan0'
        option start '100'    
        option limit '150'    
        option leasetime '12h'
        option dhcpv4 'server'              
        option dhcpv6 'relay'                        
        option ra 'relay'                   
        option ndp 'relay'                           
                           
config odhcpd 'odhcpd'                      
        option maindhcp '0'                          
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

config dhcp 'wan6'         
        option interface 'wan6'             
        option ignore '1'                            
        option ndp 'relay'                  
        option master '1'                            
        option ra 'relay'  
        option dhcpv6 'relay'  

ip -6 route:

# (transacted) is the first 48 bits of the IPv6 prefix the 1st level router retrieved from ISP.
# (transacted)::7 is the IP of my 2nd router.
# (transacted)::8 is the IP of my PC used to perform the actions above.
# eth0 is the device name of WAN port.
# eth1 is the device name of LAN port.

default from (transacted):4920::7 via fe80::1 dev eth0  metric 512 
default from (transacted):4920::/64 via fe80::1 dev eth0  metric 512 
default from (transacted):4921::/64 via fe80::1 dev eth0  metric 512 
(transacted):4920::1 dev eth0  metric 1024 
(transacted):4920::6 dev eth0  metric 1024 
(transacted):4920::8 dev eth1  metric 1024 
(transacted):4920::20 dev eth0  metric 1024 
(transacted):4920::22 dev eth0  metric 1024 
(transacted):4920:431:38f1:3d0f:8283 dev eth0  metric 1024 
(transacted):4920:c17:89e8:eea5:bf53 dev eth0  metric 1024 
(transacted):4920:c40:4b6c:957e:91ac dev eth0  metric 1024 
(transacted):4920:383b:709b:baa4:f667 dev eth0  metric 1024 
(transacted):4920:c6fb:aaff:fe1f:79f6 dev eth0  metric 1024 
(transacted):4920:c6fb:aaff:fe20:6251 dev eth0  metric 1024 
(transacted):4920::/64 dev eth0  metric 256 
unreachable (transacted):4920::/64 dev lo  metric 2147483647 
unreachable (transacted):4921::/64 dev lo  metric 2147483647 
(transacted):4922::/64 from (transacted):4920::7 via fe80::1cc0:9a45:8ab6:cb02 dev eth0  metric 512 
(transacted):4922::/64 from (transacted):4920::/64 via fe80::1cc0:9a45:8ab6:cb02 dev eth0  metric 512 
(transacted):4922::/64 from (transacted):4921::/64 via fe80::1cc0:9a45:8ab6:cb02 dev eth0  metric 512 
fdec:bcd9:c104:1a43:c6fb:aaff:fe20:6251 dev eth0  metric 1024 
unreachable fdec:bcd9:c104:1a43::/64 dev lo  metric 2147483647 
fe80::/64 dev eth0  metric 256 
fe80::/64 dev eth1  metric 256 
anycast (transacted):4920:: dev eth0  metric 0 
anycast fe80:: dev eth0  metric 0 
anycast fe80:: dev eth1  metric 0 
multicast ff00::/8 dev eth0  metric 256 
multicast ff00::/8 dev eth1  metric 256