Can you help me to unbrick my TP-Link Archer C20 v5

I installed Openwrt in my Archer C20 but the 2.4GHz wireless was having some problems randomly shutting down, usually when using a lot of bandwidth (netflix, youtube, etc).

So I tried to install again the OEM firmware to fix those problems. I used:
scp tplink_archer_v5.bin root@
to upload the oem firmware and used

sysupgrade -F /tmp/firmware.bin to force to install (I know it is not recommended), but now my router has all LEDs off, and it only turns on the corresponding leds if I connect a device in LAN/WAN ports.

I tried to unbrick using TFTP sending both the OEM version and the openwrt version. The TFTP is listening but after upload it was in the same state.

What do you recommend me try to revive my router? Thank you

Fallow these posts
I uploaded Stripped firmware to revert back to the original firmware


Thank you, I could get the Openwrt 18.06 running again with this answer Porting Firmware to TP-Link Archer C20 v5 and apparently the wifi is working fine for now.

1 Like

There is a newer version for this device (19.07.2) in that post you can use it and it works without problem

here you are
1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.