Can the hEX S power a UniFi U6+ using PoE?

Can my MikroTik hEX S running OpenWrt power a UniFi U6+ access point from the eth5 PoE out port? I'm very confused by PoE standards and requirements.

First I would like to know if it's technically possible with this router and if it is, how I should configure this.

When I tried to connect the UniFi AP on the PoE out port (eth5) it wouldn't start. I used the default 24V adapter for it at first and later also tried a 48V adapter without success. To be clear, I don't want to use PoE passthrough from eth1 to eth5, I want to use PoE out on eth5 supplied by a power adapter.

Should I disable PoE passthrough in OpenWrt? When I try to change the PoE setting (as per the Wiki) I get an error:

root@OpenWrt:~# uci get system.poe_passthrough.value
0
root@OpenWrt:~# uci set system.poe_passthrough.value=1
root@OpenWrt:~# uci commit
uci: Entry not found

This looks like PoE passthrough is enabled?

root@OpenWrt:~# cat /etc/config/system
config gpio_switch 'poe_passthrough'
        option name 'PoE Passthrough'
        option gpio_pin '497'
        option value '1'

Thanks!

There's talk of 'passive PoE' in the wiki and that does not bode well. The specs over at MikroTik also make it clear that's all it does: passive up to 57 V.

The only thing supporting real standards is the PoE in, that does 802.3af/at.

There's "passive PoE" and "active PoE". Passive PoE means the source simply connects one twisted pair to a DC voltage (usually 24 V to 48 V) and one other twisted pair to ground.

Active PoE usually refers to one of these IEEE standardized implementations:

  • 802.3af (PoE), up to 12.95 W
  • 802.3at (PoE+), up to 25.5 W
  • 802.3bt (PoE++), up to either 51 W or 71.3 W depending on mode

Unlike passive PoE, active PoE devices negotiate power with each other before use. In active PoE, the supply is called the power sourcing equipment (PSE) and the device being supplied by the PSE is called the powered device (PD).

Its MikroTik page specifically says the PoE-out port is passive PoE only. Weirdly enough, the PoE-in port is 802.3af-compliant.

UniFi U6+ requires at least an 802.3af PSE, so you can't power the U6+ off the hEX S.

2 Likes

Actually, the U6+ should be able to be powered by the hEX S as long as it can provide at least 9W (at the load) of 48V (44V-57V) PoE. Ubiquiti devices will work with passive PoE as long as it is the provides the required nominal voltage and current capacity.

As it turns out, most (maybe all?) of the Ubiquiti PoE injectors are actually passive PoE (even the ones rated for 802.3af/at/bt devices). For example, the U-POE-af is actually passive, and it is specifically called out as compatible with the U6+ (you'll notice that the datasheet doesn't mention 802.3af anywhere -- just the 'af' in the model name to indicate it is a 15W max adapter).

1 Like

I had to look up this PoE stuff more closely again to see how Ubiquiti can possibly make this work. It looks like the MP8009 used in the U6+ isn't at all picky about the PSE. (Perhaps an example of Postel's law in action?) It only requires an input above its UVLO threshold of about 40 volts to activate the switching converter. And as long as the supply doesn't collapse under the 9 W U6+ load, it will work just fine. Today I learned something new.

So I'm not sure why @jan4 can't get this working. I would suggest directly editing the gpio_switch 'poe_passthrough' configuration section in /etc/config/system and rebooting the device. If it still doesn't work even with this and your 48 V supply, I can only guess MikroTik is using some weird pinout for the PoE-out jack (which would be in really bad taste on their part, so probably not likely).

1 Like

UI has always supported passive poe - previously their 24v (non-)standard. Passive is bad (when compared to 802.3xx standard poe) because it makes it so easy to fry non-poe devices. I suspect the reason may be partially to simplify the design of their poe injectors - just throw voltage on the wire and go.

1 Like

Thanks for all the input guys! Very useful information, learned a lot from it. :slight_smile:

Currently I'm using a TP-Link TL-SG108PE PoE switch (802.3af) to power the UniFI U6+ AP and that's the only thing the switch is being used for so I hoped to "clean up" a bit by directly powering the U6+ from the hEX S.

I would like to try once more with the 48V power adapter plugged into the hEX S, @elbertmai do you suggest I disable PoE passthrough by editing /etc/config/system and changing it to option value '0' for PoE Passthrough?

You did say that you don't want PoE passthrough:

So yes, I would suggest editing /etc/config/system to disable it. :slight_smile: Reboot and make sure you're using the 48 V supply on the DC barrel jack.