Can not install OpenWrt on Linksys EA7300 v2

I got this router today and went to install openwrt in router firmware update of Linksys.
I used openwrt-ramips-mt7621-linksys_ea7300-v2-squashfs-factory.bin but even after flashing i dont see openwrt screen. The firmware is always linksys and i see the same page. I tried multiple times. Also tried to do hard reset by switching off the router after first 4 blinks about 3 times but no go .
Any help? what am i missing. It doesnt brick router but doesnt flash the image is the firmware

"Flash factory image through GUI.

This might fail due to the A/B nature of this device. When flashing, OEM firmware writes over the non-booted partition. If booted from 'A', flashing over 'B' won't work. To get around this, you should flash the OEM image over itself. This will then boot the router from 'B' and allow you to flash OpenWrt without problems."

1 Like

Thanks it worked. I am able to ssh into to the box but it doesnt open. I saw the page before but didnt understand oem. I understood when u said to flash it again even if its the same version and it worked doesnt open to access the page for config.
SSH alone works.
how do i get the page?

it's a snapshot image, you need to install the web UI manually, they ship w/o it.

opkg update
opkg install luci

Also, every iteration of the snapshot invalidates the modules, so you'll not be able to
install packages in 24 hrs or so, unless you install the current/newest snapshot image.

1 Like

so if i do opkg update will it update to latest image?
I have an issue . If i switch off the router it goes back to orginal OEM firmware. It keeps on happening. I flashed oem firmware and then after reboot installed snapshot Full Install(not upgrade) and it worked and and after switching off the router it reverted back to the oem image...Any Helo

1 Like

it'll never flash a new image unless you tell it to.

opkg only updates/DLds the available package lists.

No idea how that double FW thing works, hope someone else can step in and help you with that part.

Don't own the device, but it sounds like the env is not being set, check script as to env variable updated.

in script i can see ea7300-v2 .This works fine and i think maybe its falling back to orginal firmware later when its not properly rebooting.Dont know what to do to prevent this..

I have the same problem with rebooting. It goes back to linksys fw. Then i have to do the 3x reset thing to get back to openwrt.
Really annoying. Can't we flash openwrt on both A and B?

UP on this topic. I get the same issue.... try many way but all the time after 2 reboot (soft or hard) it back to the stock firmware.
Any idea please ?

I'm adding support for routers to's mesh routing software, which is based on OpenWRT. I've had a couple of problems with this firmware for the ea7300 that makes it harder to support than the wrt series routers that also have dual boot partitions.

  1. Requiring to first flash the OEM firmware and then the openwrt factory image is very non-intuitive and interferes with the ease of flashing this device. Also, it's poorly documented.
  2. Sometimes in power outages or other situations our users have their routers jump to the other partition. With other dual boot routers, we can make sure our custom firmware is on both partitions. But with this router, if it jumps to the OEM partition, then their internet service stops.

We'd like to support this router, but this firmware's extra flashing steps and preventing our usage of both partitions is a blocker.

There's a forum thread where someone reports adding "normal" dual partition support. Can we get this into mainline? EA7300, Flash to "Wrong" Partition

After reading this tread I can piece together all the steps required to install OpenWRT on the Linksys EA7300, there is a quite summary of what I found to be successful for me.

  1. Download both the OpenWRT image for Linksys EA7300 and the Linksys stock image for the EA7300.
    All files for the Linksys EA7300 can be found on the OpenWRT Device page for the EA7300
    Download the Linksys stock image found on the OpenWRT Device page for the EA7300

  2. You will have to upgrade/overwrite the Linksys stock firmware with itself (the same Linksys stock firmware). In Essence, via the Linksys GUI I wiped the Linksys firmware with itself. After that I uploaded the OpenWRT image. The reason for this is explained at:
    Can not install OpenWrt on Linksys EA7300 v2 - #8 by xtendtech

  3. After doing this step I was able to get a SSH to and log into OpenWRT. Then to get the OpenWRT GUI to load I had to install the OpenWRT GUI by connecting the router to the Internet (via WAN port) and then from the SSH session run:

    # opkg update
    # opkg install luci
  4. Final step before powering off or rebooting; To keep the router booting into OpenWRT and not back into the Linksys image I had to SSH into OpenWRT and edit /etc/rc.local with:

    /rom/sbin/mtd unlock s_env
    /rom/sbin/mtd erase s_env
    exit 0

As explained at Uncorrectable ECC error - #6 by aashishkul

The overview of why all of these extra steps are needed is at the bottom of the page:


Does these settings solved the issue once for all ?
I'm about to buy this device :wink:

Step 3 should not be necessary, as the default image embedded Luci. In the mentionned thread, the user was using a snapshot image, without Luci.

Yes. i tried it yesterday night and its working fine after almost a year. Some one should update the wiki too

Thank you.
I'm worrying about erasing the whole partition s_env.

Does this command works ?
fw_setenv boot_part 1
like described in the doc from the EA8300 (yes 8300, not 7300).

yes i put these three lines in /etc/rc.local .Previously it used to revert back to orginal fw.I am not sure what it does but this can be done only after installing openwrt. So if it got installed ,then main part is already done. You will have to manually assign ip address if your main router is not in 192 range. Mine was 10.1 range and so manually had to add it to get LUCI webpages...and also to install packages

The s_env partition stores the number of boot since last successfull boot. Erasing it should put the router to some kind of default behavior. I'm still worrying about doing this.

i screwed up the config and then had to hard reset using button on the router. 2 times it went back to openwrt and third time it went back to link sys after i did "firstboot" and removed the files using ssh.
So i think its safe since firmware is still there but we are not using it.

I have received the device and installed OpenWrt. I faced the issue as described. The solution you provided works well.
And BTW luci-app-advancedreboot works well with this device.

1 Like