Can not get ip address through dumbAP

Hi,

I'm currently using openWRT on Xiaomi Redmi AC2100 router which I installed ago.
For now, I want to connect another router connected to this router to extend network.

So I bought another Xiaomi Redmi AC2100 router and installed openWRT on the device.
After then, I set up this device as dumbAP.
I changed like the following in /etc/config/network
config interface 'lan'
option type 'bridge'
option ifname 'eth1.1'
option proto 'static'
option ipaddr '192.168.1.2'
option netmask '255.255.255.0'
option gateway '192.168.1.1'
option dns '192.168.1.1'
option ip6assign '60'
option option ipv6 '0'

/etc/init.d/dnsmasq disable
/etc/init.d/dnsmasq stop

/etc/init.d/odhcpd disable
/etc/init.d/odhcpd stop

/etc/init.d/firewall disable
/etc/init.d/firewall stop

and then reboot
it looks like the following in the first,

Ethernet adapter ethernet:

   Connection-specific DNS Suffix  . : lan
   Link-local IPv6 Address . . . . . : xxxx::xxxx:xxxx:xxxx:xxxx%21
   IPv4 Address. . . . . . . . . . . : 192.168.1.221
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . : 192.168.1.1

After then, however, when I connected the ethernet cable between old router's lan port to new router's lan port, it suddenly changed like the following.

Ethernet adapter ethernet:

   Connection-specific DNS Suffix  . :
   Link-local IPv6 Address . . . . . : xxxx::xxxx:xxxx:xxxx:xxxx%21
   Autoconfiguration IPv4 Address. . : 169.254.87.246
   Subnet Mask . . . . . . . . . . . : 255.255.0.0
   Default Gateway . . . . . . . . . :

It seems that my laptop doesn't get ip address through dumbAP from old router
Please help me to solve this
Thanks in advance

Are you sure you are not using some wan port for the uplink to the old router? AC2100 and old router must be connected back to back on lan ports.
Can you assign a static IP on your laptop, e.g 192.168.1.3/24 and test if you can ping the AC2100? If it works, connect again with ssh and run the following? uci export network; ip -4 addr; brctl show

1 Like

Thanks for your reply

I'm sure that the AC2100 and old router are connected back to back on lan ports.
However, ping to AC2100 doesn't work whether using static IP, 192.168.1.3, or not.

By any chance, do you have any other idea for this?

And there is nothing else between them, like Powerline?

Use IPv6 to connect. There should be at least a link local without any configuration.

Nothing else between 2 routers.
Can you please let me know how to connect with IPv6 instead of IPv4?

First you need to find the ipv6 address, run some wireshark on your laptop to capture the packets on the ethernet port. Look for any Router Advertisements, Neighbor Solicitations or Advertisements.

By default, the LAN ports are hardware switched to each other, so having a PC and a main router plugged into two of them would have the PC talking directly to the main router. Setting up a dumb AP would not change that.

I just adjusted some configuration, then now my laptop can access the dumbAP through main router by WIFI.
Currently, my laptop can access internet through WIFI with dumbAP, but it doesn't work through ethernet with dumbAP.

Just in case, an ethernet cable is connected between the 3rd lan port of the main router and the 3rd lan port of the dumbAP.
And another ethernet cabe is connected between the 1st lan port of the dumbAP and the lan port of my laptop.

root@DumbAP1:~#  uci export network; ip -4 addr; brctl show
package network

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option packet_steering '1'
	option ula_prefix 'xxxx:xxxx:xxxx::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option netmask '255.255.255.0'
	option type 'bridge'
	option ifname 'lan3 wan'
	option ipaddr '192.168.1.2'
	option dns '192.168.1.1'
	option gateway '192.168.1.1'
	option broadcast '192.168.1.255'
	option hostname 'DumbAP1'
	option delegate '0'

config interface 'wan6'
	option device 'wan'
	option proto 'dhcpv6'

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN qlen 1000
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
9: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    inet 192.168.1.2/24 brd 192.168.1.255 scope global br-lan
       valid_lft forever preferred_lft forever
bridge name	bridge id		STP enabled	interfaces
br-lan		xxxx.xxxxxxxxxxxx	no		wlan0
							wan
							lan3
							wlan1
root@DumbAP1:~# 

Please check this and give me some advice.

Thanks for your reply

I just attached another reply in detail.
Can you please check it and give me some advice?

Your laptop is connected to lan1, but this port is not part of the bridge.
Comment/remove option ifname 'lan3 wan' and restart the network.
Run brctl show again.
The listed interfaces should be wlan0, wlan1, lan1, lan2 and lan3.

Are you sure should comment/remove option `ifname 'lan3 wan'?
When remove it, it won't work anything, even can't access ssh to dumbAP. And it's painful to recover.

It seems that lan3 and wan should be bridge

If it doesn't work, then option device 'br-lan' (where the three interfaces are listed) is not recognized.

The other possibility would be to change option ifname 'lan3 wan' to option ifname 'lan1 lan2 lan3'

You're mixing the old and new syntax. Since there is a config device separately defining the bridge (new syntax) the only physical reference in the config interface will be to link it in with option device 'br-lan' Remove the option type bridge and list ports from the lan interface section, these are old syntax.

In the new syntax you can use CIDR notation for the IPv4, option ipaddr '192.168.1.2/24' automatically sets netmask and broadcast.

option hostname has no effect in a proto static interface.

2 Likes

As changed option ifname to 'lan1 lan2 lan3', it works
Thanks a lot

Thanks for your explanation in detail

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.