Can not find wifi SSID on WAVLINK WN570HA1

I recently installed OpenWrt on my WAVLINK WN750HA1. I am really enjoying it, however I can not find the default SSIDs for both radios either on my phone or my PC but I can enable the radios and do successful SSID scans using each of the them. I have radio1 disabled for now but the problem also affects it.

OpenWrt 21.02.0 r16279-5cc0535800

iwinfo radio0 info

radio0    ESSID: unknown
          Access Point: 80:3F:5D:B4:C7:C6
          Mode: Master  Channel: 6 (2.437 GHz)
          Center Channel 1: 6 2: unknown
          Tx-Power: 24 dBm  Link Quality: unknown/70
          Signal: unknown  Noise: unknown
          Bit Rate: unknown
          Encryption: unknown
          Type: nl80211  HW Mode(s): 802.11bgn
          Hardware: 14C3:7628 14C3:0006 [Generic MAC80211]
          TX power offset: unknown
          Frequency offset: unknown
          Supports VAPs: yes  PHY name: phy0

iwinfo radio1 info

radio1    ESSID: unknown
          Access Point: 00:00:00:00:00:00
          Mode: Unknown  Channel: unknown (unknown)
          Center Channel 1: unknown 2: unknown
          Tx-Power: unknown  Link Quality: unknown/70
          Signal: unknown  Noise: unknown
          Bit Rate: unknown
          Encryption: unknown
          Type: nl80211  HW Mode(s): 802.11nac
          Hardware: 14C3:7650 14C3:7650 [MediaTek MT7610E]
          TX power offset: none
          Frequency offset: none
          Supports VAPs: yes  PHY name: phy1

iw phy0 info

Wiphy phy0
        wiphy index: 0
        max # scan SSIDs: 4
        max scan IEs length: 2257 bytes
        max # sched scan SSIDs: 0
        max # match sets: 0
        Retry short limit: 7
        Retry long limit: 4
        Coverage class: 0 (up to 0m)
        Device supports AP-side u-APSD.
        Device supports T-DLS.
        Available Antennas: TX 0x1 RX 0x1
        Configured Antennas: TX 0x1 RX 0x1
        Supported interface modes:
                 * IBSS
                 * managed
                 * AP
                 * AP/VLAN
                 * monitor
                 * mesh point
                 * P2P-client
                 * P2P-GO
        Band 1:
                Capabilities: 0x17e
                        HT20/HT40
                        SM Power Save disabled
                        RX Greenfield
                        RX HT20 SGI
                        RX HT40 SGI
                        RX STBC 1-stream
                        Max AMSDU length: 3839 bytes
                        No DSSS/CCK HT40
                Maximum RX AMPDU length 65535 bytes (exponent: 0x003)
                Minimum RX AMPDU time spacing: No restriction (0x00)
                HT TX/RX MCS rate indexes supported: 0-7
                Frequencies:
                        * 2412 MHz [1] (24.0 dBm)
                        * 2417 MHz [2] (24.0 dBm)
                        * 2422 MHz [3] (24.0 dBm)
                        * 2427 MHz [4] (24.0 dBm)
                        * 2432 MHz [5] (24.0 dBm)
                        * 2437 MHz [6] (24.0 dBm)
                        * 2442 MHz [7] (24.0 dBm)
                        * 2447 MHz [8] (24.0 dBm)
                        * 2452 MHz [9] (24.0 dBm)
                        * 2457 MHz [10] (24.0 dBm)
                        * 2462 MHz [11] (24.0 dBm)
                        * 2467 MHz [12] (disabled)
                        * 2472 MHz [13] (disabled)
                        * 2484 MHz [14] (disabled)
        valid interface combinations:
                 * #{ IBSS } <= 1, #{ managed, AP, mesh point, P2P-client, P2P-GO } <= 4,
                   total <= 4, #channels <= 1, STA/AP BI must match
        HT Capability overrides:
                 * MCS: ff ff ff ff ff ff ff ff ff ff
                 * maximum A-MSDU length
                 * supported channel width
                 * short GI for 40 MHz
                 * max A-MPDU length exponent
                 * min MPDU start spacing
        max # scan plans: 1
        max scan plan interval: -1
        max scan plan iterations: 0
        Supported extended features:
                * [ RRM ]: RRM
                * [ CQM_RSSI_LIST ]: multiple CQM_RSSI_THOLD records
                * [ CONTROL_PORT_OVER_NL80211 ]: control port over nl80211
                * [ TXQS ]: FQ-CoDel-enabled intermediate TXQs
                * [ AIRTIME_FAIRNESS ]: airtime fairness scheduling
                * [ AQL ]: Airtime Queue Limits (AQL)
                * [ SCAN_RANDOM_SN ]: use random sequence numbers in scans
                * [ SCAN_MIN_PREQ_CONTENT ]: use probe request with only rate IEs in scans
                * [ CONTROL_PORT_NO_PREAUTH ]: disable pre-auth over nl80211 control port support
                * [ DEL_IBSS_STA ]: deletion of IBSS station support
                * [ SCAN_FREQ_KHZ ]: scan on kHz frequency support
                * [ CONTROL_PORT_OVER_NL80211_TX_STATUS ]: tx status for nl80211 control port support

iw phy1 info

Wiphy phy1
        wiphy index: 1
        max # scan SSIDs: 4
        max scan IEs length: 2247 bytes
        max # sched scan SSIDs: 0
        max # match sets: 0
        Retry short limit: 7
        Retry long limit: 4
        Coverage class: 0 (up to 0m)
        Device supports AP-side u-APSD.
        Device supports T-DLS.
        Available Antennas: TX 0x1 RX 0x1
        Configured Antennas: TX 0x1 RX 0x1
        Supported interface modes:
                 * IBSS
                 * managed
                 * AP
                 * AP/VLAN
                 * monitor
                 * mesh point
                 * P2P-client
                 * P2P-GO
        Band 2:
                Capabilities: 0x17e
                        HT20/HT40
                        SM Power Save disabled
                        RX Greenfield
                        RX HT20 SGI
                        RX HT40 SGI
                        RX STBC 1-stream
                        Max AMSDU length: 3839 bytes
                        No DSSS/CCK HT40
                Maximum RX AMPDU length 65535 bytes (exponent: 0x003)
                Minimum RX AMPDU time spacing: No restriction (0x00)
                HT TX/RX MCS rate indexes supported: 0-7
                VHT Capabilities (0x31800120):
                        Max MPDU length: 3895
                        Supported Channel Width: neither 160 nor 80+80
                        short GI (80 MHz)
                        RX antenna pattern consistency
                        TX antenna pattern consistency
                VHT RX MCS set:
                        1 streams: MCS 0-9
                        2 streams: not supported
                        3 streams: not supported
                        4 streams: not supported
                        5 streams: not supported
                        6 streams: not supported
                        7 streams: not supported
                        8 streams: not supported
                VHT RX highest supported: 0 Mbps
                VHT TX MCS set:
                        1 streams: MCS 0-9
                        2 streams: not supported
                        3 streams: not supported
                        4 streams: not supported
                        5 streams: not supported
                        6 streams: not supported
                        7 streams: not supported
                        8 streams: not supported
                VHT TX highest supported: 0 Mbps
                Frequencies:
                        * 5180 MHz [36] (19.0 dBm)
                        * 5200 MHz [40] (18.0 dBm)
                        * 5220 MHz [44] (18.0 dBm)
                        * 5240 MHz [48] (18.0 dBm)
                        * 5260 MHz [52] (17.0 dBm) (radar detection)
                        * 5280 MHz [56] (17.0 dBm) (radar detection)
                        * 5300 MHz [60] (17.0 dBm) (radar detection)
                        * 5320 MHz [64] (17.0 dBm) (radar detection)
                        * 5500 MHz [100] (15.0 dBm) (radar detection)
                        * 5520 MHz [104] (15.0 dBm) (radar detection)
                        * 5540 MHz [108] (15.0 dBm) (radar detection)
                        * 5560 MHz [112] (15.0 dBm) (radar detection)
                        * 5580 MHz [116] (15.0 dBm) (radar detection)
                        * 5600 MHz [120] (15.0 dBm) (radar detection)
                        * 5620 MHz [124] (15.0 dBm) (radar detection)
                        * 5640 MHz [128] (14.0 dBm) (radar detection)
                        * 5660 MHz [132] (14.0 dBm) (radar detection)
                        * 5680 MHz [136] (13.0 dBm) (radar detection)
                        * 5700 MHz [140] (13.0 dBm) (radar detection)
                        * 5720 MHz [144] (16.0 dBm) (radar detection)
                        * 5745 MHz [149] (16.0 dBm)
                        * 5765 MHz [153] (15.0 dBm)
                        * 5785 MHz [157] (15.0 dBm)
                        * 5805 MHz [161] (15.0 dBm)
                        * 5825 MHz [165] (14.0 dBm)
                        * 5845 MHz [169] (disabled)
                        * 5865 MHz [173] (disabled)
        valid interface combinations:
                 * #{ IBSS } <= 1, #{ managed, AP, mesh point, P2P-client, P2P-GO } <= 8,
                   total <= 8, #channels <= 1, STA/AP BI must match, radar detect widths: { 20 MHz (no HT), 20 MHz, 40 MHz, 80 MHz }

        HT Capability overrides:
                 * MCS: ff ff ff ff ff ff ff ff ff ff
                 * maximum A-MSDU length
                 * supported channel width
                 * short GI for 40 MHz
                 * max A-MPDU length exponent
                 * min MPDU start spacing
        max # scan plans: 1
        max scan plan interval: -1
        max scan plan iterations: 0
        Supported extended features:
                * [ VHT_IBSS ]: VHT-IBSS
                * [ RRM ]: RRM
                * [ CQM_RSSI_LIST ]: multiple CQM_RSSI_THOLD records
                * [ CONTROL_PORT_OVER_NL80211 ]: control port over nl80211
                * [ TXQS ]: FQ-CoDel-enabled intermediate TXQs
                * [ AIRTIME_FAIRNESS ]: airtime fairness scheduling
                * [ AQL ]: Airtime Queue Limits (AQL)
                * [ SCAN_RANDOM_SN ]: use random sequence numbers in scans
                * [ SCAN_MIN_PREQ_CONTENT ]: use probe request with only rate IEs in scans
                * [ CONTROL_PORT_NO_PREAUTH ]: disable pre-auth over nl80211 control port support
                * [ DEL_IBSS_STA ]: deletion of IBSS station support
                * [ SCAN_FREQ_KHZ ]: scan on kHz frequency support
                * [ CONTROL_PORT_OVER_NL80211_TX_STATUS ]: tx status for nl80211 control port support

uci show wireless

wireless.radio0=wifi-device
wireless.radio0.type='mac80211'
wireless.radio0.hwmode='11g'
wireless.radio0.path='platform/10300000.wmac'
wireless.radio0.htmode='HT20'
wireless.radio0.channel='6'
wireless.radio0.country='US'
wireless.radio0.cell_density='0'
wireless.default_radio0=wifi-iface
wireless.default_radio0.device='radio0'
wireless.default_radio0.network='lan'
wireless.default_radio0.mode='ap'
wireless.default_radio0.ssid='OpenWrt'
wireless.default_radio0.encryption='none'
wireless.radio1=wifi-device
wireless.radio1.type='mac80211'
wireless.radio1.channel='36'
wireless.radio1.hwmode='11a'
wireless.radio1.path='pci0000:00/0000:00:00.0/0000:01:00.0'
wireless.radio1.htmode='VHT80'
wireless.radio1.cell_density='0'
wireless.radio1.disabled='1'
wireless.default_radio1=wifi-iface
wireless.default_radio1.device='radio1'
wireless.default_radio1.network='lan'
wireless.default_radio1.mode='ap'
wireless.default_radio1.encryption='none'
wireless.default_radio1.ssid='OpenWrt-5ghz'
wireless.default_radio1.disabled='1'

cat /etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdf1:3dbd:2882::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0.1'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 3 6t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '4 6t'

config device
        option name 'wlan0'

Any ideas to get it working?

Hey! No one?!

A radio or a phy is the whole radio, which may be running multiple SSIDs. An interface (wlanX) or a dev is an individual AP (attached to a radio).

Use iw dev to see if your AP device has been created.

root@OpenWrt:~#iw dev
phy#1
	Interface wlan1
		ifindex 11
		wdev 0x100000002
		addr 2c:30:33:<redacted>
		ssid myssid
		type AP
		channel 11 (2462 MHz), width: 20 MHz, center1: 2462 MHz
		txpower 22.00 dBm
		multicast TXQ:
			qsz-byt	qsz-pkt	flows	drops	marks	overlmt	hashcol	tx-bytes	tx-packets
			0	0	17601	0	0	0	0	1759543		17644
phy#1
        Interface wlan1
                ifindex 24
                wdev 0x100000002
                addr 80:3f:5d:b4:c7:c7
                ssid OpenWrt-5ghz
                type AP
                channel 36 (5180 MHz), width: 80 MHz, center1: 5210 MHz
                txpower 19.00 dBm
                multicast TXQ:
                        qsz-byt qsz-pkt flows   drops   marks   overlmt hashcoltx-bytes tx-packets
                        0       0       0       0       0       0       0      00
phy#0
        Interface wlan0
                ifindex 26
                wdev 0x9
                addr 80:3f:5d:b4:c7:c6
                ssid WAW20_AE4
                type AP
                channel 11 (2462 MHz), width: 20 MHz, center1: 2462 MHz
                txpower 24.00 dBm
                multicast TXQ:
                        qsz-byt qsz-pkt flows   drops   marks   overlmt hashcoltx-bytes tx-packets
                        0       0       0       0       0       0       0      00

That looks normal, they should be on the air.

Do you see a line with "AP-ENABLED" (for wlan0 and wlan1) in the log?

Yes I can find them but the AP are yet not visible.

Wed Sep  1 00:09:36 2021 daemon.notice hostapd: wlan1: interface state HT_SCAN->ENABLED
Wed Sep  1 00:09:36 2021 daemon.notice hostapd: wlan1: AP-ENABLED
Wed Sep  1 00:09:37 2021 daemon.notice netifd: Network device 'wlan1' link is up
Wed Sep  1 00:09:44 2021 daemon.notice netifd: Network device 'wlan0' link is up
Wed Sep  1 00:09:44 2021 daemon.notice hostapd: wlan0: interface state ACS->ENABLED
Wed Sep  1 00:09:44 2021 daemon.notice hostapd: wlan0: AP-ENABLED

Everything there looks normal like the APs are usable. Do you see anything with those MACs on a wifi analyzer app?

I did check now. No, I can not find any of them.

Edit:
Upon further inspection, I found that it actually broadcasts the APs as long as I am having my phone beside the antennas. So, I teared it down and found one little rogue smd inductor that has failed partially open circuit, I bridged it and the signal was up.

At last it was a hardware issue.

Thanks.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.