Can not access local area network with an extender

Hello everyone.
Recently I tried to build a server in my home but because of the cable limitation, I can't connect my server with a cable to the router.
So I buy an extender but it doesn't work well on 5 GHz wifi, so I flashed OpenWrt on it and it is a snapshot image. I successfully install Luci and download relayd.
I can access the network by ethernet and wireless. But I am unable to access my unraid server under the local network via PC1 and PC2.
I think I mess up the firewall setting. I will be very grateful if anyone can help with my issue.

> wireless
config wifi-device 'radio0'
	option type 'mac80211'
	option path 'platform/10300000.wmac'
	option channel '1'
	option band '2g'
	option htmode 'HT20'
	option disabled '1'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'OpenWrt'
	option encryption 'none'

config wifi-device 'radio1'
	option type 'mac80211'
	option path 'pci0000:00/0000:00:00.0/0000:01:00.0'
	option channel '36'
	option band '5g'
	option htmode 'VHT80'
	option disabled '0'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option ssid 'OpenWrt'
	option encryption 'none'

config wifi-iface 'wifinet0'
	option device 'radio1'
	option mode 'sta'
	option network 'wan'
	option ssid '*******'
	option encryption 'psk2'
	option key '********'
	option bssid '**:**:**:**:**:**'
> network
config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdd2:9ba6:3329::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth0'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '0'

config interface 'wan'
	option proto 'dhcp'

config interface 'bridge'
	option proto 'relay'
	option ipaddr '192.168.0.30'
	list network 'lan'
	list network 'wan'
>firewall
config defaults
	option input 'ACCEPT'
	option output 'ACCEPT'
	option synflood_protect '1'
	option forward 'ACCEPT'

config zone
	option name 'lan'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'ACCEPT'
	list network 'lan'
	list network 'wan'

config zone
	option name 'wan'
	option output 'ACCEPT'
	option masq '1'
	option mtu_fix '1'
	option input 'ACCEPT'
	option forward 'ACCEPT'

config forwarding
	option src 'lan'
	option dest 'wan'

config rule
	option name 'Allow-DHCP-Renew'
	option src 'wan'
	option proto 'udp'
	option dest_port '68'
	option target 'ACCEPT'
	option family 'ipv4'

config rule
	option name 'Allow-Ping'
	option src 'wan'
	option proto 'icmp'
	option icmp_type 'echo-request'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
	option name 'Allow-IGMP'
	option src 'wan'
	option proto 'igmp'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
	option name 'Allow-DHCPv6'
	option src 'wan'
	option proto 'udp'
	option src_ip 'fc00::/6'
	option dest_ip 'fc00::/6'
	option dest_port '546'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-MLD'
	option src 'wan'
	option proto 'icmp'
	option src_ip 'fe80::/10'
	list icmp_type '130/0'
	list icmp_type '131/0'
	list icmp_type '132/0'
	list icmp_type '143/0'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Input'
	option src 'wan'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	list icmp_type 'router-solicitation'
	list icmp_type 'neighbour-solicitation'
	list icmp_type 'router-advertisement'
	list icmp_type 'neighbour-advertisement'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Forward'
	option src 'wan'
	option dest '*'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-IPSec-ESP'
	option src 'wan'
	option dest 'lan'
	option proto 'esp'
	option target 'ACCEPT'

config rule
	option name 'Allow-ISAKMP'
	option src 'wan'
	option dest 'lan'
	option dest_port '500'
	option proto 'udp'
	option target 'ACCEPT'

config forwarding
	option src 'wan'
	option dest 'lan'

Post the plaintext and not a zip

thx for your remind
edited

config interface 'lan'
option device 'br-lan'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'
option ip6assign '60'

config interface 'bridge'
option proto 'relay'
option ipaddr '192.168.0.30'
list network 'lan'
list network 'wan'

Gotta be on the same subnet. FW is wide open so that shouldn't be an issue.

i follow this video

So i should set lan ipaddr to 192.168.0.xxx?

Depends on what your working PC IP subnet is. If the Netgear is using 192.168.0.0/24 then the RE should be in the same subnet.

the ip that RE assigns to PC 2 and Unriad are in 192.168.0.xxx
when using the config that I sent out.But still cant access local network

What is PC 1 using?

The RE should be using something with the first 3 octets matching.

The Netgear lease pool should be excluding X number of leases for static assignments to be used and not overlap clients.

using windows
connect with netgear r6200 via wifi

ipconfig shows what IP though?

Then change this to 192.168.0.1

Needs to match as well 255.255.254.0

Any reason you're using a /23 instead of a /24 on 3 devices?

i actually have no idea what that is :smiling_face_with_tear:

https://www.aelius.com/njh/subnet_sheet.html

/23 allows more hosts (subnet mask) is the clue to having 512 IP's available for DHCP instead of the normal 256. Seems the Netgear is slightly off but, with the 2 changes it RE should start passing traffic.

if i follow this then i can't access the internet
IDK if it is because of my Netgear is using 192.168.0.1 as the web control panel

also i make an update the diagram and remove PC2

OK... then try 192.168.0.50 / 255.255.254.0

Not sure what the Relay is if it's the management for the RE or something else.

I was going to say use 0.2 but, your PC is using that. In the Netgear you can change the DHCP range to be something starting with 192.168.0.x to allow more IP's at the beginning to be used for static.

The alternative is to just set the RE as DHCP and let it auto configure the IP and then look in your LAN list to figure out the IP to manage it.

Looking at this for the GUI the 2 IP's seem to be the same and passes traffic back on the 2.4G band but, allows for connecting clients to 2.4 / 5 bands w/o the speed benefits of 5ghz due to the limited backhaul of 2.4ghz.

pp 27