Can not access dumb AP router luci interface

After following the guide on how to make a router into a dumb AP -

After succesfully turning the router into a dumb AP and connecting the Lan port of my main router with Dumb AP router Lan port i can access the internet using ethernet cable to connect to the dumb AP. I can not access the admin interface nor ping the dumb AP router.

The ip adress of the dumb ap is set to static with default gateway

The ip adress of the main router is with dhcp ip range from to

If i try to access the luci interface from browser typing in the ip of the dump AP i cant access it. The dumb AP doesnt show in devices connected to the main router nor can it be pinged or does it show using arp -a.

To help visualize the network

ISP - Main router - Dumb AP - My computer connected via ethernet cable to the dumb AP

Am i doing something wrong? Should i use a different type of AP to be able to change its settings?

That should work. Maybe the netmask is not set properly?

I usually configure dumb APs as DHCP client for administration, especially if there is a way to log into the main router and see its DHCP lease list.

1 Like

Well i followed the guide to the letter, tried hard resetting and setting it up again multiple times checking for any errors on my side and i cant think of anything else that could be the cause. Im trying to use this dumb ap to direct all traffic through it with sqm to the main router to get rid of buffer bloating.

How would i go about checking if the netmask is set properly? I did not tinker with any settings apart from what is in the guide

I don't know what can have gone wrong in your case and if you cannot access the device by serial console it will be hard to troubleshoot. However these steps will have the same result:

/etc/init.d/dnsmasq disable
/etc/init.d/dnsmasq stop
/etc/init.d/odhcpd disable
/etc/init.d/odhcpd stop
/etc/init.d/firewall disable
/etc/init.d/firewall stop
uci set network.lan.ipaddr=''
uci set network.lan.dns=''
uci set network.lan.gateway=''
uci commit network
/etc/init.d/network restart
1 Like

If anyone stumbles upon this topic il just leave this here

In a "dumb AP" configuration, traffic does no traverse the device's CPU, so things like SQM are not going to work.

im going to try bridge mode now and see if it helps

EDIT: I can not find any useful info on SQM with different AP modes. Could anyone explain the difference between dumb AP, bridge AP and route AP? My ISP doesnt allow to use the ISP provided router in bridge mode thus im forced to use the second router with openwrt installed in AP mode if i want to use SQM.

A dumb AP is a bridge. Specifically a bridge from wired to wifi.

SQM works on any CPU interface even if that interface is part of a bridge. Traffic to or from a wifi AP definitely goes through the CPU since the CPU runs the wifi driver. Traffic between two Ethernet LAN ports will usually be hardware switched thus it does bypass SQM, although you can break the LAN ports up into VLANs then merge them back together with a software bridge. This involves the CPU with every packet which of course is usually avoided due to loss of raw speed performance, but SQM can now be applied.

1 Like

You'll have to do poor man's bridge.


Set the dump AP to DHCP so it gets an IP from the main router.
Set it to static in the main router.

Thank you so much! After 2 days of trying to set this up so i could use SQM it finally seems to work. Im not sure if the poor mans bridge introduces double NAT to the home network but my bufferbloat seems to be gone and after more than 20 hours everything seems to be working!

If you can set a static route for the OpenWrt lan network on the ISP router and the latter does NAT everything which goes out of its wan interface, you could avoid the double NAT. Otherwise it is by default double NAT.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.