Can I recompile ffmpeg with h.264 and/or h.265 support without recompiling all system?

I mean that there are options to build openwrt with ffmpeg with support of this codecs. But can I not to rebuild OpenWRT but just rebuild ffmpeg on my current system? I need those codecs support to decode rtsp stream from IP-camera. Thank you
P.S. I undesratnd that I would also need to rebuild motion package. It would be very appreciated if you guide me on how to.

Yes , you can build a package without building the entire image. See the wiki. I cannot post a link now on my mobile.

2 Likes

Many thanks! I would be grateful for link, yet I will try to find myself. Finding something is never easy for me.

I looked through the wiki and it seems that this is https://openwrt.org/docs/guide-developer/toolchain/single.package manual that I need?

Let's see where you are.

ubus call system board

{
        "kernel": "5.15.167",
        "hostname": "OpenWrt",
        "system": "Intel(R) Pentium(R) Dual  CPU  E2160  @ 1.80GHz",
        "model": "ECS G31T-M",
        "board_name": "ecs-g31t-m",
        "rootfs_type": "ext4",
        "release": {
                "distribution": "OpenWrt",
                "version": "23.05.5",
                "revision": "r24106-10cc5fcd00",
                "target": "x86/64",
                "description": "OpenWrt 23.05.5 r24106-10cc5fcd00"
        }
}

cat /etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd49:7213:1681::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.3.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option device 'eth1'
        option proto 'dhcp'

config interface 'wan6'
        option device 'eth1'
        option proto 'dhcpv6'

opkg list-installed

alsa-lib - 1.2.9-1
ar - 2.40-1
base-files - 1562-r24106-10cc5fcd00
binutils - 2.40-1
bnx2-firmware - 20230804-1
busybox - 1.36.1-1
ca-bundle - 20230311-1
cgi-io - 2022-08-10-901b0f04-21
dnsmasq - 2.90-2
dropbear - 2022.82-6
e2fsprogs - 1.47.0-2
fdk-aac - 2.0.1-5
ffmpeg - 5.1.3-1
firewall4 - 2023-09-01-598d9fbb-1
fstools - 2023-02-28-bfe882d5-1
fwtool - 2019-11-12-8f7fe925-1
getrandom - 2022-08-13-4c7b720b-2
glib2 - 2.74.7-1
grub2 - 2.06-5
grub2-bios-setup - 2.06-5
grub2-efi - 2.06-5
https-dns-proxy - 2023.12.26-1
jansson4 - 2.14-3
jshn - 2023-05-23-75a3b870-1
jsonfilter - 2024-01-23-594cfa86-1
kernel - 5.15.167-1-59d1431675acc6823a33c7eb2323daeb
kmod-amazon-ena - 5.15.167-1
kmod-amd-xgbe - 5.15.167-1
kmod-bnx2 - 5.15.167-1
kmod-button-hotplug - 5.15.167-3
kmod-crypto-acompress - 5.15.167-1
kmod-crypto-crc32c - 5.15.167-1
kmod-crypto-hash - 5.15.167-1
kmod-dma-buf - 5.15.167-1
kmod-e1000 - 5.15.167-1
kmod-e1000e - 5.15.167-1
kmod-forcedeth - 5.15.167-1
kmod-fs-vfat - 5.15.167-1
kmod-hwmon-core - 5.15.167-1
kmod-i2c-algo-bit - 5.15.167-1
kmod-i2c-core - 5.15.167-1
kmod-igb - 5.15.167-1
kmod-igc - 5.15.167-1
kmod-input-core - 5.15.167-1
kmod-ixgbe - 5.15.167-1
kmod-lib-crc-ccitt - 5.15.167-1
kmod-lib-crc32c - 5.15.167-1
kmod-lib-lzo - 5.15.167-1
kmod-libphy - 5.15.167-1
kmod-mdio - 5.15.167-1
kmod-mdio-devres - 5.15.167-1
kmod-mii - 5.15.167-1
kmod-nf-conntrack - 5.15.167-1
kmod-nf-conntrack6 - 5.15.167-1
kmod-nf-flow - 5.15.167-1
kmod-nf-log - 5.15.167-1
kmod-nf-log6 - 5.15.167-1
kmod-nf-nat - 5.15.167-1
kmod-nf-reject - 5.15.167-1
kmod-nf-reject6 - 5.15.167-1
kmod-nf-tproxy - 5.15.167-1
kmod-nfnetlink - 5.15.167-1
kmod-nft-core - 5.15.167-1
kmod-nft-fib - 5.15.167-1
kmod-nft-nat - 5.15.167-1
kmod-nft-offload - 5.15.167-1
kmod-nft-tproxy - 5.15.167-1
kmod-nls-base - 5.15.167-1
kmod-nls-cp437 - 5.15.167-1
kmod-nls-iso8859-1 - 5.15.167-1
kmod-nls-utf8 - 5.15.167-1
kmod-phy-realtek - 5.15.167-1
kmod-ppp - 5.15.167-1
kmod-pppoe - 5.15.167-1
kmod-pppox - 5.15.167-1
kmod-pps - 5.15.167-1
kmod-ptp - 5.15.167-1
kmod-r8169 - 5.15.167-1
kmod-scsi-core - 5.15.167-1
kmod-slhc - 5.15.167-1
kmod-sound-core - 5.15.167-1
kmod-tg3 - 5.15.167-1
kmod-usb-core - 5.15.167-1
kmod-usb-ehci - 5.15.167-1
kmod-usb-ohci - 5.15.167-1
kmod-usb-ohci-pci - 5.15.167-1
kmod-usb-storage - 5.15.167-1
kmod-usb-storage-uas - 5.15.167-1
kmod-usb-uhci - 5.15.167-1
kmod-usb-xhci-hcd - 5.15.167-1
kmod-usb2 - 5.15.167-1
kmod-usb2-pci - 5.15.167-1
kmod-usb3 - 5.15.167-1
kmod-video-core - 5.15.167-1
kmod-video-uvc - 5.15.167-1
kmod-video-videobuf2 - 5.15.167-1
lame-lib - 3.100-1
libatomic1 - 12.3.0-4
libattr - 2.5.1-1
libbfd - 2.40-1
libblkid1 - 2.39-2
libblobmsg-json20230523 - 2023-05-23-75a3b870-1
libbz2-1.0 - 1.0.8-1
libc - 1.2.4-4
libcares - 1.27.0-1
libcomerr0 - 1.47.0-2
libctf - 2.40-1
libcurl4 - 8.7.1-r1
libev - 4.33-2
libevdev - 1.13.0-1
libext2fs2 - 1.47.0-2
libf2fs6 - 1.16.0-1
libffi - 3.4.2-2
libffmpeg-full - 5.1.3-1
libgcc1 - 12.3.0-4
libgcrypt - 1.10.2-1
libgmp10 - 6.2.1-1
libgnutls - 3.8.3-1
libgpg-error - 1.47-1
libiwinfo-data - 2023-07-01-ca79f641-1
libiwinfo20230701 - 2023-07-01-ca79f641-1
libjpeg-turbo - 2.1.4-2
libjson-c5 - 0.16-3
libjson-script20230523 - 2023-05-23-75a3b870-1
liblua5.1.5 - 5.1.5-11
liblucihttp-lua - 2023-03-15-9b5b683f-1
liblucihttp-ucode - 2023-03-15-9b5b683f-1
liblucihttp0 - 2023-03-15-9b5b683f-1
libmbedtls12 - 2.28.9-1
libmicrohttpd-ssl - 0.9.75-1
libmnl0 - 1.0.5-1
libmount1 - 2.39-2
libncurses6 - 6.4-2
libnettle8 - 3.9.1-1
libnftnl11 - 1.2.6-1
libnghttp2-14 - 1.57.0-1
libnl-tiny1 - 2023-07-27-bc92a280-1
libopcodes - 2.40-1
libopenssl3 - 3.0.15-1
libopus - 1.3.1-3
libparted - 3.6-1
libpcre2 - 10.42-1
libpthread - 1.2.4-4
libreadline8 - 8.2-1
librt - 1.2.4-4
libsmartcols1 - 2.39-2
libss2 - 1.47.0-2
libssh2-1 - 1.10.0-1
libstdcpp6 - 12.3.0-4
libubox20230523 - 2023-05-23-75a3b870-1
libubus-lua - 2023-06-05-f787c97b-1
libubus20230605 - 2023-06-05-f787c97b-1
libuci20130104 - 2023-08-10-5781664d-1
libuclient20201210 - 2023-04-13-007d9454-1
libucode20230711 - 2024-07-11-1a8a0bcf-3
libudev-zero - 1.0.1-1
libusb-1.0-0 - 1.0.26-3
libustream-mbedtls20201210 - 2023-02-25-498f6e26-1
libuuid1 - 2.39-2
libv4l - 1.22.1-1
libzstd - 1.5.2-2
logd - 2022-08-13-4c7b720b-2
losetup - 2.39-2
lua - 5.1.5-11
luci - git-24.364.71483-75d2b84
luci-app-firewall - git-24.364.71483-75d2b84
luci-app-https-dns-proxy - 2023.12.26
luci-app-opkg - git-24.364.71483-75d2b84
luci-app-v2raya - git-24.364.71483-75d2b84
luci-base - git-24.264.56413-c7a3562
luci-compat - git-24.364.71483-75d2b84
luci-lib-base - git-24.364.71483-75d2b84
luci-lib-ip - git-24.364.71483-75d2b84
luci-lib-jsonc - git-24.364.71483-75d2b84
luci-lib-nixio - git-24.364.71483-75d2b84
luci-light - git-23.024.33244-34dee82
luci-lua-runtime - git-24.364.71483-75d2b84
luci-mod-admin-full - git-19.253.48496-3f93650
luci-mod-network - git-24.264.56960-63ba3cb
luci-mod-status - git-24.212.61237-b6da3f2
luci-mod-system - git-24.067.01860-7a82b2f
luci-proto-ipv6 - git-24.086.45108-51aee90
luci-proto-ppp - git-24.135.44542-f1ec9c2
luci-ssl - git-24.364.71483-75d2b84
luci-theme-bootstrap - git-24.086.46634-1ffe078
mc - 4.8.27-3
mkf2fs - 1.16.0-1
motion - 4.5.0-1
msmtp - 1.8.25-1
mtd - 26
netifd - 2024-01-04-c18cc79d-2
nftables-json - 1.0.8-1
objdump - 2.40-1
odhcp6c - 2023-05-12-bcd28363-20
odhcpd-ipv6only - 2023-10-24-d8118f6e-1
openwrt-keyring - 2022-03-25-62471e69-2
opkg - 2022-02-24-d038e5b6-2
parted - 3.6-1
partx-utils - 2.39-2
ppp - 2.4.9.git-2021-01-04-4
ppp-mod-pppoe - 2.4.9.git-2021-01-04-4
procd - 2023-06-25-2db83655-2
procd-seccomp - 2023-06-25-2db83655-2
procd-ujail - 2023-06-25-2db83655-2
px5g-mbedtls - 10
r8169-firmware - 20230804-1
resize2fs - 1.47.0-2
resolveip - 2
rpcd - 2023-07-01-c07ab2f9-1
rpcd-mod-file - 2023-07-01-c07ab2f9-1
rpcd-mod-iwinfo - 2023-07-01-c07ab2f9-1
rpcd-mod-luci - 20240305-1
rpcd-mod-rrdns - 20170710
rpcd-mod-ucode - 2023-07-01-c07ab2f9-1
terminfo - 6.4-2
ubox - 2022-08-13-4c7b720b-2
ubus - 2023-06-05-f787c97b-1
ubusd - 2023-06-05-f787c97b-1
uci - 2023-08-10-5781664d-1
uclient-fetch - 2023-04-13-007d9454-1
ucode - 2024-07-11-1a8a0bcf-3
ucode-mod-fs - 2024-07-11-1a8a0bcf-3
ucode-mod-html - 1
ucode-mod-lua - 1
ucode-mod-math - 2024-07-11-1a8a0bcf-3
ucode-mod-ubus - 2024-07-11-1a8a0bcf-3
ucode-mod-uci - 2024-07-11-1a8a0bcf-3
uhttpd - 2023-06-25-34a8a74d-2
uhttpd-mod-ubus - 2023-06-25-34a8a74d-2
urandom-seed - 3
urngd - 2023-11-01-44365eb1-1
usbutils - 014-1
usign - 2020-05-23-f1f65026-1
v2raya - 2.2.5.7-1
v4l-utils - 1.22.1-1
xray-core - 24.12.18-1
zlib - 1.2.13-1

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.