Can I improve my switching configuration?

I got a TP-Link WDR4300 which I'm using it as a managed switch, or at least, that's my intention. Its routing speed is 300 - 400 Mbps, but its switching speed is 850 - 1000 Mbps, that is perfect for my purpose.

Before to continue exposing my case, I put here my switching network configuration (swconfig device):


config globals 'globals'
        option packet_steering  '0'

##################################################################################################################
#########################################################SWITCH###################################################
##################################################################################################################

config switch
        option name             'switch0'
        option reset            '1'
        option enable_vlan      '1'

        #Puerto CPU - 0
        #Puerto WAN - 1
        #Puerto LAN1 - 2
        #Puerto LAN2 - 3
        #Puerto LAN3 - 4
        #Puerto LAN4 - 5

config switch_vlan
        option device           'switch0'
        option vlan             '1'
        option ports            '0t 1t 2'
        option vid              '10'
        option description      'Admin'

config switch_vlan
        option device           'switch0'
        option vlan             '2'
        option ports            '1t 2t 3t'
        option vid              '15'
        option description      'Telefonia'

config switch_vlan
        option device           'switch0'
        option vlan             '3'
        option ports            '1t 2t'
        option vid              '20'
        option description      'Servidores'

config switch_vlan
        option device           'switch0'
        option vlan             '4'
        option ports            '1t 4 5'
        option vid              '25'
        option description      'Hosts'

config switch_vlan
        option device           'switch0'
        option vlan             '5'
        option ports            '1t 2t'
        option vid              '99'
        option description      'DNS'

##################################################################################################################
#********************************************************LOOPBACK************************************************#
##################################################################################################################

config interface 'loopback'
        option device           'lo'
        option proto            'static'
        option ipaddr           '127.0.0.1'
        option netmask          '255.0.0.0'

##################################################################################################################
#*********************************************************ADMIN**************************************************#
##################################################################################################################

config device
        option type             '8021q'
        option name             'eth0.10'
        option ifname           'eth0'
        option vid              '10'
        option macaddr          '64:70:02:D3:13:10'
        option mtu              '1500'

config interface 'admin'
        option device           'eth0.10'
        option proto            'static'
        option ipaddr           '192.168.10.2'
        option gateway          '192.168.10.1'
        option broadcast        '192.168.10.255'
        option netmask          '255.255.255.0'
        option auto             '0'

##################################################################################################################
#********************************************************TELEFONIA***********************************************#
##################################################################################################################

config device
        option type             '8021q'
        option name             'eth0.15'
        option ifname           'eth0'
        option vid              '15'
        option macaddr          '64:70:02:D3:13:15'
        option mtu              '1500'

config interface 'telefonia'
        option device           'eth0.15'
        option proto            'none'

##################################################################################################################
#********************************************************SERVIDORES**********************************************#
##################################################################################################################

config device
        option type             '8021q'
        option name             'eth0.20'
        option ifname           'eth0'
        option vid              '20'
        option macaddr          '64:70:02:D3:13:20'
        option mtu              '1500'

config interface 'servidores'
        option device           'eth0.20'
        option proto            'none'

##################################################################################################################
#**********************************************************HOSTS*************************************************#
##################################################################################################################

config device
        option type             '8021q'
        option name             'eth0.25'
        option ifname           'eth0'
        option vid              '25'
        option macaddr          '64:70:02:D3:13:25'
        option mtu              '1500'

config interface 'hosts'
        option device           'eth0.25'
        option proto            'none'

##################################################################################################################
#**********************************************************DNS***************************************************#
##################################################################################################################

config device
        option type             '8021q'
        option name             'eth0.99'
        option ifname           'eth0'
        option vid              '99'
        option macaddr          '64:70:02:D3:13:99'
        option mtu              '1500'

config interface 'dns'
        option device           'eth0.99'
        option proto            'none'

##################################################################################################################
##################################################################################################################
##################################################################################################################

Like you can see, the CPU port is the 0 port which I only associated to the admin VLAN / Subnet, which I use to manage this switch and other devices in my network, like the router and a Raspeberry Pi 3 B+, and when I'm not managing or accessing to the switch itself (that is the 99.9% of the time) this interface is down.

All devices that are connected to this device are 100 Mbps only:

  • A VoIP Phone (Grandstream-GXP1620)
  • Raspberry 3B + working as a MultiServer (1 Gbps FD but with a maximum performance of 300 Mbps because its ethernet card is electronically connected to the USB 2.0 controller chip [480 Mbps theorically]).
  • An Android TV Box for streaming from Internet (Amazon, Netflix...) and from LAN resources.

This switch doesn't have firewall installed and I don't make use the Wi-Fi capabilities, and the Admin Subnet VLAN is the unique that has an IP associated (remember, for managing), the rest of the Subnets / VLANs configured work at OSI model level 2.

Taking a look to the config, the only real switching happening inside the device itself is at the VLAN 2 (Telefonia - eth0.15), and the routing is happening at the router device (a Linksys-WRT3200ACM), I don't know if this configuration is "OK" or I can improve it.

EDIT: Which devices are connected to each physical port?:

  • Port 1 (WAN): Upstream for this device to the Linksys-WRT3200ACM LAN 3 port (router)

  • Port 2 (LAN1): Raspberry Pi 3B+ working as MultiServer, DNS Server (at VLAN 99, being this device the only device in this subnet), VoIP Server with Asterisk (VLAN 15), Free-Radius 3 Server (VLAN 20) and admin subnet at VLAN 10 to access and managment.

  • Port 3 (LAN2): VoIP Phone Grandstream GXP-1620 (VLAN 15).

  • Port 4 (LAN3): Android TV Box (VLAN 25)

  • Port 5 (LAN4): Reserved for a future device that will be belong to the hosts subnet (VLAN 25)

EDIT2: Will be better make routing for these devices connected to the switch in the TP-Link WDR4300 itself, adding an OSI model level 3 configuration for each one of the Subnets / VLANs configured?

Thanks in advance, regards.