"Call Failed" error with AT&T sim card

Hi guys,

I'm trying to use a new AT&T SIM card with a GL.iNet MiFi and I can't seem to get it working. I'm switching from a TMobile SIM card that does work. I've installed the luci-proto-qmi package and created a new QMI interface, using no authentication and the APN 'Broadband' (as instructed by the carrier). All I get is an error that says 'call failed' when this same setup worked with the TMobile SIM card. I get the same error when I run "uqmi -d /dev/cdc-wdm0 --start-network --apn broadband" from the bash shell.

I emailed GL.iNet support to ask if maybe I need a different modem card (the modem is installed in a mini-PCI slot and was one of a few options that was supposed to work with TMobile). They replied with the message: "For AT&T network, it is not an issue with the modem but an issue with their network." and sent me this link. Unfortunately, I am unable to send AT commands to the modem. I've read through this page, and skimmed this manual but running "socat - /dev/cdc-wdm0,cr" and sending "ATI" returns nothing, so I'm clearly missing something.

I'm using the latest release of OpenWRT with all default packages up to date.

Any and all help would be appreciated.

Check that modem covers the bands used by ATT in your area. That company also has an imei whitelist / blacklist.

Try picocom to manually send and receive AT commands from the modem.

So it turned out the issue was just that the SIM card hadn't been activated yet. I was told it would be activated on arrival but the company I bought it from is based in Texas and their power got wiped out in the recent storms.

I don't know who this could possibly help, but I'll leave the post up.

Thanks for the help, see my reply below.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.