So, personally I do not do anything prioritisation wise UNLESS I can see tangible improvements... so I would always try not to apply any special prioritisation rules at all, and only if that does not help would I try to find the smallest set of rules (or better the set of rules that changes priority for the smallest number of packets) that improve things...
May I ask which script you prefer for call of duty out of all of them
Hey guys I am really trying to solve some issues here. So am running the cake script. I added all pictures. My network setup is like this. Cable fiber modem nokia from ISP KPN which connects the cable fiber cable. It takes that signal and forms it which is then connected through a wan cable on my openwrt x64 router.
My internet is KPN FTTH cable fiber 1000/1000 connection. Some people say with that kind of speed you wont need qos. But I still get bufferbloat so I use it.
My internet is like this. The wan cable is in the eth1. The vlan 6 is for internet and vlan 4 for iptv.
It also uses pppoe. I will post my network setup below. I do need to say am running a snapshot release now. Normally I use the stable versions, I also tried out some custom kernels, but it is not that great when needed to add new packages. Cause I need to build those, so am running standard releases.
The documentation for my cable fiber 1000/1000 internet:
KPN Cable fiber document
Interfaces traffic:
The bufferbloat test result:
These are my qdiscs which also is with a custom script, when I did not do this it said sometimes that packets were queued when checking logs so I set cake unlimited so it does have cake but it don't really work which are distributed over my 4 cpu cores:
This is my network config:
config interface 'loopback'
option device 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config globals 'globals'
option packet_steering '1'
config device
option name 'br-lan'
option type 'bridge'
list ports 'eth0'
list ports 'eth3'
option igmp_snooping '1'
option stp '1'
config interface 'lan'
option device 'br-lan'
option proto 'static'
option netmask '255.255.255.0'
option ipaddr '192.168.1.1'
option ip6assign '60'
config interface 'wan'
option proto 'pppoe'
option username 'xxx'
option password 'xxx'
option device 'eth1.6'
option ipv6 '0'
option mtu '1500'
config interface 'wan6'
option proto 'dhcpv6'
option device '@wan'
option reqaddress 'none'
option reqprefix 'auto'
config device
option name 'eth1'
option mtu '1508'
config device
option name 'eth1.6'
option type '8021q'
option ifname 'eth1'
option vid '6'
config device
option name 'eth1.4'
option type '8021q'
option ifname 'eth1'
option vid '4'
option ipv6 '0'
option mtu '1500'
config interface 'IPTV_WAN'
option proto 'dhcp'
option delegate '0'
option defaultroute '0'
option peerdns '0'
option vendorid 'IPTV_RG'
option device 'eth1.4'
option ipv6 '0'
config route
option interface 'IPTV_WAN'
option target '213.112.0/21'
option gateway 'xxx'
config device
option name 'eth0'
config device
option name 'eth3'
config interface 'veth0'
option proto 'none'
option device 'veth0'
This is my firewall config:
config defaults
option input 'REJECT'
option output 'ACCEPT'
option forward 'REJECT'
option synflood_protect '1'
config zone
option name 'lan'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'ACCEPT'
list network 'lan'
list network 'veth0'
config zone
option name 'wan'
option input 'REJECT'
option output 'ACCEPT'
option forward 'REJECT'
option masq '1'
list network 'wan'
list network 'wan6'
config forwarding
option src 'lan'
option dest 'wan'
config rule
option name 'Allow-DHCP-Renew'
option src 'wan'
option proto 'udp'
option dest_port '68'
option target 'ACCEPT'
option family 'ipv4'
config rule
option name 'Allow-Ping'
option src 'wan'
option proto 'icmp'
option icmp_type 'echo-request'
option family 'ipv4'
option target 'ACCEPT'
config rule
option name 'Allow-IGMP'
option src 'wan'
option proto 'igmp'
option family 'ipv4'
option target 'ACCEPT'
config rule
option name 'Allow-DHCPv6'
option src 'wan'
option proto 'udp'
option dest_port '546'
option family 'ipv6'
option target 'ACCEPT'
config rule
option name 'Allow-MLD'
option src 'wan'
option proto 'icmp'
option src_ip 'fe80::/10'
list icmp_type '130/0'
list icmp_type '131/0'
list icmp_type '132/0'
list icmp_type '143/0'
option family 'ipv6'
option target 'ACCEPT'
config rule
option name 'Allow-ICMPv6-Input'
option src 'wan'
option proto 'icmp'
list icmp_type 'echo-request'
list icmp_type 'echo-reply'
list icmp_type 'destination-unreachable'
list icmp_type 'packet-too-big'
list icmp_type 'time-exceeded'
list icmp_type 'bad-header'
list icmp_type 'unknown-header-type'
list icmp_type 'router-solicitation'
list icmp_type 'neighbour-solicitation'
list icmp_type 'router-advertisement'
list icmp_type 'neighbour-advertisement'
option limit '1000/sec'
option family 'ipv6'
option target 'ACCEPT'
config rule
option name 'Allow-ICMPv6-Forward'
option src 'wan'
option dest '*'
option proto 'icmp'
list icmp_type 'echo-request'
list icmp_type 'echo-reply'
list icmp_type 'destination-unreachable'
list icmp_type 'packet-too-big'
list icmp_type 'time-exceeded'
list icmp_type 'bad-header'
list icmp_type 'unknown-header-type'
option limit '1000/sec'
option family 'ipv6'
option target 'ACCEPT'
config rule
option name 'Allow-IPSec-ESP'
option src 'wan'
option dest 'lan'
option proto 'esp'
option target 'ACCEPT'
config rule
option name 'Allow-ISAKMP'
option src 'wan'
option dest 'lan'
option dest_port '500'
option proto 'udp'
option target 'ACCEPT'
config zone
option name 'IPTV_WAN'
option input 'ACCEPT'
option forward 'REJECT'
option output 'ACCEPT'
option masq '1'
list network 'IPTV_WAN'
option family 'ipv4'
config forwarding
option dest 'IPTV_WAN'
option src 'lan'
config rule
option name 'Allow-IGMP-Proxy'
option proto 'udp'
option family 'ipv4'
option target 'ACCEPT'
option dest_ip '212.0.2.0/4'
option dest 'lan'
option src 'IPTV_WAN'
This is my cake.sh script global settings:
WAN="pppoe-wan" # Example: eth0, eth0.2, eth1, eth1.2, wan, etc.
### CAKE settings ###
BANDWIDTH_DOWN="900" # Change this to about 80-95% of your download speed (in megabits).
BANDWIDTH_UP="900" # Change this to about 80-95% of your upload > speed (in megabits).
AUTORATE_INGRESS="no" # Write: "yes" | "no"
OVERHEAD="50" # Write values between "-64" and "256"
MPU="84" # Write values between "0" and "256"
LINK_COMPENSATION="noatm" # Write: "atm" | "ptm" | "noatm"
## Only use these presets or keywords if you don't write a value above in "OVERHEAD", "MPU" and "LINK_COMPENSATION".
COMMON_LINK_PRESETS="" # Write the keyword below:
ETHER_VLAN_KEYWORD="" # Write values between "1" and "3" or don't write any value.
PRIORITY_QUEUE_INGRESS="diffserv4" # Write: "besteffort" | "diffserv3" | "diffserv4" | "diffserv8"
PRIORITY_QUEUE_EGRESS="diffserv4" # Write: "besteffort" | "diffserv3" | "diffserv4" |
"diffserv8"
HOST_ISOLATION="yes" # Write: "yes" | "no"
NAT_INGRESS="no" # Write: "yes" | "no"
NAT_EGRESS="yes" # Write: "yes" | "no"
WASH_INGRESS="no" # Write: "yes" | "no"
WASH_EGRESS="yes" # Write: "yes" | "no"
INGRESS_MODE="no" # Write: "yes" | "no"
ACK_FILTER_EGRESS="no" # Write: "yes" | "no" | "auto"
I know it is alot of information. But I think I set it up right. Still my download speed with the script is alot lower than I would expect.
I am running the cpu freq in performance mode for better latency. Which works. When I run luci-app-sqm I get better results.
Now it could be that it is cause of the snapshot. But still sometimes I get this these weird numbers on the bufferbloat with this script. But when I use the luci-app-sqm I don't. But I want to prioritize my gaming packets to EF and luci-app-sqm don't do that, so I need something custom to the side of it in order for me to have that.
Have I set this up wrong. Or since my connection is kpn FTTH on the wan in eth1 with vlan and pppoe this script is not suited for that kind of connection?
So I was thinking maybe it is smarter to set like the script with luci-app-sqm with a custom script to the side to set custom dscp on ports and ip on my ipv4 and ipv6 on my gaming pc.
However that was not successfull since it did not what the script did. Maybe that is cause I dont use the veth than. Or I just need to copy it out the cake.sh script and set it but I think I need veth for that.
Can someone help me with this>?
For years I tried diff scripts but nowadays I'm really happy with default piece of cake script. Just let it handle the traffic and if you want you can apply EF
through Windows firewall for games. Honestly, I don't even bother applying DSCP for any traffic. I let it be default. Keep everything simple as much as possible it's not worth micro-optimizing everything
My SQM file:
config queue 'eth1'
option enabled '1'
option interface 'pppoe-wan'
option download '21000'
option upload '21000'
option qdisc 'cake'
option script 'piece_of_cake.qos'
option qdisc_advanced '1'
option ingress_ecn 'ECN'
option egress_ecn 'NOECN'
option qdisc_really_really_advanced '1'
option itarget 'auto'
option etarget 'auto'
option linklayer 'none'
option debug_logging '0'
option verbosity '5'
option squash_dscp '1'
option squash_ingress '1'
option iqdisc_opts 'nat ingress'
option eqdisc_opts 'nat ack-filter'
Yeah but if I use for the firewall will it be bi directional? Also if I use 'EF' I can't use squash_dscp or squash_ingress right? Or do I have to do that? It should not wash my dscp marks. Also I can't use piece_of_cake.qos when using dscp marking in the firewall right? I should use layer_cake than or not?
Basically I had the numbers down by simply throttling down the download connection. So now I get around 0.6 latency which is really good with the script. The only downside of it is that I am loosing alot of my connection. About 1/3 on download.
Also you don't use the overhead option. Is that not important?
Please read here:
https://openwrt.org/docs/guide-user/network/traffic-shaping/sqm-details#sqmlink_layer_adaptation_tab
about the relationship between shaper gross rate and overhead and how and under which conditions one can make up for the other. Rule of thumb, rather err on the side of too small for shaper rate and too large for per packet overhead...
Side-note: if you do not specify any overhead at all, you are likely to inherit the kernel's 14 byte default, but that depends on the type of interface...
It's gonna be one-way DSCP anyways doesn't matter what shaper you use. For Piece of Cake always SQUASH
and ignore
ingress. For egress you can assign EF
from Windows Firewall
.
Single tin (of Piece of cake) is enough for everyday traffic. Layered Cake uses default diffserv3
and if you compare the difference, practically it'll negligible.
Also, scripts are very useful if your internet speed is above ~4mbps. You should focus on bumping your internet bandwidth to 10mbps at least to see major difference.
I didn't see any difference. None. But that doesn't mean it's correct for others. You should test and figure it out.
Hry moeller I have read it but as I said my earlier post on this thread was quite substantial.
The reason that I gave all that information is that I am not sure what to set my network rate to and which values to use. I can play with the values but I am asking for confirmation about the stuff I have done.
I have given all the information about my network setup and my qdiscs. So providing a link to read about certain topics is not helping. Why is it not helping? I have already read the manpages about it. And I would not be contacting on the forum if I was 100% sure about what I had done was the right path.
Also the manpages do NOT give any information about my network setup. You dont see anywhere what the overhead should be on a wan link with vlan with pppoe.
Of course I can think of it myself but some isp take vlan already in consideration on the ethernet. This is not mentioned in manpages. So than it would make the additional 4.bytes of vlan obsolete.
Next to all of this I have no clue can I set the ethernet links to noqueue or do they always need to have a shaper?
The default is fq_codel but you cant have cake and fq_codel at the same time.
I thought cake should only be set on the wan link. Which in my case as provided in the pictures earlier is pppoe-wan.
Is it normal that my system logs give me kern.crit warning a virtual device is asking x interface to queue packet.
So I created a script that made mq with cake distributed over my 4 cores cake so I do not use the default difserv3 but difserv4 with custom values. To not interfere with the wan I set the cake to unlimited. That way I could get around the messages that my system log was showing.
But is this the right way?
I was hoping some people had expierence and read my earlier post on the thread thoroughly and was able to help me out. This is why I made such an effort to give you all the information I had so someone could help me out
Well, confirmation is:
a) relatively easy, just use the application that you want to improve with and without competing loads, with and without the QoS script of your choice.
b) rather personal, I can not see this from the outside.
That is a problem. I wrote a lot of that stuff, and if you can not understand that I am not sure how I can explain this differently.
Well, this is why we recommend to set the overhead to 44 bytes and forget about it, for almost all cases this is slightly more than the true overhead, which from a bufferbloat perspective is fine (you only run into issues when you configure too small an overhead).
Empirically deducing the true overhead is hard, hence the recommendation to slightly overestimate it and be done with...
An interface will always inherit the systems default qdisc, this used to be pfifo_fast if I recall correctly, but got changed to fq_codel in OpenWrt, if you configure cake on an interface that default qdisc gets replaced, no need to do anything, unless you want to change the default qdisc.
As I said you can always replace the qdisc and that is what e.g. sqm-scripts and Elan's scripts do.
Typically cake somewhat expensive features help most for internet traffic, but on which interface you access that internewt traffic is less consequential.
Since I do not use veth interfaces I have no idea, my gut feeling is that kern.crit is not normal, on my system I would try to investigate and remedy the root cause, but as I said I never used veth so can not help you there.
I really can not say much, except that sounds like a complication most users avoid, so I would guess this is not strictly necessary.
As I said, I have never tried Elan's script so have no first hand experience.
Hey Thanks for the response. I do understand everything. Am in IT myself but it is more that my cable fiber isn't traditional. Most cable fiber connections dont go with pppoe-wan. Personally I also dont like software bridges for iptv and internet. I rather have a hardware bridge
But this cable fiber provider simply dont do that. The provider I got is the owner of the line if I would take a diffrent provider they sometimes if there is a lot of traffic tune the other providers down.
Most providers go like eth1 or eth0 and that is it.
So the traditional overhead is not applied to my connection.
Basically from reading the manpage since it is the wan link plus vlan plus pppoe. Which means 38+4+8=50 in my case.
However on the openwt setup configs apparently the vlan they dont take account. I actually ask this to my provider if this is the case but they cant provide me the awnser.
What do you use since you are not using elan script. Do you use the luci-app-sqm with some custom marks?
I was thinking about making my own nft table.
I actually got the dscp classifier running now. Since i want my gaming pc to always have ef as dscp mark. Ip bound on ipv4 and ipv6. However when I tried elan script the markings were there. When I tried myself I did not always see them.go through.
So I was hoping that people could share there configs so I could take a look how others do it.
I do think elan script might work better than the dscp classifier though. But I rather do not use veth.
However I am not always familiar with what you can or cannot do.
Well, the challenge is that we have two somewhat coupled unknowns, the ISP's shaper rate and the applicable per-packet-overhead. The coupling makes it hard to simply deduce these simply in two steps, as roughly speaking, e.g. getting the shaper rate too high can be (under certain conditions) be "corrected" by also specifying too much overhead, and vice versa...
From a buffebloat perspective the benign errors are setting the shaper rate a bit too low and the per-packet-overhead a bit too high...
In your situation, on a shared link like cable/DOCSIS where the segment capacity is variable and typically considerably larger than your contracted capacity, we can mostly ignore the true link capacity and true link overhead, we have to consider what assumptions your ISP's traffic shaping makes. The easiest would be to simply ask the ISP, but IMHO you are unlikely to get a response to such a question from most ISPs.
That would be ethernet plus vlan plus PPPoE, not a bad assumption, I bet your ISPs accounts for less though, so I guess this would be OK...
Well you can account for all overhead you deem likely whether your ISPs confirms that or not, no?
I sam using vanilla sqm-scripts (with layer_cake.qos/cake, configured for per-internat-IP-isolation). So I have the capability to set DSCPs, but outside of some testing, I do not actually do that routinely, so no custom marks for me.
I note my prioritisation philosophy is rather simple:
a) prioritise as little traffic as possible
b) only use prioritisations that I can reliably conform as improving the use-case they are aiming to help with
(The rationale is that in prioritisation for every packet that gets better treatment some other packet(s) will need to be treated worse, so you need sufficient potential "victim" packets for prioritisation to actually help, because trying to prioritise all traffic is identical to not prioritising at all).
However, if I would try to actually use prioritisation, I would use the method employed in DSCP classify or cake-qos-simple where the egress DSCP is copied onto incoming packets of the same flow as that strikes be the best approach; in combination with usingg the normal firewall GUI to create the egress marking rules (or have the applications apply their own marking directly).
Yeah, this is a simple rule, but this can have unintended consequences: if you play an on-line game this machine likely only produces little but latency sensitive traffic, so your rule will be fine, but if you download a multi-GB game update, maybe giving highest priority to this bulk traffic might not be the best idea?
Well, I have nothing to share except a rather pedestrian /etc/config/sqm... but actual users of this script might...
it helps that I am not getting traffic on the inbound side, but on the outbound side there is traffic, what am I doing wrong?
root@OpenWrt:~# tc -s qdisc
qdisc noqueue 0: dev lo root refcnt 2
Sent 0 bytes 0 pkt (dropped 0, overlimits 0 requeues 0)
backlog 0b 0p requeues 0
qdisc cake 800d: dev eth0 root refcnt 2 bandwidth 500Mbit diffserv4 dual-srchost nat wash ack-filter split-gso rtt 100ms noatm overhead 44
Sent 5742718 bytes 34147 pkt (dropped 0, overlimits 977 requeues 0)
backlog 0b 0p requeues 0
memory used: 9Kb of 15140Kb
capacity estimate: 500Mbit
min/max network layer size: 16 / 1500
min/max overhead-adjusted size: 60 / 1544
average network hdr offset: 14
Bulk Best Effort Video Voice
thresh 31250Kbit 500Mbit 250Mbit 125Mbit
target 5ms 5ms 5ms 5ms
interval 100ms 100ms 100ms 100ms
pk_delay 0us 8us 0us 0us
av_delay 0us 3us 0us 0us
sp_delay 0us 1us 0us 0us
backlog 0b 0b 0b 0b
pkts 0 34147 0 0
bytes 0 5742718 0 0
way_inds 0 28 0 0
way_miss 0 614 0 0
way_cols 0 0 0 0
drops 0 0 0 0
marks 0 0 0 0
ack_drop 0 0 0 0
sp_flows 0 2 0 0
bk_flows 0 1 0 0
un_flows 0 0 0 0
max_len 0 1514 0 0
quantum 953 1514 1514 1514
qdisc fq_codel 0: dev eth2 root refcnt 2 limit 10240p flows 1024 quantum 1514 target 5ms interval 100ms memory_limit 32Mb ecn drop_batch 64
Sent 12812141 bytes 12667 pkt (dropped 0, overlimits 0 requeues 5)
backlog 0b 0p requeues 5
maxpacket 1292 drop_overlimit 0 new_flow_count 4 ecn_mark 0
new_flows_len 0 old_flows_len 0
qdisc fq_codel 0: dev eth3 root refcnt 2 limit 10240p flows 1024 quantum 1514 target 5ms interval 100ms memory_limit 32Mb ecn drop_batch 64
Sent 91589276 bytes 96201 pkt (dropped 0, overlimits 0 requeues 8)
backlog 0b 0p requeues 8
maxpacket 1506 drop_overlimit 0 new_flow_count 6 ecn_mark 0
new_flows_len 0 old_flows_len 0
qdisc noqueue 0: dev br-lan root refcnt 2
Sent 0 bytes 0 pkt (dropped 0, overlimits 0 requeues 0)
backlog 0b 0p requeues 0
qdisc cake 800c: dev veth0 root refcnt 5 bandwidth 800Mbit diffserv4 dual-dsthost nonat nowash ingress no-ack-filter split-gso rtt 100ms noatm overhead 44
Sent 0 bytes 0 pkt (dropped 0, overlimits 0 requeues 0)
backlog 0b 0p requeues 0
memory used: 0b of 15140Kb
capacity estimate: 800Mbit
min/max network layer size: 65535 / 0
min/max overhead-adjusted size: 65535 / 0
average network hdr offset: 0
Bulk Best Effort Video Voice
thresh 50Mbit 800Mbit 400Mbit 200Mbit
target 5ms 5ms 5ms 5ms
interval 100ms 100ms 100ms 100ms
pk_delay 0us 0us 0us 0us
av_delay 0us 0us 0us 0us
sp_delay 0us 0us 0us 0us
backlog 0b 0b 0b 0b
pkts 0 0 0 0
bytes 0 0 0 0
way_inds 0 0 0 0
way_miss 0 0 0 0
way_cols 0 0 0 0
drops 0 0 0 0
marks 0 0 0 0
ack_drop 0 0 0 0
sp_flows 0 0 0 0
bk_flows 0 0 0 0
un_flows 0 0 0 0
max_len 0 0 0 0
quantum 1514 1514 1514 1514
qdisc noqueue 0: dev veth1 root refcnt 2
Sent 0 bytes 0 pkt (dropped 0, overlimits 0 requeues 0)
backlog 0b 0p requeues 0
qdisc fq_codel 0: dev pppoe-wan root refcnt 2 limit 10240p flows 1024 quantum 1514 target 5ms interval 100ms memory_limit 32Mb ecn drop_batch 64
Sent 9275612 bytes 55847 pkt (dropped 0, overlimits 0 requeues 0)
backlog 0b 0p requeues 0
maxpacket 1452 drop_overlimit 0 new_flow_count 12 ecn_mark 0
new_flows_len 0 old_flows_len 0
root@OpenWrt:~#
Hello i have install this script in the MT600 cust_build from Pesa, and now the GUI from OPENWRT page lost connection like this:
I have to refresh the page mult-times
Mon Oct 7 15:15:01 2024 daemon.err sh[18067]: RTNETLINK answers: File exists
Mon Oct 7 15:15:01 2024 daemon.err sh[18067]: RTNETLINK answers: File exists
Mon Oct 7 15:15:01 2024 daemon.info sh[18067]: ############################################################
Mon Oct 7 15:15:01 2024 daemon.info sh[18067]: NOBODY ELSE CAN SAVE YOU
Mon Oct 7 15:15:01 2024 daemon.info sh[18067]: TRUST JESUS TODAY!
Mon Oct 7 15:15:01 2024 daemon.info sh[18067]: ############################################################
Mon Oct 7 15:15:01 2024 daemon.info sh[18067]:
Mon Oct 7 15:15:01 2024 daemon.info sh[18067]: As it is written: 'There is none righteous, no, not one'. Romans 3:10
Mon Oct 7 15:15:01 2024 daemon.info sh[18067]: For all have sinned and come short of the glory of God. Romans 3:23
Mon Oct 7 15:15:01 2024 daemon.info sh[18067]:
Mon Oct 7 15:15:01 2024 daemon.info sh[18067]: Therefore, as by one man sin entered into the world, and death by sin, so death passed onto all men, for all have sinned. Romans 5:12
Mon Oct 7 15:15:01 2024 daemon.info sh[18067]: For the wages of sin is death, but the gift of God is eternal life through Jesus Christ our Lord. Romans 6:23
Mon Oct 7 15:15:01 2024 daemon.info sh[18067]:
Mon Oct 7 15:15:01 2024 daemon.info sh[18067]: But God commendeth His love toward us in that, while we were yet sinners, Christ died for us. Romans 5:8
Mon Oct 7 15:15:01 2024 daemon.info sh[18067]: For 'whosoever shall call upon the name of the Lord shall be saved'. Romans 10:13
Mon Oct 7 15:15:01 2024 daemon.info sh[18067]:
Mon Oct 7 15:15:01 2024 daemon.info sh[18067]: Jesus said, 'I am the Way, the Truth, and the Life; no man cometh unto the Father, but by Me.' John 14:6
Mon Oct 7 15:15:01 2024 daemon.info sh[18067]:
Mon Oct 7 15:15:01 2024 daemon.info sh[18067]: Behold, I stand at the door and knock. If any man hear My voice and open the door, I will come in to him, and will sup with him, and he with Me. Revelation 3:20
Mon Oct 7 15:15:01 2024 daemon.info sh[18067]: That if thou shalt confess with thy mouth the Lord Jesus, and shalt believe in thine heart that God hath raised Him from the dead, thou shalt be saved. Romans 10:9
Mon Oct 7 15:15:01 2024 daemon.info sh[18067]:
Mon Oct 7 15:15:01 2024 daemon.info sh[18067]: WHAT TO PRAY
Mon Oct 7 15:15:01 2024 daemon.info sh[18067]: ============
Mon Oct 7 15:15:01 2024 daemon.info sh[18067]: Dear God, I am a sinner and need forgiveness.
Mon Oct 7 15:15:01 2024 daemon.info sh[18067]: I believe that Jesus Christ shed His 'precious blood' and died for my sin.
Mon Oct 7 15:15:01 2024 daemon.info sh[18067]: I am willing to turn from sin.
Mon Oct 7 15:15:01 2024 daemon.info sh[18067]: I now invite Jesus Christ to come into my heart as my personal Savior. AMEN!
Mon Oct 7 15:15:01 2024 daemon.info sh[18067]:
Mon Oct 7 15:15:01 2024 daemon.info sh[18067]: The Lord Jesus is coming for His Church!
Mon Oct 7 15:15:01 2024 daemon.info sh[18067]: ****************************************
Mon Oct 7 15:15:01 2024 daemon.info sh[18067]: Do not waste your time, repent of your sins and accept Jesus Christ as your Lord and Savior and you and your family will be saved.
Mon Oct 7 15:15:01 2024 daemon.info sh[18067]:
Mon Oct 7 15:15:01 2024 daemon.err sh[18067]: [!] Automatically including '/usr/share/nftables.d/ruleset-post/30-pbr.nft'
Mon Oct 7 15:15:01 2024 daemon.err sh[18067]: [!] Automatically including '/usr/share/nftables.d/table-post/30-pbr.nft'
Mon Oct 7 15:15:01 2024 daemon.err sh[18067]: [!] Automatically including '/usr/share/nftables.d/chain-post/dstnat_lan/30-pbr.nft'
Mon Oct 7 15:15:01 2024 daemon.err sh[18067]: [!] Automatically including '/usr/share/nftables.d/chain-post/mangle_forward/30-pbr.nft'
Mon Oct 7 15:15:01 2024 daemon.err sh[18067]: [!] Automatically including '/usr/share/nftables.d/chain-post/mangle_input/30-pbr.nft'
Mon Oct 7 15:15:01 2024 daemon.err sh[18067]: [!] Automatically including '/usr/share/nftables.d/chain-post/mangle_output/30-pbr.nft'
Mon Oct 7 15:15:01 2024 daemon.err sh[18067]: [!] Automatically including '/usr/share/nftables.d/chain-post/mangle_postrouting/30-pbr.nft'
Mon Oct 7 15:15:01 2024 daemon.err sh[18067]: [!] Automatically including '/usr/share/nftables.d/chain-post/mangle_prerouting/30-pbr.nft'
Mon Oct 7 15:15:02 2024 user.notice pbr: Sending reload signal to pbr due to firewall action: includes
Mon Oct 7 15:15:02 2024 user.notice pbr: Reusing the fw4 nft file.
Why is there scripture in your log
Edit: OK, looks like that is part of the script. Pray that it works or something...
The original author of the script @EXREYFOX uses had this tendency... which left me always feeling a bit uneasy, but since he was otherwise a very friendly and polite fellow I personally decided to accept/tolerate this.
I have install the OpenWrt 23.05.5 on my MT6000 and i still have this error i google it and it seems to be by the etc/init.d this script use
which error?
"xhr timeout" error
Ah, thanks, no idea, not yet using OpenWrt23, have you tried clearing the browser cache already?