Ca certificate generation

I'm on rPi 3b+ running 19.07.5. I need ca certificates to connect to a secured wifi hotspot with travelmate. A few sources seem to say there should already be certificates in /etc/ssl/certs. However my /etc does not even contain an ssl directory.

I tried to install nginx-ssl_1.17.7-2_x86_64.ipk and got packages for nginx-ssl found, but incompatible with the architectures configured. Am I downloading the wrong architecture? If so, which is the right one?

Many thanks in advance

Joe

Try to install the package ca-bundle instead.

2 Likes

Yes.

rPi3b+ is certainly not based on Intel x86_64 processors.

Likely cortex-a7_neon-vfpv4 would be right packages arch.

1 Like

This is not listed in available packages. At least, not what hnyman linked to

in subdiretories...

in "base":
https://downloads.openwrt.org/releases/packages-19.07/arm_cortex-a7_neon-vfpv4/base/ca-bundle_20200601-1_all.ipk

and nginx-ssl in "packages":
https://downloads.openwrt.org/releases/packages-19.07/arm_cortex-a7_neon-vfpv4/packages/nginx-ssl_1.17.7-2_arm_cortex-a7_neon-vfpv4.ipk

... just browse a bit the package download dirs, please...

Ah so. I was under the mistaken impression that only /packages contained useful things. Thanks so much for the clarification.

Use opkg to download and install packages, not browsing and downloading from the browser of your PC.

1 Like

Both ways work ok (if you know the exact packages that you want), but using opkg is naturally easier, like trendy says.

But using opkg is possible only when the router has internet connectivity.

2 Likes

I'd love to, if I could actually get OWRT to go online.

1 Like

That's correct, I cannot use opkg because I'm not online yet. Basically overall tactical goal is to use travelmate to connect to captive portal which requires ssl certs.

Have you worked with travelmate? I know there's a separate thread for it, but perhaps you have relevant experience

Yeah, I have no clue what isp router address is. Unless you mean the address windows refers to as default gateway, which looks nothing like what you specified beyond the format. Windows also says my dns servers are 1.1.1.1 and 8.8.8.8.

I mean, I have an IP for ISP DHCP server, if that helps.

Copy paste the ipconfig /all from a windows cmd here in preformatted text (the </> button).

2 Likes
C:\Users\Virgo Systems>ipconfig -all

Windows IP Configuration

   Host Name . . . . . . . . . . . . : OSHUN
   Primary Dns Suffix  . . . . . . . :
   Node Type . . . . . . . . . . . . : Mixed
   IP Routing Enabled. . . . . . . . : No
   WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Ethernet_2:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . : lan
   Description . . . . . . . . . . . : Killer E2500 Gigabit Ethernet Controller
   Physical Address. . . . . . . . . : 8C-04-BA-A6-43-0B
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes

Wireless LAN adapter Local Area Connection* 9:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Microsoft Wi-Fi Direct Virtual Adapter
   Physical Address. . . . . . . . . : 02-14-2D-8A-11-17
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes

Wireless LAN adapter Wi-Fi:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Killer(R) Wireless-AC 1550 Wireless Network Adapter (9260NGW) 160MHz
   Physical Address. . . . . . . . . : 02-14-2D-8A-11-16
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes
   Link-local IPv6 Address . . . . . : fe80::2939:dd8a:472b:aa40%23(Preferred)
   IPv4 Address. . . . . . . . . . . : 172.20.20.20(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Lease Obtained. . . . . . . . . . : Thursday, December 10, 2020 3:33:37 AM
   Lease Expires . . . . . . . . . . : Thursday, December 10, 2020 6:45:21 AM
   Default Gateway . . . . . . . . . : 172.20.20.1
   DHCP Server . . . . . . . . . . . : 172.20.20.1
   DHCPv6 IAID . . . . . . . . . . . : 345550693
   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-26-75-80-98-8C-04-BA-A6-43-0B
   DNS Servers . . . . . . . . . . . : 1.1.1.1
                                       8.8.8.8
   NetBIOS over Tcpip. . . . . . . . : Enabled

Wireless LAN adapter Local Area Connection* 11:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Microsoft Wi-Fi Direct Virtual Adapter #2
   Physical Address. . . . . . . . . : 00-14-2D-8A-11-16
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
   Link-local IPv6 Address . . . . . : fe80::359b:3040:200f:778a%14(Preferred)
   IPv4 Address. . . . . . . . . . . : 192.168.5.1(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . :
   DHCPv6 IAID . . . . . . . . . . . : 848998245
   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-26-75-80-98-8C-04-BA-A6-43-0B
   DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1
                                       fec0:0:0:ffff::2%1
                                       fec0:0:0:ffff::3%1
   NetBIOS over Tcpip. . . . . . . . : Enabled

Ethernet adapter Bluetooth Network Connection:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Bluetooth Device (Personal Area Network)
   Physical Address. . . . . . . . . : 98-AF-65-2A-5E-AD
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes

This is with Pi disconnected. I connect to the Windows ethernet, which enables access to SSH and LuCI, but for some reason the wifi can no longer access internet when I connect ethernet.

Use gateway 172.20.20.1 , dns 1.1.1.1 and for address some unused IP in the range 172.20.20.2-254
Then connect the RPi to the router.

2 Likes

Yeah, I guess I wasn't being clear. There is no physical router for me to connect to. I'm on a neighborhood wifi hotspot. What I'm trying to do is install and configure travelmate so I can connect the pi to it.

It would be faster to enable internet connection sharing on Windows and connect the RPi on the ethernet adapter.

1 Like

Yeah, ICS used to work on this system. Once upon a time. Now anything that tries to connect via ICS never gets assigned an IP. I have no idea what the story is. I gave up on trying to figure it out weeks ago.