C2600: wifi sta mode works with 5G, but not with 2G

I've installed OpenWrt 22.03.2 r19803-9a599fee93 on an Archer C2600.

I try to define the WAN input via wifi (mode sta and protocol DHCP). This works with 5G, but not with 2G. The 2G radio has no other wifi-interface.

The only difference between the two wifi-interface definitions is the declaration of the radios.

I googled with the phrase 'c2600 sta mode', but found no helpful informations. There are some postings/problems, but they relate to mixed mode (sta & ap on the same radio).

Before I present more detailed informations, I would like to know, whether other users have problems with the sta mode and the C2600. In ap-only mode both radios (2G & 5G) of the C2600 work flawlessly.

So far no replies! Nobody any ideas?

I think, it's time to deliver some more information.

My goal is to establish a WAN connection for my C2600 via wifi.

For 5G wifi the relevant definitions in /etc/config/network are:

config interface 'wwan'
	option proto 'dhcp'

For 5G wifi the relevant definitions in /etc/config/wireless are:

config wifi-device 'radio0'
	option type 'mac80211'
	option path 'soc/1b500000.pci/pci0000:00/0000:00:00.0/0000:01:00.0'
	option channel '36'
	option band '5g'
	option cell_density '0'
	option htmode 'HT20'
	option country 'DE'

config wifi-iface 'wifinet12'
	option device 'radio0'
	option mode 'sta'
	option network 'wwan'
	option ssid 'H2O-LTEMOBIL-WLAN'
	option encryption 'psk2'
	option key 'Top-Secret'
	option ifname 'wtplink5'

With these definitions I can successfully establish a WAN connection via wifi 5G. Logread shows the following entries:

Tue Nov  8 18:39:45 2022 daemon.notice wpa_supplicant[1533]: wtplink5: SME: Trying to authenticate with XX:XX:XX:XX:XX:XX (SSID='H2O-LTEMOBIL-WLAN' freq=5180 MHz)
Tue Nov  8 18:39:45 2022 kern.info kernel: [72918.995989] wtplink5: authenticate with XX:XX:XX:XX:XX:XX
Tue Nov  8 18:39:46 2022 kern.info kernel: [72919.338196] wtplink5: send auth to XX:XX:XX:XX:XX:XX (try 1/3)
Tue Nov  8 18:39:46 2022 daemon.notice wpa_supplicant[1533]: wtplink5: Trying to associate with XX:XX:XX:XX:XX:XX (SSID='H2O-LTEMOBIL-WLAN' freq=5180 MHz)
Tue Nov  8 18:39:46 2022 kern.info kernel: [72919.347301] wtplink5: authenticated
Tue Nov  8 18:39:46 2022 kern.info kernel: [72919.359731] wtplink5: associate with XX:XX:XX:XX:XX:XX (try 1/3)
Tue Nov  8 18:39:46 2022 kern.info kernel: [72919.365873] wtplink5: RX AssocResp from XX:XX:XX:XX:XX:XX (capab=0x11 status=0 aid=2)
Tue Nov  8 18:39:46 2022 kern.info kernel: [72919.372577] wtplink5: associated
Tue Nov  8 18:39:46 2022 daemon.notice netifd: Network device 'wtplink5' link is up
Tue Nov  8 18:39:46 2022 daemon.notice wpa_supplicant[1533]: wtplink5: Associated with XX:XX:XX:XX:XX:XX
Tue Nov  8 18:39:46 2022 daemon.notice wpa_supplicant[1533]: wtplink5: CTRL-EVENT-SUBNET-STATUS-UPDATE status=0
Tue Nov  8 18:39:47 2022 daemon.notice wpa_supplicant[1533]: wtplink5: Unknown event 37
Tue Nov  8 18:39:47 2022 daemon.notice wpa_supplicant[1533]: wtplink5: WPA: Key negotiation completed with XX:XX:XX:XX:XX:XX [PTK=CCMP GTK=TKIP]
Tue Nov  8 18:39:47 2022 daemon.notice wpa_supplicant[1533]: wtplink5: CTRL-EVENT-CONNECTED - Connection to XX:XX:XX:XX:XX:XX completed [id=0 id_str=]
Tue Nov  8 18:39:51 2022 daemon.notice wpa_supplicant[1533]: wtplink5: Unknown event 37
Tue Nov  8 18:39:55 2022 user.notice WANIP: got lease for wtplink5: 192.168.73.244/24
Tue Nov  8 18:39:55 2022 user.notice firewall: Reloading firewall due to ifup of wwan (wtplink5)

For 2G wifi the relevant definitions in /etc/config/network are:

config interface 'wwan2'
	option proto 'dhcp'

For 2G wifi the relevant definitions in /etc/config/wireless are:

config wifi-device 'radio1'
	option type 'mac80211'
	option path 'soc/1b700000.pci/pci0001:00/0001:00:00.0/0001:01:00.0'
	option band '2g'
	option htmode 'HT20'
	option cell_density '0'
	option txpower '17'
	option country 'DE'
	option channel '11'

config wifi-iface 'wifinet9'
	option device 'radio1'
	option mode 'sta'
	option network 'wwan2'
	option ssid 'H2O-LTEMOBIL-WLAN'
	option encryption 'psk2'
	option key 'Top-Secret'
	option ifname 'wtplink2'

With these definitions I cannot successfully establish a WAN connection via wifi 2G. Logread shows the following entries:

Tue Nov  8 21:29:46 2022 daemon.notice netifd: Wireless device 'radio1' is now up
Tue Nov  8 21:29:46 2022 daemon.notice netifd: Interface 'wwan2' is enabled
Tue Nov  8 21:29:47 2022 daemon.notice wpa_supplicant[1538]: wtplink2: SME: Trying to authenticate with XX:XX:XX:XX:XX:XX (SSID='H2O-LTEMOBIL-WLAN' freq=2462 MHz)
Tue Nov  8 21:29:47 2022 kern.info kernel: [ 1412.281364] wtplink2: authenticate with XX:XX:XX:XX:XX:XX
Tue Nov  8 21:29:48 2022 kern.info kernel: [ 1412.613521] wtplink2: send auth to XX:XX:XX:XX:XX:XX (try 1/3)
Tue Nov  8 21:29:48 2022 kern.info kernel: [ 1413.015212] wtplink2: send auth to XX:XX:XX:XX:XX:XX (try 2/3)
Tue Nov  8 21:29:49 2022 kern.info kernel: [ 1414.022017] wtplink2: send auth to XX:XX:XX:XX:XX:XX (try 3/3)
Tue Nov  8 21:29:50 2022 kern.info kernel: [ 1415.050994] wtplink2: authentication with XX:XX:XX:XX:XX:XX timed out

The previous tests have been made with a TP-Link MR7350 (stock firmware) as AP to connect to. But the results are the same, when I replace the TP-Link with a Linksys WRT1900ACSv2 (OpenWRT).

My question: Is there anything wrong with my definitions? Did I miss anything?

I've installed OpenWrt 22.03.2 r19803-9a599fee93 on an Archer C7v5.

Using the same interface and wireless definitions as for the C2600 wifi sta mode works with 5G and 2G.

Has anybody an explanation for the different behaviour of the two devices (although they use the same definitions)?

Hi Barney,

Can you try to use the interface name "wan"? The firewall may block it.

config interface 'wan'
	option proto 'dhcp'
config wifi-device 'radio1'
	option type 'mac80211'
	option path 'soc/1b700000.pci/pci0001:00/0001:00:00.0/0001:01:00.0'
	option band '2g'
	option htmode 'HT20'
	option cell_density '0'
	option txpower '17'
	option country 'DE'
	option channel '11'

config wifi-iface 'wifinet9'
	option device 'radio1'
	option mode 'sta'
	option network 'wan'
	option ssid 'H2O-LTEMOBIL-WLAN'
	option encryption 'psk2'
	option key 'Top-Secret'
	option ifname 'wtplink2'

Thanks a lot for your reply.

I double-checked my definitions and concentrate on 2G wifi.

The interface definitions for C2600 and C7v5 looks like this:

config interface 'wlte2'
        option proto 'dhcp'

The wireless definitions for C2600 and C7v5 looks like this:

config wifi-device 'radio1'
        option type 'mac80211'
        option path 'soc/1b700000.pci/pci0001:00/0001:00:00.0/0001:01:00.0'
        option channel '1'
        option band '2g'
        option htmode 'HT20'
        option country 'DE'
        option cell_density '0'

config wifi-iface 'wifinet2'
        option device 'radio1'
        option mode 'sta'
        option network 'wlte2'
        option ssid 'H2O-LTEMOBIL-WLAN'
        option encryption 'psk2'
        option key 'TOP-SECRET'
        option ifname 'wlte2'

The only difference between the C2600 and the C7v5 wireless definition is the path option. Otherwise they are completely identical.

While the C7v5 sucessfully connects to the MR7350, the C2600 fails.

The log of the C2600 shows the following entries:

Nov 24 14:56:24 daemon.notice wpa_supplicant[1537]: wlte2: CTRL-EVENT-SSID-REENABLED id=0 ssid="H2O-LTEMOBIL-WLAN"
Nov 24 14:56:24 daemon.notice wpa_supplicant[1537]: wlte2: SME: Trying to authenticate with xx:xx:xx:xx:xx:xx (SSID='H2O-LTEMOBIL-WLAN' freq=2437
Nov 24 14:56:24 kern.info kernel: [ 4753.658648] wlte2: authenticate with xx:xx:xx:xx:xx:xx
Nov 24 14:56:24 kern.info kernel: [ 4753.667042] wlte2: send auth to xx:xx:xx:xx:xx:xx (try 1/3)
Nov 24 14:56:25 kern.info kernel: [ 4754.068702] wlte2: send auth to xx:xx:xx:xx:xx:xx (try 2/3)
Nov 24 14:56:25 kern.info kernel: [ 4754.470225] wlte2: send auth to xx:xx:xx:xx:xx:xx (try 3/3)
Nov 24 14:56:26 kern.info kernel: [ 4755.098937] wlte2: authentication with xx:xx:xx:xx:xx:xx timed out
Nov 24 14:56:26 daemon.notice wpa_supplicant[1537]: BSSID xx:xx:xx:xx:xx:xx ignore list count incremented to 3, ignoring for 60 seconds

The C2600 sends auth to the MR7350, but never gets an answer. Why? And why does the C7v5 suceeds with the same definitions? Does the C2600 need some special definitions for a successfull connect? Or is the C2600 not capable to operate in sta mode with 2G wifi?

I haven't read your post carefully. Yes, this is more WiFI issues. I have a few routers setup as wireless clients and I don't have this issue.

I have a whole bunch of OpenWRT supported devices (see my profile), but the C2600 is the first device, which does not work in sta mode with 2G wifi. :angry:

Heureka!

The OpenWRT repository contains four package sets for the C2600's Wifi:

  • kmod-ath10k
  • kmod-ath10k-ct
  • kmod-ath10k-ct-smallbuffers
  • kmod-ath10k-smallbuffers

The standard images use kmod-ath10k-ct. Today I had the idea to install kmod-ath10k: with this module I get a connect to an AP via STA mode.

But I'm cautious to call it success. I'm still testing with different APs, whether the connect is stable/reliable and speedy. I'll report back, when I finished my tests.

My success message was too early. :angry:

See my newly opened thread: look here