C2600 stuck on OpenWrt 19.07-SNAPSHOT, r10495-db5164d3d0, can't upgrade

I have a c2600 running OpenWrt 19.07-SNAPSHOT, r10495-db5164d3d0 and I just noticed that I can't upgrade to any of the release candidates. The upgrade process through both LuCi and the sysupgrade command lines seem to work, but when the router restarts, both LuCi and the shell MOTD report that the device is still running: OpenWrt 19.07-SNAPSHOT, r10495-db5164d3d0. Also uname confirms a kernel from early fall.

# uname -a
Linux c2600 4.14.141 #0 SMP Wed Sep 4 11:47:36 2019 armv7l GNU/Linux

Any idea on what's going on and the best way to fix it?

I had it once in the last time that the wifiservice could not be stopped and the update was therefore not started.
You can try to log in via lan over ssh and deactivate wifibefore you start sysupgrade.......

$ wifi down
$ sysupgrade ...
1 Like

Sysupgrade got broken in early September. And got fixed a few days after that.

You have the latest commit from September 4. Please check the following commits to see possible fixes. First fix on 6th, several smaller ones a few days later.


Looks like you would need to replace also procd, so it might be easier to use some tftp recovery, or similar, if possible.


Finally had a chance to do something about this.

TFTP upgrade doesn't work. Router downloads file, but nothing happens. It doesn't reboot, even after more than 5 minutes. If, after waiting, I power cycle, it boots into the snapshot version of 19.07 I'm trying to get away from. Same behavior if I try to restore the factory firmware.

Since I couldn't get a TFTP upgrade to work, I tried cherrypicking updates. I installed a new procd package using opkg, then installed updated files for sysupgrade and common.sh, stage2 & platform.sh from /lib/upgrade/. No luck.

Sysupgrade from the command line over ssh, even with -v, produces one message ("Image not in /tmp, copying...") and then quickly exits. With 'ps', I don't see anything happening in the background , either.

Any ideas about what to try next to get this on the current version of the firmware? If it comes to cracking the case I'll probably just buy a "new" device. I don't want to mess with pulling the flash chip, or getting a low-voltage serial interface working.


That should work as it has nothing to do with OpenWrt. It is pure oem functionality in bootloader, if it has been enabled. Tp-link devices are not quite easy on that front.

Read the device specific instructions from wiki (or OEM advice?)

Thanks for the advice.

That's what I thought. As I said, it does download a firmware file. It just never reboots. Could it be sensitive to something OpenWRT does? Does/can OpenWRT change the flash layout?

I guess I can try different versions of the factory firmware. I just tried the latest one.

No. (Or a specially tailored firmware could naturally overwrite anything, but the default images for a device maintain writeprotect for restricted areas.)

There is no real partition table. Bootloader has built-in knowledge about the expected structure.

The TFTP is built-in into the permanent bootloader that is not overwritten by OpenWrt, and should not be overwritten by OEM firmware either.

My guess is that something goes wrong with the OEM image. Try with a semiold OEM image, not the newest one.

(Tp-link has made it significantly more difficult than e.g

1 Like

Thanks for the advice. Unfortunately, flashing earlier OEM images didn't work either. As before, they are transferred, but the device never reboots, and when I power cycle it, it comes back up in the old snapshot version of 19.07.

I guess I have a zombie with increasingly out-of-date software. Anyone have suggestions for an economical replacement?

For hardware recommendations please open a new topic in the Hardware Questions and Recommendations
category of this forum.

Please state your usecase, your requirements and price limit when asking which device to buy.
This way you will get better recommendations and come to a quicker solution.

Have you tried 'resetting' under Backup / Flash Firmware >Flash operations >Restore > Perform reset (to reset the firmware to its initial state) to see if you can upgrade your snapshot after the reset?

Thanks. Yes. And unfortunately it hasn't worked.