Bypassing and removing CenturyLink Fiber Modem


#21

Ugg, you're sort of right. On the openwrt page, the openwrt boot logs only show eth0. The ddwrt boot logs show eth0 and eth1.

I ordered a WRT1900ACS. Its openwrt boot logs have both.


#22

Usually, ipq806x devices have two CPU ports - both connected to the same switch, one used for WAN, the other for LAN. The provided bootlogs in the OpenWrt wiki also show both interfaces (eth0 and eth1) being detected, although only one of them (eth0) actually gets configured, which is rather uncommon (maybe an oversight? obviously with the common setup you don't need to configure both CPU ports, although that is a better solution).


#23

I tried a WRT1900AC v1 running OpenWRT 18.06.2.

Here's IPv4 without the hardware NAT:
image

And IPv6 without the hardware NAT:
image

IPv4 with the hardware NAT:
image

The IPv6 results vary a lot. Here is one of the high results:
image


#24

Purchased a Linksys WRT32X and flashed OpenWRT on it today, verison OpenWrt 18.06.2 r7676-cddd7b4c77 / LuCI openwrt-18.06 branch (git-19.020.41695-6f6641d)

I am not able to get more than 500M up/down when connected to the router via ethernet. I have a GB connection to my home via Centurylink.

I am not sure where to start troubleshooting. Where is a good place to start?


#25

are you running SQM?


#26

Did you enable software flow offloading and hardware flow offloading?

Do two ethernet interfaces show up on WRT32X (eth0 and eth1)? Otherwise you'll probably only reach 1GB half duplex.

Centurylink gives slower IPv6 than IPv4. So it's probably easiest to keep the IPv6 disabled until you reach the expected speeds with IPv4.


#27

Test with PC connected directly to the modem.

My experience with the WRT32X is it could NAT at the Ethernet line speed (net 930 Mb or so) without turning on any offloading. The test was conducted with two PCs running iperf3.